Dependency error during install 0.9.2 using ubuntu ppa [auto fixed]

When trying to install kdenlive 0.9.2 on Ubuntu 12.04 a dependancy is unmet:

x@y:/$ sudo apt-get install kdenlive
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kdenlive : Depends: kdenlive-data (= 0.9.2-0ubuntu0~sunab~precise1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages

How can I resove this issue?
I already tried removing related packages and installing again.

Is it possible that the kdenlive-data package is build with the i386 build? At this moment only the x64 build is complete.

I can't install 0.9.2 under Ubuntu 11.10 using sunab ppa. (see the attachment...)
Is it the same problem of dependency ?
But I'm using a Oneiric 64 bit...

Issue is solved after the i386 build was complete.

Hi all,

You have to be patient with ppa builds. You updated your package list in the "middle" of the build process". This occurs only for x86_64 architecture as the kdenlive-data package is platform independent but it is built along with 32bits packages. And you have to know in Soyuz (the ppa build system) builds are not lauched synchronously but only in the order of queued packages.

Regards.

sunab.

Hi sunab,

After upgrading to Ubuntu 12.04 I got the "false error" at the end of the rendering of the video files, so after finding similar bug reports in the forum, I followed the instructions to fix it. I have tried to update to kdenlive 0.9.2 and mlt 0.8 from your ppa:sunab/kdenlive-release , but when making the partial upgrade, kdenlive is uninstalled and then not installed again. After that, if I try just to

# sudo apt-get install kdenlive

it says that it has unresolved dependencies: kdenlive depends on libmlt4 and it is going not to be installed.

It seems that it is trying to install kdenlive from standard ubuntu repository, not the one from sunab repository. Any clue about how can I fix this?

Thankssss

kdenlive:
Depends: kdenlive-data (=0.9.3+git20120701.53f9c1b9-0ubuntu0~sunab~precise1) but 0.9.2-0ubuntu0~sunab~precise2 is to be installed

Apparently the sunab repository has not updated yet. I cannot use the older version of kdenlive as the newer fri0r plugins cause it to crash...

netpet's picture

I have been using 0.9.2 and maybe even 0.9.3 using the http://ppa.launchpad.net/sunab/kdenlive-svn/ubuntu precise main
but now have problems because the late version was crashing if I tried to load and old project and even a jpg file
so tried to remove and reinstall - but I can't get anything to work

it says it have the following dependencies

Følgende pakker har uopfyldte afhængigheder:

kdenlive: Depends: libc6 (>= 2.14) men 2.15-0ubuntu10 vil blive installeret (says but 2.15-0ubuntu10 vil be installed)
Depends: libkdecore5 (>= 4:4.4.95) men 4:4.8.4a-0ubuntu0.2 vil blive installeret
Depends: libkdeui5 (>= 4:4.8.4) men 4:4.8.4a-0ubuntu0.2 vil blive installeret
Depends: libkio5 (>= 4:4.6.2-0ubuntu2) men 4:4.8.4a-0ubuntu0.2 vil blive installeret
Depends: libknewstuff3-4 (>= 4:4.4.0) men 4:4.8.4a-0ubuntu0.2 vil blive installeret
Depends: libknotifyconfig4 (>= 4:4.3.4) men 4:4.8.4a-0ubuntu0.2 vil blive installeret
Depends: libnepomuk4 (>= 4:4.5.85) men 4:4.8.4a-0ubuntu0.2 vil blive installeret
Depends: libqt4-dbus (>= 4:4.6) men 4:4.8.1-0ubuntu4.2 vil blive installeret
Depends: libqt4-opengl (>= 4:4.6) men 4:4.8.1-0ubuntu4.2 vil blive installeret
Depends: libqt4-script (>= 4:4.6.1) men 4:4.8.1-0ubuntu4.2 vil blive installeret
Depends: libqt4-svg (>= 4:4.6) men 4:4.8.1-0ubuntu4.2 vil blive installeret
Depends: libqt4-xml (>= 4:4.6) men 4:4.8.1-0ubuntu4.2 vil blive installeret
Depends: libqtcore4 (>= 4:4.8.0) men 4:4.8.1-0ubuntu4.2 vil blive installeret
Depends: libqtgui4 (>= 4:4.8.0) men 4:4.8.1-0ubuntu4.2 vil blive installeret
Depends: libsolid4 (>= 4:4.3.4) men 4:4.8.4a-0ubuntu0.2 vil blive installeret
Depends: libstdc++6 (>= 4.4.0) men 4.6.3-1ubuntu5 vil blive installeret
Depends: kdenlive-data (= 0.9.3+git20120917.07b893f8-0ubuntu0~sunab~precise1) men 0.9.3+git20120914.449d9625-0ubuntu0~sunab~precise1 vil blive installeret

But it does not install anything even if it says it will and if the latest kdenlive-svn was really broken - so I feel lost even a openshot can not be installed also
because of dependency problems - so sometimes I wich it would be easy to use previews installations or maybe i should use virtualbox to
make sure I always have a working installation but I really like to follow the development and I like the new features with audio align
and improved work flow on effect on the time-line etc.

I have just installed the latest sunab Kdenlive-svn+MLT (built 14 hrs ago) and all seems now to be working fine.

netpet's picture

Well now it was working again - the project I tried to load still crach but other projects work fine, this only that project - now I can add clip/jpg again :)

netpet's picture

Oh no - now again it's gone I can even do a

sudo apt-get update && sudo apt-get install kdenlive

says kdenlive : Afhængigheder: kdenlive-data (= 0.9.3+git20120917.07b893f8-0ubuntu0~sunab~precise1) men 0.9.3+git20120920.ab6c2634-0ubuntu0~sunab~precise1 forventes installeret

Translated depends on kdenlive-data (= 0.9.3+git20120917.07b893f8-0ubuntu0~sunab~precise1) but needs 0.9.3+git20120920.ab6c2634-0ubuntu0~sunab~precise1 to be installad
But does not show

Then I tried to remove 0.9.3+git20120920.ab6c2634-0ubuntu0~sunab~precise1 - so maybe I just have to wait again ;-)

I have been using 0.9.?.? for a while but I got ambitious and switched DE to KDE and an update removed kdenlive. I have spent about a day and a half trying to get it back. I was able to drop back to 0.88 but now I can't open the files I created with 0.9

ppa confusion:
sunab/kdenlive-stable
sunab/kdenlive-release
sunab/kdenlive-svn

the newest release seems to be in sunab/kdenlive-release but this install removes libmlt4 which breaks melt. Looks like new kdenlive needs libmlt5
but melt won't run unless is has libmlt4.

Finally I found this under
Testing the current development version - Development packages

with the following result:

$ sudo add-apt-repository ppa:sunab/kdenlive-svn && sudo apt-get update && sudo apt-get install kdenlive
You are about to add the following PPA to your system:
kdenlive-svn +MLT-git BEWARE! Testing only!
THIS PPA CONTAINS BLEEDING EDGE PACKAGES.

This package archive contains the latest development trees of Frei0r-plugins, MLT and Kdenlive.

The packages are daily built, use them to test those apps and please report any bug to upstream projects

NOTE : 2012/11/16 : packages are back.

NOTE : 2012/11/15 : All packages have been deleted but will come back soon.

NOTE : 2012/05/30 : OpenCV support for frei0r-plugins is disabled for Precise builds due to unresolved problem causing crashes in melt.

NOTE : 2012/05/14 : Translations are back (synced from l10n-kde4)

NOTE : 2011/11/11 : At this moment kdenlive builds are english only, this is not a bug [translations have moved away from kdenlive head with KDE.git migration, they are hosted now by the l10n-kde4 team]. Translations return is expected as soon as possible.
More info: https://launchpad.net/~sunab/+archive/kdenlive-svn
Press [ENTER] to continue or ctrl-c to cancel adding it

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.72KqSKjCuK --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv 6976C1CEB06586061C2C0472B5115B98AA836CA8
gpg: requesting key AA836CA8 from hkp server keyserver.ubuntu.com
gpg: key AA836CA8: "Launchpad PPA for C.A.B/sunab" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
Ign file: binary/ InRelease
Ign file: binary/ Release.gpg
Ign file: binary/ Release
Ign file: binary/ Translation-en_US
Ign file: binary/ Translation-en
Ign http://packages.linuxmint.com lisa InRelease
Get:1 http://packages.linuxmint.com lisa Release.gpg [197 B]
Get:2 http://packages.linuxmint.com lisa Release [17.7 kB]
Ign http://security.ubuntu.com oneiric-security InRelease
Ign http://archive.ubuntu.com oneiric InRelease
Ign http://archive.ubuntu.com oneiric-updates InRelease
Hit http://packages.medibuntu.org oneiric InRelease
Get:3 http://packages.linuxmint.com lisa/upstream Sources [10.3 kB]
Get:4 http://packages.linuxmint.com lisa/import Sources [1,190 B]
Get:5 http://security.ubuntu.com oneiric-security Release.gpg [198 B]
Hit http://archive.ubuntu.com oneiric Release.gpg
Get:6 http://packages.linuxmint.com lisa/backport Sources [20 B]
Get:7 http://packages.linuxmint.com lisa/romeo Sources [1,518 B]
Get:8 http://packages.linuxmint.com lisa/main Sources [14.3 kB]
Get:9 http://archive.ubuntu.com oneiric-updates Release.gpg [198 B]
Get:10 http://security.ubuntu.com oneiric-security Release [40.8 kB]
Get:11 http://packages.linuxmint.com lisa/upstream amd64 Packages [28.9 kB]
Hit http://archive.ubuntu.com oneiric Release
Get:12 http://packages.linuxmint.com lisa/import amd64 Packages [22.1 kB]
Get:13 http://packages.linuxmint.com lisa/backport amd64 Packages [20 B]
Get:14 http://archive.ubuntu.com oneiric-updates Release [40.8 kB]
Get:15 http://packages.linuxmint.com lisa/romeo amd64 Packages [20 B]
Get:16 http://packages.linuxmint.com lisa/main amd64 Packages [15.0 kB]
Get:17 http://packages.linuxmint.com lisa/upstream i386 Packages [28.4 kB]
Get:18 http://security.ubuntu.com oneiric-security/main amd64 Packages [238 kB]
Hit http://packages.medibuntu.org oneiric/free amd64 Packages
Get:19 http://packages.linuxmint.com lisa/import i386 Packages [22.0 kB]
Get:20 http://packages.linuxmint.com lisa/backport i386 Packages [20 B]
Get:21 http://packages.linuxmint.com lisa/romeo i386 Packages [20 B]
Get:22 http://packages.linuxmint.com lisa/main i386 Packages [15.0 kB]
Hit http://archive.ubuntu.com oneiric/main amd64 Packages
Hit http://archive.ubuntu.com oneiric/restricted amd64 Packages
Hit http://archive.ubuntu.com oneiric/universe amd64 Packages
Hit http://archive.ubuntu.com oneiric/multiverse amd64 Packages
Hit http://archive.ubuntu.com oneiric/main i386 Packages
Hit http://archive.ubuntu.com oneiric/restricted i386 Packages
Hit http://archive.ubuntu.com oneiric/universe i386 Packages
Hit http://archive.ubuntu.com oneiric/multiverse i386 Packages
Hit http://archive.ubuntu.com oneiric/main TranslationIndex
Hit http://archive.ubuntu.com oneiric/multiverse TranslationIndex
Hit http://packages.medibuntu.org oneiric/non-free amd64 Packages
Ign http://packages.linuxmint.com lisa/backport TranslationIndex
Ign http://packages.linuxmint.com lisa/import TranslationIndex
Ign http://packages.linuxmint.com lisa/main TranslationIndex
Ign http://packages.linuxmint.com lisa/romeo TranslationIndex
Ign http://packages.linuxmint.com lisa/upstream TranslationIndex
Hit http://archive.ubuntu.com oneiric/restricted TranslationIndex
Hit http://archive.ubuntu.com oneiric/universe TranslationIndex
Get:23 http://archive.ubuntu.com oneiric-updates/main amd64 Packages [430 kB]
Hit http://packages.medibuntu.org oneiric/free i386 Packages
Hit http://packages.medibuntu.org oneiric/non-free i386 Packages
Get:24 http://security.ubuntu.com oneiric-security/restricted amd64 Packages [3,995 B]
Get:25 http://security.ubuntu.com oneiric-security/universe amd64 Packages [64.8 kB]
Get:26 http://security.ubuntu.com oneiric-security/multiverse amd64 Packages [3,212 B]
Get:27 http://security.ubuntu.com oneiric-security/main i386 Packages [238 kB]
Ign http://packages.medibuntu.org oneiric/free TranslationIndex
Ign http://packages.linuxmint.com lisa/backport Translation-en_US
Ign http://packages.linuxmint.com lisa/backport Translation-en
Ign http://packages.linuxmint.com lisa/import Translation-en_US
Ign http://packages.linuxmint.com lisa/import Translation-en
Ign http://packages.linuxmint.com lisa/main Translation-en_US
Ign http://packages.linuxmint.com lisa/main Translation-en
Ign http://packages.linuxmint.com lisa/romeo Translation-en_US
Ign http://packages.linuxmint.com lisa/romeo Translation-en
Ign http://packages.linuxmint.com lisa/upstream Translation-en_US
Ign http://packages.medibuntu.org oneiric/non-free TranslationIndex
Ign http://packages.linuxmint.com lisa/upstream Translation-en
Get:28 http://security.ubuntu.com oneiric-security/restricted i386 Packages [4,062 B]
Get:29 http://security.ubuntu.com oneiric-security/universe i386 Packages [64.9 kB]
Get:30 http://archive.ubuntu.com oneiric-updates/restricted amd64 Packages [6,651 B]
Get:31 http://archive.ubuntu.com oneiric-updates/universe amd64 Packages [145 kB]
Get:32 http://security.ubuntu.com oneiric-security/multiverse i386 Packages [3,382 B]
Hit http://security.ubuntu.com oneiric-security/main TranslationIndex
Hit http://security.ubuntu.com oneiric-security/multiverse TranslationIndex
Hit http://security.ubuntu.com oneiric-security/restricted TranslationIndex
Hit http://security.ubuntu.com oneiric-security/universe TranslationIndex
Get:33 http://archive.ubuntu.com oneiric-updates/multiverse amd64 Packages [6,228 B]
Hit http://security.ubuntu.com oneiric-security/main Translation-en
Get:34 http://archive.ubuntu.com oneiric-updates/main i386 Packages [430 kB]
Hit http://security.ubuntu.com oneiric-security/multiverse Translation-en
Hit http://security.ubuntu.com oneiric-security/restricted Translation-en
Hit http://security.ubuntu.com oneiric-security/universe Translation-en
Get:35 http://archive.ubuntu.com oneiric-updates/restricted i386 Packages [6,645 B]
Get:36 http://archive.ubuntu.com oneiric-updates/universe i386 Packages [145 kB]
Get:37 http://archive.ubuntu.com oneiric-updates/multiverse i386 Packages [6,378 B]
Hit http://archive.ubuntu.com oneiric-updates/main TranslationIndex
Hit http://archive.ubuntu.com oneiric-updates/multiverse TranslationIndex
Hit http://archive.ubuntu.com oneiric-updates/restricted TranslationIndex
Hit http://archive.ubuntu.com oneiric-updates/universe TranslationIndex
Hit http://archive.ubuntu.com oneiric/main Translation-en
Hit http://archive.ubuntu.com oneiric/multiverse Translation-en
Hit http://archive.ubuntu.com oneiric/restricted Translation-en
Hit http://archive.ubuntu.com oneiric/universe Translation-en
Hit http://archive.ubuntu.com oneiric-updates/main Translation-en
Hit http://archive.ubuntu.com oneiric-updates/multiverse Translation-en
Hit http://archive.ubuntu.com oneiric-updates/restricted Translation-en
Hit http://archive.ubuntu.com oneiric-updates/universe Translation-en
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://archive.canonical.com oneiric InRelease
Hit http://archive.canonical.com oneiric Release.gpg
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Hit http://ppa.launchpad.net oneiric Release.gpg
Hit http://ppa.launchpad.net oneiric Release.gpg
Hit http://archive.canonical.com oneiric Release
Hit http://ppa.launchpad.net oneiric Release.gpg
Hit http://ppa.launchpad.net oneiric Release.gpg
Hit http://ppa.launchpad.net oneiric Release.gpg
Ign http://ppa.launchpad.net oneiric Release.gpg
Get:38 http://ppa.launchpad.net oneiric Release.gpg [316 B]
Hit http://archive.canonical.com oneiric/partner amd64 Packages
Hit http://ppa.launchpad.net oneiric Release.gpg
Hit http://ppa.launchpad.net oneiric Release
Hit http://archive.canonical.com oneiric/partner i386 Packages
Ign http://archive.canonical.com oneiric/partner TranslationIndex
Hit http://ppa.launchpad.net oneiric Release
Hit http://ppa.launchpad.net oneiric Release
Hit http://ppa.launchpad.net oneiric Release
Hit http://ppa.launchpad.net oneiric Release
Ign http://ppa.launchpad.net oneiric Release
Get:39 http://ppa.launchpad.net oneiric Release [9,776 B]
Hit http://ppa.launchpad.net oneiric Release
Hit http://ppa.launchpad.net oneiric/main Sources
Hit http://ppa.launchpad.net oneiric/main amd64 Packages
Hit http://ppa.launchpad.net oneiric/main i386 Packages
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Hit http://ppa.launchpad.net oneiric/main Sources
Hit http://ppa.launchpad.net oneiric/main amd64 Packages
Hit http://ppa.launchpad.net oneiric/main i386 Packages
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Hit http://ppa.launchpad.net oneiric/main Sources
Hit http://ppa.launchpad.net oneiric/main amd64 Packages
Hit http://ppa.launchpad.net oneiric/main i386 Packages
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Hit http://ppa.launchpad.net oneiric/main Sources
Hit http://ppa.launchpad.net oneiric/main amd64 Packages
Hit http://ppa.launchpad.net oneiric/main i386 Packages
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Hit http://ppa.launchpad.net oneiric/main Sources
Hit http://ppa.launchpad.net oneiric/main amd64 Packages
Hit http://ppa.launchpad.net oneiric/main i386 Packages
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Get:40 http://ppa.launchpad.net oneiric/main Sources [1,665 B]
Get:41 http://ppa.launchpad.net oneiric/main amd64 Packages [3,904 B]
Get:42 http://ppa.launchpad.net oneiric/main i386 Packages [3,908 B]
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Hit http://ppa.launchpad.net oneiric/main Sources
Hit http://ppa.launchpad.net oneiric/main amd64 Packages
Hit http://ppa.launchpad.net oneiric/main i386 Packages
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Ign http://packages.medibuntu.org oneiric/free Translation-en_US
Ign http://archive.canonical.com oneiric/partner Translation-en_US
Ign http://packages.medibuntu.org oneiric/free Translation-en
Ign http://archive.canonical.com oneiric/partner Translation-en
Ign http://packages.medibuntu.org oneiric/non-free Translation-en_US
Ign http://packages.medibuntu.org oneiric/non-free Translation-en
Err http://ppa.launchpad.net oneiric/main Sources
404 Not Found
Err http://ppa.launchpad.net oneiric/main amd64 Packages
404 Not Found
Err http://ppa.launchpad.net oneiric/main i386 Packages
404 Not Found
Ign http://ppa.launchpad.net oneiric/main Translation-en_US
Ign http://ppa.launchpad.net oneiric/main Translation-en
Ign http://ppa.launchpad.net oneiric/main Translation-en_US
Ign http://ppa.launchpad.net oneiric/main Translation-en
Ign http://ppa.launchpad.net oneiric/main Translation-en_US
Ign http://ppa.launchpad.net oneiric/main Translation-en
Ign http://ppa.launchpad.net oneiric/main Translation-en_US
Ign http://ppa.launchpad.net oneiric/main Translation-en
Ign http://ppa.launchpad.net oneiric/main Translation-en_US
Ign http://ppa.launchpad.net oneiric/main Translation-en
Ign http://ppa.launchpad.net oneiric/main Translation-en_US
Ign http://ppa.launchpad.net oneiric/main Translation-en
Ign http://ppa.launchpad.net oneiric/main Translation-en_US
Ign http://ppa.launchpad.net oneiric/main Translation-en
Ign http://ppa.launchpad.net oneiric/main Translation-en_US
Ign http://ppa.launchpad.net oneiric/main Translation-en
Fetched 2,075 kB in 9s (230 kB/s)
W: Failed to fetch http://ppa.launchpad.net/sunab/kdenlive-stable/ubuntu/dists/oneiric/main... 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/sunab/kdenlive-stable/ubuntu/dists/oneiric/main... 404 Not Found

W: Failed to fetch http://ppa.launchpad.net/sunab/kdenlive-stable/ubuntu/dists/oneiric/main... 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

I pretty new to Linux so I'm kinda confused.

amd64 - Mint12 - KDE

Pages