Title Clip and Screen tint?

Hello guys,

I am having a question. Actually I'd almost consider this a bug but I am just not sure wether I am just doing something wrong. I am faily often using Title clips to add in text over my videos. So I create these Title Clips with whatever text I want, select a transparent background and put it in with a default-set composite effect.
Now wehenever I did that I had the feeling that something changed on the whole image. But even after rendering and looking to the video frame-by-frame I could not put my finger on it.

Recently I did a video where I - for comedic effect - added in $-chars all over the image over time. At the end of this sequence I had 8 title clips all over each other. Each composite effect was aligned to the video track. Now if I'd add in a new title clip and composite effect set to the track of the previous title track, each new title clip text would get more and more transparent itself. Yet another weird side-effect I don't know what to do with.

So I ended up having all 8 title clips with their composite effects set to my video.

And that resulted in an extreme green tint of the whole video - in the preview monitor and after rendering itself.

See the example here:
Before (no title clips): http://www.8bit-memories.com/tmp/before.jpg
After (8 title clips): http://www.8bit-memories.com/tmp/after.jpg

Now the fewer title clips I sue, the less "tint" there is on the screen - with one title clip it's really not to notice. Also I am not sure if the text color itself does actually influence the tint color of the whole screen. I assume so however.

I'm using kdenlive 0.9.2 and mlt 0.8.2.

A while back another user made a similar complaint. see http://www.kdenlive.org/mantis/view.php?id=2759
You should perhaps add your findings to that mantis bug.

As a workaround you could have all the $ signs in the one title rather than compositing them over the top of each other. You can put many text boxes in the one title. And you can use one title as the starting point for a second title. See http://userbase.kde.org/Kdenlive/Manual/Titles#FAQ

Okay I responded to the bug report and added my own video there.

I wasn't aware I could duplicate titles so easily. This'll definately help. Still since a slight tint is already visible with even one title CLip present I hope this'll get fixed soon.

Pages