Cannot import SVG clips (anymore)

I've opened an old project with some SVG clips, in order to apply some change.

All the SVG clips I used, and that I can open with Inkscape, are no more accepted by kdenlive.
Something like: "the clip is not usable, it will be removed from project."

I've tried to save to different SVG version with inkscape, but still nothing.
With previous versions of kdenlive I used them!

To reproduce: just open a new project and add a clip:
http://dl.dropbox.com/u/7540375/balli.svg

hi dinolib, the svg works for me. Ubuntu 12.10 64bit. Kdenlive from sunabs 'Unstable' git PPA.

Check your MLT version by clicking on the menu: Settings-->Run Config Wizard. Click on the next button. The 2nd screen should show your version. With KDEnlive 0.9.2 your MLT version needs to be at 0.8.2. (if you have 0.8.6, you'll need to downgrade)

B.

Thank you for your suggestions, but atm I've no luck.

OS: Linux 3.5.6-1-CHAKRA #1 SMP PREEMPT Mon Oct 8 16:00:22 UTC 2012 x86_64 GNU/Linux

kde: 4.9.3

kdenlive: 0.9.2 (program menu)

melt: 0.8.2 (command line)

mlt: 0.8.2 (program wizard)

The SVGs are rejected without output in command line, just the popup.

OK, solved with workaround:

it seems that for SVG files kdenlive cannot handle path with special keys: "à","è","ì","ò","ù" (I don't know if others also).
Changing the project path solved my problem.

All other project files are read fine.

Could you open a bug report, or is it already known?

thankyou

You should open your own bug report since you know the details of the issue

dinolib - thanks for reporting the bug. Many bugs do get fixed. Watch the Commits section on the LHS of the page to see what is getting fixed.

Pages