Ensuring a Working Installation

My systems run straight Debian, using an unholy combination of 'testing', 'unstable', and 'deb-multimedia'. After updating my laptop's copy of ffmpeg to v1.0, I noticed that kdenlive stopped being able to import certain clips. Checking ffmpeg's man page, I discovered that they've significantly re-worked the command line argument syntax, so it doesn't surprise me that it doesn't work.

However, now it's made me paranoid about updating any media component in my system. My desktop installation of kdenlive is still working, but there are updates to ffmpeg and MLT that are begging to be pulled over.

My current install is:

Kdenlive: 0.9.2
ffmpeg: 0.11.2
MLT: 0.8.2

There is an update for ffmpeg 1.0.1 available, but I know not to take that (yet). However, there is also an update for MLT 0.8.6 available; is it safe to take that? And when will it be safe to take ffmpeg 1.0?

I use openSUSE 12.2

kdenlive 0.9.2
mlt 0.8.6
ffmpeg 1.0.1

I usually work with dv material and have no problems.
What is 'certain clips'?

I don't seem to be able to reproduce the issue anymore. I successfully compiled a new video last week with ffmpeg 1.0.1 installed. So, hrm...

Hasn't MLT just moved to ffmpeg 1.whatever recently, so maybe you have compatibility at the moment, but running with 'a unholy mix of ' libraries from different repos there is more risk of incompatibilty to cause problems with MLT or kdenlive.

Why not downloading the latest git versions (ffmpeg, melt, kdenlive, x264, ...) and compile it by yourself?
It's not that difficult - just use the download script from the mlt-framework site.

http://github.com/mltframework/mlt-scripts/raw/master/build/build-kdenli...

For the first time you might need to take care to have a proper toolchain - but if you have spent that effort -
you will always have the latest version with the best use of your hardware!

Pages