[solved] Perte de projet lors du passage à 0.9.4 (résolu)

Bonjour,

suite à la mise à jour de kdenlive vers la version 0.9.4, un projet de longue haleine (montage film de mariage) ne veut plus s'ouvrir, avec pour message "unexpected character".

Lorsque j'ouvre un fichier de backup enregistré en version 0.9.2, il s'ouvre et se convertit au format 0.9.4. Après enregistrement, le fichier nouvellement créé ne s'ouvre plus, avec la même erreur. Suis-je le seul dans ce cas ? Y-aurait-il une solution de contournement ? J'ai commencé ce projet depuis très (trop) longtemps pour tout perdre, je suis excédé par cette erreur de *%!:, j'ai fait un diff sur les 2 fichiers (celui que je peux ouvrir et celui transformé), il n'y a pas tant de différences que ça, et pas de caractère spécial, principalement des propriétés "loop" à 1 sur mes clips...

Merci d'avance des éventuels coups de main.

Pouvez-vous m'envoyer le fichier .kdenlive qui ne s'ouvre pas afin que je puisse analyser le problème? ( jb at kdenlive org )

Ok, j'ai bien reçu le fichier. Le bug responsable a déjà été corrigé:
http://kdenlive.org/mantis/view.php?id=2976

Comme dépanage, sur Ubuntu il est possible d'utiliser le PPA experimental de Sunab qui contient une version de Kdenlive avec le correctif pour ce bug:
https://launchpad.net/~sunab/+archive/kdenlive-svn

Avec cette version, il est possible d'ouvrir le fichier créé par Kdenlive 0.9.2 et de travailler dessus sans corrompre le projet.

Sinon, je vais de toute façon sortir une nouvelle version de Kdenlive avec les correctifs pour les récents bugs annoncés d'ici maximum une semaine.

Salutations

OK, merci.
Je tenterai la mise à jour dès demain et vous tiendrai au courant.

Merci beaucoup, je ne me voyais pas recommencer tout ce montage depuis le début !

Edit: Après mise à jour, le problème a disparu. L'ouverture d'un projet préalablement importé (et donc corrompu) indique clairement l'endroit où il y a un caractère non supporté. En repartant d'une sauvegarde, pas de problème cette fois je peux sauver et reprendre mon travail.

Mille mercis !

Cool de voir que tu n'as pas tout perdu ton travail et que ce bug est corrigé.

Je suppose une histoire de caractères accentués ? j'ai eu des mésaventures (maintenant corrigé) avec ceux ci lors d'archivages/restauration de projet.

Sinon, pourrais tu modifier le titre initial du sujet pour y ajouter "résolu" ? une formalité bien pratique pour les lecteurs suivants.

Salutations et
Bon montage(s) libre

Bonjour

J'ai le même problème que RomJ : Le travail de tout un groupe (je suis animateur en cinéma amùateur) n'a pas pu être valorisé en fin de séjour par l'impossibilité d'ouvrir les fichier .kdenlive créés, autant par moi que par la sauvegarde automatique (même message d'alerte que RomJ, même recherche de solution, même impasse). Et aujourd'hui, leur travail est entre mes mains, et je sèche, malgrés mon utilisation professionnelle quotidienne de Kdenlive depuis plus de 2 ans... Et donc, il semble que ce problème ne soit pas résolu pour tous les cas de figure, car même avec la version 0.9.5 du PPA expérimental de Sunab, les fichiers ne s'ouvrent pas. Je me permet donc de vous envoyer un de ces fameux fichiers, comme vous l'avez demandé à RomJ. Pouvez-vous y jeter un coup d'oeil ?
Merci d'avance !

Pages