Rendu qui se bloque (sans raison apparente, pas d'erreur) (résolu)

Bonjour,

suite à mon problème avec la mise à jour de kdenlive (depuis résolu grâce à j-b-m, merci !), j'ai pu continuer et presque achever mon montage. Je voulais donc générer un rendu "prototype" pour voir ce qu'il reste à retoucher / couper.

C'est là qu'arrive le problème: Le rendu se bloque au bout d'un moment, comme s'il se mettait en pause, et n'avance plus; ceci arrive toujours au même endroit. Que je passe par un rendu direct ou par un script le résultat est le même. J'ai tenté de lancer le script de rendu en ligne de commande, pour voir s'il y avait un message d'erreur; que neni.
Je me tourne donc vers vous avec quelques questions: où consulter les logs de Melt, éventuellement comment les activer si ce n'est pas le cas par défaut ? Comment fait kdenlive pour avoir un retour sur le temps restant, et serait-il possible de savoir à quelle frame le problème se produit ? (en gros s'il y a un moyen de connaitre la frame en cours de traitement, je pourrai voir à quelle frame le rendu se bloque).

Eventuellement, quelqu'un saurait peut-être si un effet est connu pour avoir ce genre d'effet secondaire ?

Merci.

Et sinon, petite remarque qui n'a rien à voir, mais une évolution qui pourrait être sympa pour le forum: la possibilité de recevoir un mail quand quelqu'un poste sur un fil auquel on est abonné; en effet lors de mon dernier message, je n'avais pas mis le sujet à "résolu", et un utilisateur me l'a fait remarquer; sauf que comme mon problème était résolu, je viens seulement de voir son message... Après, si ce n'est pas possible, pas grave.

Pour y voir plus clair, il est possible de faire un rendu directement avec MLT, ça peut donner plus s'infos. Depuis un terminal:

melt monprojet.kdenlive -consumer avformat:test.mp4

Cette commande fera un rendu du projet "monprojet.kdenlive" dans un fichier vidéo appelé "test.mp4". Pendant le rendu, MLT affiche le numéro de frame en cours de rendu.

Concernant les notifications email de commentaires, très bonne idée. Je viens d'installer le module. Depuis les réglages du compte, il faut activer l'option "Comment notification". A tester...

Merci, j'ai lancé un rendu avec cette commande, qui a planté mais qui me donne la raison et le numéro de trame.
Voici la justification du plantage:
"overflow in spectral RLE ignoring swscaler 720x576 -> 6x6 is invalid scaling dimension"

Je pense que j'ai du faire une mauvaise manip sur un redimensionnement; pour l'instant mon PC est en rade donc je creuserai dans cette voie après réparation. En attendant je considère mon problème comme résolu car je ne suis plus bloqué. Merci.

...PC réparé, mais ce n'est pas la fin des ennuis pour autant.

Je tente de m'en dépatouiller tout seul puis je viendrai enrichir ce fil avec ce que j'aurai trouvé, si ça peut servir à d'autres, ou lever des bugs...

En tout cas l'erreur levée précédemment n'est pas celle qui faisait planter mon rendu jusqu'ici, puisqu'elle a lieu sur la dernière image du film (image qui n'a pas de scaler, peut-être un bug ?).

Problème résolu: Le rendu plantait à cause du format H264. En choisissant MPEG4, j'ai pu enfin effectuer un rendu complet !

Pages