[SOLVED] Can't import .mov to my project : clip is missing

Hello,

I use Kdenlive 0.9.2 on Debian testing 64bits.

When I want to import .mov video in my project, Kdenlive tell me « Clip is missing and will be erased from the project». These .mov file exist and works on VLC. This issue happen only with video importation, while playing sounds and photos works.

I runned Kdenlive from a terminal and I get this output : http://pastebin.com/JbjW6fgv

PS : Sorry for my English.

Thanks!

What does VLC tell you about the file, for example codec?

Thanks for your answer,

VLC tell me :

Codec : H264 - MPEG-4 AVC (part 10) (avc1)

Videos are shooted with an EOS 550D.

Hi, I have the very same camera and kdenlive has no problems with these files, so how did you install kdenlive? There must be some incompatibility between your kdenlive, MLT and ffmpeg libraries. What MLT and ffmpeg versions do you have?

choot@ricola:~$ dpkg -l | grep mlt
ii libmlt++3 0.8.0-4 amd64 MLT multimedia framework C++ wrapper (runtime)
ii libmlt-data 1:0.8.8-dmo1 all multimedia framework (data)
ii libmlt5 0.8.0-4 amd64 multimedia framework (runtime)

choot@ricola:~$ dpkg -l | grep ffmpeg
ii ffmpeg 6:0.8.5-1 amd64 Multimedia player, server, encoder and transcoder (transitional package)
ii gstreamer0.10-ffmpeg 1:0.10.13-dmo1 amd64 FFmpeg plugin for GStreamer
ii winff 1.4.2-3 amd64 graphical video and audio batch converter using ffmpeg

I've installed Kdenlive from Deb-Multimedia repository.

You probably should upgrade Kdenlive and melt by the look of this. Lots of bug fixes in kdenlive and melt since your versions. Melt is now 0.8.8, Kdenlive is 0.9.4

Might help but I've been importing Canon 550D DSLR video for the last 2 years into kdenlive without issue, so I'd look to incompatibility with ffmpeg / libav libraries you have installed, any that you may have built manually or installed from other repositories.

Hi,

Can I retrograde or upgrade ffmpeg or libav libraries to avoid this conflict without new potential issue?

Also I think this solution is temporary because at every update of my Debian (which is containing one of this package) I will be forced to make this hack again.

Have you an other idea?

Regards

I'm not familiar with Debian, can you use PPA's? if so perhaps drop kdenlive and MLT from deb multimedia and just keep current ffmpeg libav and get kdenlive and MLT from sunabs kdenlive PPA?

Sorry can't be much help, I've never had much success or experience with Debian.

Hi,

You can mix PPA with Debian but honnestly it sounds like a bad idea as much as I know :/.

I'll check the release from sunabs PPA tomorrow and see if I can get the same version or, with any other way, compile desired kdenlive.

Thanks

Hi,

I've solved this problem.

I've checked the version on deb-multimedia, 0.9.4, on sunab PPA it's the same. On the laptop it was the 0.9.2, so I've make an update and kdenlive was still in 0.9.2... Weird...

I reinstalled it and kdenlive is now in 0.9.4 and every things works !

Thanks for your help, it was helping to solve that.

I'll send an email to deb-multimedia to ask why I wasn't able to update kdenlive without reinstalling it.

Hey, good to hear that, have fun. :-)

Pages