[solved]Kdenlive 0.8 dependency conflicts in Synaptic (libmlt4)

I'm trying to update MLT to libmlt4, but now I can't install kdenlive 0.8 in synaptic because it says the kdenlive package depends on libmlt3.

How can I update MLT and Kdenlive at the same time without installing them both from source?

Please help...this is an emergency for me right now. Thanks.

I can't install kdenlive 0.8 because I installed libmlt4. In synaptic, kdenlive 0.8 wants to install libmlt++3 which can't be installed since libmlt4 is installed. At the same time, kdenlive 0.8 requires libmlt4 to be installed.

Am I doing something wrong?

You have to use the recommended ppa:sunab/kdenlive-stable

disable all others ppa sources

and update with this command :

sudo apt-get update && sudo apt-get dist-upgrade

If it doesn't work you have something wrong on your system, and it will be recommended to clean manually removing

libmlt-data libmlt3 libmlt4 melt python-mlt3 python-mlt4 kdenlive kdenlive-data

Thanks sunab, that worked perfectly.

I am all of a sudden having issues encoding aac audio within the x264 profiles. Not sure what happened as I didn't think I changed anything. I am running 10.04 with medibuntu repo (for ffmpeg and extra libs) and sunab's ppa he listed above. If you need further info such that you can help me figure this out I can post whatever info you need. Any help would be greatly appreciated.

Thanks alot from Russia, sunab! That's work for me as well! I had such problems with libmlt3 and libmlt5

Pages