kdenlive menu disappeared(version is 0.9.6)

hello everyone,

My kdenlive encountered a problem, version is 0.9.6. The menu disappeared, anyone know how to restore it?

Thanks so much.

So you have no menu items at all ? Or are you missing windows that you used to have.

Yes, the menu, I attached the snapshot for you. I am not sure why it disappear, after my first installation, it was there.

Are you using Ubuntu with Unity? Then the menu bar is moved from the application window to this system bar on the top of the screen, and hidden unless you go there with the mouse cursor - a bit like on a Mac.

No, I don't use Unity. At first I use version 0.8.2, the menu was there after first installation, but disappeared and I don't know why. Then I totally remove kdenlive including its config files(not sure if removed all the config files), and install the latest version 0.9.6, sadly, the menu still not play with me.

Okay sorry, I didn't want to imply that you don't know what you are doing.
It's just that the window decoration or actually the whole kdenlive window in your screenshot looks exactly like when I start it in Unity - and there's no menu bar either, so I think it looks kinda normal.

What distro are you using?

Thanks Dode. I'm using Ubuntu 12.04. Do you know any config file will change this?

Hmm. Isn't the close window buttons on the left hand side of the window a unity desktop thing? luckyyang - could some update given you unity without your knowledge?

Ubuntu comes with Unity by default since 12.x I think. So did you switch to another desktop (KDE, Gnome Shell, ?) by installing a desktop package? In that case, normally Unity is removed I think but maybe there are some Unity packages left that cause strange behaviour.

@ttguy and @dode:

I am not using Unity, I fell back to Gnome classical. I don't think Unity had been removed, I just switch the desktop environment by hand. Maybe some strange behaviour happened like this, but how to debug? Back to Unity and see what will happen?

I try to back to Unity and the menu appears again, so strange.

Maybe you have to remove some packages related to Unity that cause this behaviour when using Gnome.
On kubuntu for example, I have "thunderbird-globalmenu" installed, which is "Unity appmenu integration for Thunderbird", which doesn't make sense with KDE. Maybe there is some kind of "globalmenu" package for KDE apps that breaks your KDE menubars under Gnome? Did you try with other KDE apps like kwrite or so if they also lose their menubar?

Thanks dode. I decide to use Unity back again, it also resolved the "composite effect" problem which annoyed me for several days. So maybe Unity is my best choice, debug this is really a heart broken thing. :)

I got rid of the unity look and feel by following this http://ubuntuforums.org/showthread.php?t=1886799 thread. (for Oneiric/11.10). I am now on 12.04 precise and I think my tweaks were kept when I upgraded.

This thread describes how to do it for 12.04 precise http://ubuntuforums.org/showthread.php?t=1966370

I hate unity interface.
And BTW I do have the menus appear in Kdenlive.

Thanks ttguy! I added the links to my browser's bookmark.

Pages