invalid clip, will be removed [SOLVED]

First off, I really like this program, and was starting to enjoy using the 7.1 release.

The 7.2 release doesn't like me...

On attempting to add a title clip, avi, or slideshow clip, the following message alert: displays

Clip /home/<username>/kdenlive/titles/title<num>.png is invalid, will be removed from project

And the clip is not saved in the project tree.  The file is saved in the designated folder, but is deemed invalid, and cannot be loaded.
 
When attempting to do same after launching kdenlive in a term, terminal shows:
 
kdenlive(12723) ProjectList::slotAddClip: Adding clip with groupid:  ""
kdenlive(12723) Render::getFileProperties:  / / / / / / / /ERRROR / / / / // CANNOT LOAD PRODUCER:
 
Same error, (basically), for any avi clip
Same error for slideshow clip
color clips are ok
latest Sid Debian package installed
Attempted kdenlive downgrade to 7.1, (previously working), did not solve.
versions:
FFmpeg version SVN-r16844 (Debian Sid)
MLT version 3.6-0.0 0 (Debian Sid)
kdenlive version 7.2.1
KDE version (do not have metapackage installed)
using kdelibs 3.5.10.dfsg.1.01enny on one machine
using kdelibs 3.5.10.1-1 sid on other
 

Sorry if this has been answered previously.  I did search for 'removed from project' and 'cannot load producer'

Hallo, I have the same error, have Debian Lenny, kdenlive 7.2.1. Upgrade am 4.2. The Kdenlive package 7.2.1 remove automaticly package inigo.

Don't know if inigo is relevant.  I never had it installed.

aptitude install inigo warns both mlt and kdenlive will be removed

 

I'm currently doing a fresh install of Debian Lenny, and plan to upgrade it to Sid, w KDE4

will report results

Just tested fresh install.

Debian Sid (amd64)

Installed w64codecs, then kdenlive 7.2 from Sid

Same error on attempting to create title clip

Currently upgrading to KDE4, from Debian experimental

 

If this fails, I may do a complete re-install, and try an older kdenlive version from archives

In the meantime, if anyone has any suggestions/ideas, or can tell me what to look for/what I'm missing/doing wrong, I'd greatly appreciate it

 

Same error following upgrade to full KDE4 from Debian experimental

Next I'll try compiling from source, following instructions outlined here

 

btw, I note inigo is included in mlt, and that the 'producer' error is likely related to mlt

Is it possible kdenlive installed from the package is unable to locate the mlt libraries or binary?

Or is this some weird permissions problem?

 

Any help?

I have the same problem.

The problem afflicts the kdenlive live cd too ('cause it's a debian-live cd).

No truble with Ubuntu version, but it hasn't some nice effects (like dust and old film)

Today's full-upgrade included an updated version of MLT, which appears to have resolved the issue.

I don't have time for a full test right now, but will do so this evening and report results

What's the version of MLT after the upgrade ? Where's the package from (which repository / dist) ?

How about the versions of packages MTL depends on ?

Could you please provide some information ?

Thanks,

Toby

 

 

for me too. I'm using kdenlive from debian-multimedia but on Ubuntu.

 

aptitude show mlt | grep Depends
Depends: libc6 (>= 2.7-1), libmlt1 (>= 1:0.3.6), ffmpeg

apt-cache policy mlt
mlt:
  Installed: 1:0.3.6-0.1
  Candidate: 1:0.3.6-0.1
  Version table:
 *** 1:0.3.6-0.1 0
        500 http://www.debian-multimedia.org sid/main Packages
        100 /var/lib/dpkg/status
     1:0.3.0-0.1 0
        500 http://www.debian-multimedia.org testing/main Packages

apt-cache policy libmlt1
libmlt1:
  Installed: 1:0.3.6-0.1
  Candidate: 1:0.3.6-0.1
  Version table:
 *** 1:0.3.6-0.1 0
        500 http://www.debian-multimedia.org sid/main Packages
        100 /var/lib/dpkg/status
     1:0.3.0-0.1 0
        500 http://www.debian-multimedia.org testing/main Packages
     0.3.2-2 0
        500 http://ftp.uk.debian.org sid/main Packages

apt-cache policy libc6
libc6:
  Installed: 2.7-18
  Candidate: 2.7-18
  Version table:
     2.9-0exp2 0
          1 http://ftp.uk.debian.org experimental/main Packages
 *** 2.7-18 0
        500 http://ftp.uk.debian.org lenny/main Packages
        500 http://ftp.uk.debian.org sid/main Packages
        100 /var/lib/dpkg/status
     2.3.6.ds1-13etch8 0
        500 http://ftp.uk.debian.org etch/main Packages

apt-cache policy ffmpeg
ffmpeg:
  Installed: 3:20090128-0.0
  Candidate: 3:20090128-0.0
  Version table:
 *** 3:20090128-0.0 0
        500 http://www.debian-multimedia.org sid/main Packages
        100 /var/lib/dpkg/status
     3:20080706-0.3 0
        500 http://www.debian-multimedia.org testing/main Packages
     3:0.svn20090204-2 0
          1 http://ftp.uk.debian.org experimental/main Packages
     0.svn20080206-16 0
        500 http://ftp.uk.debian.org lenny/main Packages
        500 http://ftp.uk.debian.org sid/main Packages
     0.cvs20060823-8 0
        500 http://ftp.uk.debian.org etch/main Packages

 

Hope that helps.

 

On rare occasions, I've used 'buntu packages on my Debian boxes, but I've been warned to mix and match dists and sources can lead to problems.

 

I can confirm that the latest version 0.3.6-0.1 of libmlt1 is required for kdenlive 0.7.2.1.

Now everything's  working fine

 

The problem still persist in kdenlive.x86_64 0:0.9.6-1.fc18
Can not load any clip regardless of format (avi, mpg4, etc)
Simply the program does not work.

Installed Progs:
kdenlive.x86_64 0:0.9.6-1.fc18
ffmpeg-1.0.7-1.fc18.x86_64
ffmpeg-devel.x86_64 0:1.0.7-1.fc18
xvidcore-1.3.2-3.fc17.x86_64

Pages