Feedback about Kdenlive for Mac OS X

Please make your feedback here:

Looking at this screenshot, I am asking myself wether the monitor can be displayed or not?

I am sorry. I do not understand the question. The screenshot is encouraging.
I have reorganized the hard disk partitions and made much more space on my MacBook Pro, and I plan to take a look at kdenlive on OS X.

Installation is failing when installing from macport. I am new to terminal commands and macports. I'm running OS X on 10.4. Any help would be very appreciated. Here's the error I get...

Error: The following dependencies failed to build: automoc cmake qt4-kde dbus autoconf help2man gettext expat libiconv gperf ncurses ncursesw p5-locale-gettext perl5 perl5.8 m4 automake libtool pkgconfig jpeg libmng lcms tiff zlib libpng mysql5 openssl readline postgresql83 bison libxml2 libxslt ossp-uuid sqlite3 unixODBC cdrtools smake dvdauthor ImageMagick bzip2 fontconfig freetype xorg-libXext xorg-libX11 xorg-bigreqsproto xorg-inputproto xorg-kbproto xorg-libXau xorg-xproto xorg-libXdmcp xorg-xcmiscproto xorg-xextproto xorg-xf86bigfontproto xorg-xtrans xorg-libXt xorg-libsm xorg-libice xorg-util-macros libdvdread libdvdcss kdelibs4 aspell texinfo lzmautils aspell-dict-en cyrus-sasl2 doxygen coreutils gmp graphviz gd2 xpm pango Xft2 xrender xorg-renderproto cairo libpixman glib2 urw-fonts xorg-libXaw xorg-libXmu enchant hunspell flex giflib jasper libart_lgpl libidn openexr ilmbase pcre phonon shared-mime-info intltool gnome-common p5-xml-parser soprano clucene redland curl db46 raptor rasqal strigi mlt atk gtk-doc docbook-xml-4.3 xmlcatmgr docbook-xsl gnome-doc-utils docbook-xml docbook-xml-4.1.2 docbook-xml-4.2 docbook-xml-4.4 docbook-xml-4.5 docbook-xml-5.0 iso-codes python25 gdbm tk tcl xorg-libXScrnSaver xorg-scrnsaverproto py25-libxml2 rarian getopt ffmpeg XviD dirac cppunit faac libmp4v2 faad2 gmake lame libogg libsdl xorg-libXrandr xorg-randrproto libtheora libvorbis schroedinger liboil x264 yasm frei0r-plugins gavl opencv gtk2 xorg-libXcomposite xorg-compositeproto xorg-libXfixes xorg-fixesproto xorg-libXcursor xorg-libXdamage xorg-damageproto xorg-libXi xorg-libXinerama xorg-xineramaproto git-core p5-error rsync popt libdv libsamplerate fftw-3 libsndfile flac qt4-mac sox file libao libid3tag libmad wavpack
Error: Status 1 encountered during processing.

Hi jmpoure,

I found your invite to test Kdenlive on http://forum.mac-video.fr.

I've got a MacPro 2 x 2,66 GHz Dual-Core Intel Xeon - 12 Go 667 MHz DDR2 FB-DIMM and 10.5.7 (9J61).

I've tried to install Kdenlive from MacPorts 1.710 and here are the results:

Good luck,

Peloche,

Thanks for your reports. The md5sum error shows that you are not working on the SVN repository of MacPorts. I published more detailed information on http://kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-...

I did not use the SVN HEAD of the MacPorts, but according to the SVN web view the md5sum of kdelibs4 is still wrong for me. To workaround, I made a local version of the kdelibs4 Portfile and changed the md5sum to the value I computed after manually downloading the tarball. Then, the icons did not appear, so I installed kdebase4-runtime, but that failed due to missing dependency on phonon. Installing phonon resolved that and then everything is working. Now, I am at the same state as JMP with kdenlive running on OS X.

I don't have any access to a Mac OS X machine any longer.

I saw your bug reports, thanks:
http://trac.macports.org/ticket/19960

Adding a patch to your file would fasten things.

Hi all,

How long to build qt4-mac on 2 x 2,66 GHz Dual core Xenon + 12 Go Ram, somebody knows ?

Thanks,

Peloche,

Edit: It's OK now for building qt4-mac, this morning after 3 hours it wasn't finished so I started again and now qt4-mac cleaning is under way ...

Kde4 was fixed in MacPorts SVN.

To upgrade:
%% sudo port -d selfupdate
Now MacPorts will look for portfiles in the working copy.

Upgrade installed packages
%% sudo port upgrade outdated

Install Kdenlive
%% sudo port install kdenlive

Did anyone succeed building automatically from MacPorts?

Some days ago I successfully built kdenlive from macports, without having any macports packages installed.

The built went fine except that building the frei0r plugins did not find the bundle1.o file from the Apple Developer Tools. Is this a local problem?

Starting kdenlive brings up the wizard which seems to work fine. After the last wizard step nothing happens. I do not get any kdenlive window nor do I get any error.

a kdenlive process still runs but nothing happens. I suppose this is because I am using a PowerBook with a ppc processor.

Could you upgrade all your ports to see what happens with the latest version of MacPorts SVN.

%% sudo port -d selfupdate
Now MacPorts will look for portfiles in the working copy.

Upgrade installed packages
%% sudo port upgrade outdated

Install Kdenlive
%% sudo port install kdenlive

Hi jmpoure,

I could install it on my Mac Pro but when clicking open I get the following message:

You also lack icons. Do you have kdebase4-runtime installed? I think Dave mentioned this requirement. Could you install kdebase4-runtime and tell us if this fixes the issue. Then I will post a patch on MacPorts.

After upgrading all my macports packages the behaviour slightly changed.

After proceeding from the last step of the wizard a emtpy window shows up and kdenlive crashes with SIGSEGV. The backtrace provided by the kde crash application is attached.

Tell me if you need more information or if I should file a bug

make sure you are pointing to the SVN repository.

%% sudo port -d selfupdate
Now MacPorts will look for portfiles in the working copy.

Upgrade installed packages
%% sudo port upgrade outdated

Install Kdenlive
%% sudo port install kdebase4-runtime
%% sudo port install kdenlive

Can you try to debug using gdb:
gdb kdenlive

What version of MaxOsX?
Can you run melt from the command line?
melt foo.avi

Kind regards,
JMP

I already had the most recent versions of the mentioned packages.
I think debugging kdenlive does not make much sense since I found that running melt in the Command line results in a segmentation fault.

What i get by running melt MELT.MPG is:

2009-06-21 00:33:29.940 melt[45338:813] Warning once: This application, or a library it uses, is using NSQuickDrawView, which has been deprecated. Apps should cease use of QuickDraw and move to Quartz.
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
|1=-10| |2= -5| |3= -2| |4= -1| |5= 0| |6= 1| |7= 2| |8= 5| |9= 10|
+-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+ +-----+
+---------------------------------------------------------------------+
| H = back 1 minute, L = forward 1 minute |
| h = previous frame, l = next frame |
| g = start of clip, j = next clip, k = previous clip |
| 0 = restart, q = quit, space = play |
+---------------------------------------------------------------------+

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x486b48d9
[Switching to process 45338 thread 0x4503]
0x91e14254 in pthread_mutex_lock ()

I am running Mac OsX 10.5.7(ppc) on an PowerBook G4.

I (MLT developer) am aware that ppc does not work, but I do not have a ppc machine, nor really the bandwidth at the moment to attempt debugging remotely. I can only accept patches to get ppc working. I think this situation applies to Linux as well. So, it might happen that someone submits ppc patches; it has happened for me with Kino in the past.

I did some research into what it will take to embed the player window on OS X. It is far from trivial, and no simple example. I have to do some combination of SDL-GL and QGLWidget. The Qt Phonon Quicktime backend source code provides some help. In any case, it is something I will continue to work on periodically.

Here attached kdebase4-runtime installation report:

If someone provides me with remote access to a MacOsX 10.5 computer via SSH, I can try to fix packages. But I will not be able to port MLT so that it supports MacOsX better. We need someone to work on melt.

Any working and succeeding installation out there?

It's done but still error message when trying to open a file:
"
when running config wizard it shows "URL cannot be listed" and "Malformed URL" "file:///"

Could you open a bug report, please.

To help debugging kdenlive under Mac OS X, I would be in favour of buying a Mac OS X computer (Mac Mini) at the lowest price, install SSH server and VNC Server and open access to the core team. Financing would be via Paypal. I can host the computer. For information, I wron't be using the Mac as I run GNU/Linux exclusively. When porting is over, we may keep the Mac to fix MacPorts packages OR we may resell the mac on eBay.

What do you think of this idea?

I have a work-supplied Mac, and I have kdenlive working on OS X. I also get a file dialog error, but I believe this is due to a general kde setup problem - prolly related to dbus. Otherwise, I have work to do on MLT to embed the monitor window to make it usable. I am quite interested and have been doing the research. It will take some time to integrate QGlWidget, OpenGL, and maybe SDL_GL. People will have to be patient unless someone else with plenty of spare time and skills comes along.

I was looking into this a time ago. Avidemux uses also SDL Windowed Widgets with Qt4 (which works on Mac OS X ).
Trying this at kdenlive did not work (a branch with apple changes is in the kdenlive git). But it seems the init process for SDL must be changed also a bit (in mlt).

So look at some avidemux source could help.

I bumped Kdenlive to 0.7.5 in MacPorts and added a dependency to kdebase4-runtime. Could you test compilation under PPC? A 24 hours running compilation/test PPC computer is available if you wish. Dave, did you succeed to wake-up the computer and connect?

I think there is a need to start dbus by hand, but I cannot verify unless PPC compiles. Sorry!

In the future, maybe we should integrate dbus start in standard Mac OS X mechanisms. It is quite easy to do and requires the writing an XML file. I don't have documentation at hand, but it can be done easily.

With regard to avidemux: My name is surfer on the avidemux forum. I build (Universal) bundles for OSX for avidemux (and for hugin, but that's wxwindows). (Unfortunately the new avidemux 2.5 completely new build structure has offered some new "challenges").

I used to be a long-term kdenlive user on Linux until my laptop crashed in 2006 and I was given a macbook (yes, that happens). That started my OSX adventure.
I still build (upgrade) kdenlive on my Ubuntu server as I still like it very much and I also build (upgrade) and run it occasionally in my Kubuntu virtualbox on my macbook.

I am more than willing to step in to help make kdenlive work on OSX. Please note that I'm not(!) a developer: not at all (and from that point of view: I can't help with the request to port avidemux like functionality to kdenlive. Gruntster and Mean should answer that question).

By now I think I have some experience in building bundles and "make it work" on OSX (I also fixed a couple of macports, but I'm not a maintainer). I don't pretend to be a guru. Again: not at all. I just think I might be able to help here and there.

Only one issue right now: I will go on holiday in 1 week for 3 weeks and don't have much time to step in right now. I could have waited until August to reply on this forum thread, but I still feel enthousiastic about kdenlive. I am already following the progress on OSX for a while and now that this thread also mentions avidemux I decided to not only follow but also step in.
I will setup a separate macports svn tree and have a look at it next week and during my holiday.

I've never had any luck with installing anything via macports or fink or similar.

Something is always broken and it pains me to be without amarok and kdenlive on my macbook.

Hopefully the end goal is to have a .dmg and .app or at least a .pkg installer.

(I said end goal, as this is a project in it's beginning stages.)

MacPorts is interesting as it can automate compilation. A graphical installer is being developed for MacPorts and it is in final stage. Then and only then we may think of an installer. But you will loose the ability to seemless upgrade, like in MacPorts.

By the way, FreiOr was fixed by Lucca using our PPC Mac and pushed to MacPorts. Kdenlive was upgraded to 0.7.5. You should be able to install of x86 10.5 Mac OS.

Hello,

Can someone help me with this i rec'd this error when installing kdenlive (sudo port install kdenlive)? I'm running a Macbook 13" 2.0GHz OS X 10.5.7.

Error: git is required to fetch git://code.dyne.org/frei0r.git
Error: Please install the git-core port before proceeding.
Error: Target org.macports.fetch returned: Git command not found
Error: The following dependencies failed to build: mlt frei0r-plugins git-core p5-error rsync popt libdv libsamplerate fftw-3 libsndfile flac sox file libao libid3tag libmad wavpack
Error: Status 1 encountered during processing.

You probably need to install git. Thanks for pointing this out.

sudo port install git-core

I am not in front of the Mac, but I will try to submit a patch.

I mentioned on the 9th of July that I wanted to help (if possible) to bring kdenlive to macosx and that I would be going on holiday trying to work on it. One day later I connected a USB disk (which I use quite often) to my macbook and with a flash and crackle both were fried. A repair would cost 500-800 euro's. Being a convinced Linux user until mid 2006 I'm now back on Ubuntu Linux using Kdenlive 0.7.5 (thanks, works fine but is not that stable) on a laptop costing only 500 Euro's.
I don't know whether I will buy a macbook back, so my first post was very premature.

I'm sorry.

No problem, I am making progress. I made a Qt test app where I can now embed a single MLT SDL window, but there are issues with resizing. Also, I worry if it will work with multiple SDL windows as Kdenlive uses.

I finally have MLT playing very nicely and stable in my Qt test app using OpenGL for video and SDL for audio. Next step is to integrate my custom QGLWidget into Kdenlive. Getting close!

Really nice. Looking forward to test your code!
The PPC powermac should be back in a few hours via SSH if you need to do some testing.

Hi:
I recently tried to build kdenlive from macports (first time I try, following the documentation), but it fails for me. After the step:

sudo port install kdebase4-runtime

(or directly attempting to install kdenlive)

I get this error:
------------------------------------
---> Computing dependencies for kdebase4-runtime
---> Building libical
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/ma
cports/build/_opt_mports_trunk_dports_devel_libical/work/libical-0.43" && /usr/b
in/make all " returned error 2
Command output: "_icalparameter_get_cn", referenced from:
_test_properties in access_properties_and_parameters.o
"_icalparameter_new_cutype", referenced from:
_create_new_component_with_va_args in access_components.o
_create_new_component in access_components.o
"_icalcomponent_add_component", referenced from:
_create_new_component in access_components.o
"_icalparser_add_line", referenced from:
_parse_text in parse_text.o
"_icalcomponent_isa", referenced from:
_update_attendees in access_properties_and_parameters.o
_get_required_attendees in access_properties_and_parameters.o
"_icalproperty_get_next_parameter", referenced from:
_test_properties in access_properties_and_parameters.o
"_icalcomponent_free", referenced from:
_parse_text in parse_text.o
"_icalcomponent_count_errors", referenced from:
_component_errors in errors.o
_component_errors in errors.o
"_icalproperty_vanew_dtstart", referenced from:
_create_new_component_with_va_args in access_components.o
"_icalcomponent_get_next_component", referenced from:
_remove_vevent_sub_components in access_components.o
_find_sub_components in access_components.o
_find_sub_components in access_components.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[2]: *** [doesnothing] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: The following dependencies failed to build: kdepimlibs4 libical openldap
db44 oxygen-icons qimageblitz
Error: Status 1 encountered during processing.
------------------------------------

I'm using Mac OSX Snow Leopard (10.6), with XCode 3.2

And well, I mainly use kdenlive on ubuntu (which works great! :-). On macosx it was just a trial, to see if it compiles, in order to promote kdenlive to some colleagues which use macosx.

Thanks for producing this nice software (so easy for end users)
I'll give it another try under macosx if I get any hint on what I maybe doing wrong (I'm not experienced at all with macosx)

port uninstall -f libical

and port install libical helped for me (the old libical was 32-bit from 10.5, so ist must be updated to 64-bit)

I'm on OS X 10.5.5 and it installed via macports.

I now have 2 files on my computer that are apps called kdenlive, one is /opt/local/bin/kdenlive, the other is /opt/local/var/macports/sftware/kdenlive/0.7.6_0/opt/local/bin. Both of these do the same thing when I attempt to open them, that being to open up the config wizard for first time use at which point I get the rainbow cursor and eventually it just crashes out.

If there's anything I'm doing wrong or any other info you'd like, let me know. I would love to get this working since it looks to be a fantastic bit of software

edit: I pastebinned the crash report for the benefit of IRC, if anybody would like a look it is here http://pastebin.ca/1653919

edit: I noticed that a lot of the errors I was getting were from not having permission for the Preferences/KDE directory or anything inside it, so I chmod 777'd it and then rebooted to make sure everything was starting from scratch. kdenlive now works but dbus appears to not be getting a socket so I can't work with any files. I shall keep investigating

information about the Preferences/KDE permissions was displayed during install as well as dbus things that you need to manually setup. Basically,
sudo launchctl load -w /Library/LaunchDaemons/org.freedesktop.dbus-system.plist
sudo chown $USER /Library/LaunchAgents/org.freedesktop.dbus-session.plist
launchctl load -w /Library/LaunchAgents/org.freedesktop.dbus-session.plist

These will run now whenever you reboot. Next, you have to run 'open -a kdeinit4' whenever you reboot and before you run the first KDE4 app. You can probably create a StartupItem for that, but I have not. I just run it from Spotlight. You should be able to run kdenlive from Spotlight as well and Dock it if you want.

Thanks, open -a kdeinit4 doesn't work since it can't find an app called kdeinit4 but I ran kde4 instead (not sure if it did anything) and it seems to work fine thus far, apart from the file browser giving me a black line when I hover over an item, but that's not really a problem

I'm running macports svn from today and I had to disable mmx in the portfile to get mlt to compile.

The conditional "platform darwin 8" didn't do it. I had to put it in the configure options above that

This is under:

10.5.8 with XCode 3.1.2 installed

I haven't tried using it yet, but kdenlive starts up

Thanks!

Martins

Hi, i'm trying to install Kdenlive onto my MacBook pro (OS X 10.6.1) but am having trouble configuring Kdenlive. I did come across trouble at the Opencv part too but i searched around and found a patch for the portfile for 64bit then it finished the other dependancies and it comes up with an error while trying to configure Kdenlive.
I have copy and pasted the text from my Terminal screen below...

Jas-MacPro:~ jwriley276$ sudo port install kdenlive
Password:
Warning: Skipping upgrade since opencv 1.0.0_0 >= opencv 1.0.0_0, even though installed variants "+sl_64bit_21014" do not match "". Use 'upgrade --enforce-variants' to switch to the requested variants.
---> Computing dependencies for kdenlive
---> Configuring kdenlive
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_kdenlive/work/build" && cmake -DCMAKE_INSTALL_PREFIX=/opt/local -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_COLOR_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON -DCMAKE_SYSTEM_PREFIX_PATH="/opt/local;/usr" -DQT_QMAKE_EXECUTABLE=/opt/local/libexec/qt4-mac/bin/qmake -Wno-dev -DBUILD_doc=OFF -DBUILD_SHARED_LIBS=ON -DBUNDLE_INSTALL_DIR=/Applications/MacPorts/KDE4 -DPHONON_INCLUDE_DIR=/opt/local/libexec/qt4-mac/include -DPHONON_LIBRARY=/opt/local/libexec/qt4-mac/lib/phonon.framework/phonon -DQT_QMAKE_EXECUTABLE=/opt/local/libexec/qt4-mac/bin/qmake -DKDE_DISTRIBUTION_TEXT="MacPorts/Mac OS X" ../kdenlive-0.7.6 -DNO_JOGSHUTTLE=1 " returned error 1
Command output: -- Found Qt-Version 4.5.3 (using /opt/local/libexec/qt4-mac/bin/qmake)
-- Phonon Version: 4.3.1
-- Found KDE 4.3 include dir: /opt/local/include
-- Found KDE 4.3 library dir: /opt/local/lib
-- Found the KDE4 kconfig_compiler preprocessor: /opt/local/bin/kconfig_compiler
-- Found automoc4: /opt/local/bin/automoc4
-- Found MLT INSTALL PATH: /opt/local
-- Found MLT INCLUDES: /opt/local/include/mlt
-- Found MLT LIBR: /opt/local/lib/libmlt.dylib
-- Found MLT++ INCLUDES: /opt/local/include
-- Found MLT++ LIBR: /opt/local/lib/libmlt++.dylib
-- Found MLT library: /opt/local/lib/libmlt.dylib
-- Found msgfmt: /opt/local/bin/msgfmt
-- Found Soprano version 2.2.0: /opt/local/lib/libsoprano.dylib
-- Found Soprano includes: /opt/local/include
-- Found Soprano Index: /opt/local/lib/libsopranoindex.dylib
-- Found Soprano Client: /opt/local/lib/libsopranoclient.dylib
-- Found Soprano Plugin Dir: /opt/local/share/soprano/plugins
-- Found Soprano Plugins: nquadparser nquadserializer raptorparser raptorserializer redlandbackend sesame2backend
CMake Error at /opt/local/share/cmake-2.6/Modules/FindPackageHandleStandardArgs.cmake:57 (MESSAGE):
Could NOT find NEPOMUK (missing: NEPOMUK_LIBRARIES NEPOMUK_INCLUDE_DIR)
Call Stack (most recent call first):
/opt/local/share/apps/cmake/modules/FindNepomuk.cmake:53 (find_package_handle_standard_args)
src/CMakeLists.txt:4 (find_package)

-- Configuring incomplete, errors occurred!

Error: Status 1 encountered during processing.
Jas-MacPro:~ jwriley276$

Thanks
Jason

I'm in the SAME situation: I found a problem in compiling opencv and I solved disabling carbon and quicktime support, and adding gtk support, as found on this macports ticket: http://trac.macports.org/ticket/21014
Now, the output of kdenlive configure is this:

**********************************************

---> Configuring kdenlive
Error: Target org.macports.configure returned: configure failure: shell command " cd "/opt/local/var/macports/build/_opt_mports_trunk_dports_multimedia_kdenlive/work/build" && cmake -DCMAKE_INSTALL_PREFIX=/opt/local -DCMAKE_VERBOSE_MAKEFILE=ON -DCMAKE_COLOR_MAKEFILE=ON -DCMAKE_BUILD_TYPE=Release -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON -DCMAKE_SYSTEM_PREFIX_PATH="/opt/local;/usr" -DQT_QMAKE_EXECUTABLE=/opt/local/libexec/qt4-mac/bin/qmake -Wno-dev -DBUILD_doc=OFF -DBUILD_SHARED_LIBS=ON -DBUNDLE_INSTALL_DIR=/Applications/MacPorts/KDE4 -DPHONON_INCLUDE_DIR=/opt/local/libexec/qt4-mac/include -DPHONON_LIBRARY=/opt/local/libexec/qt4-mac/lib/phonon.framework/phonon -DQT_QMAKE_EXECUTABLE=/opt/local/libexec/qt4-mac/bin/qmake -DKDE_DISTRIBUTION_TEXT="MacPorts/Mac OS X" ../kdenlive-0.7.6 -DNO_JOGSHUTTLE=1 " returned error 1
Command output: -- Found KDE 4.3 library dir: /opt/local/lib
-- Found the KDE4 kconfig_compiler preprocessor: /opt/local/bin/kconfig_compiler
-- Found automoc4: /opt/local/bin/automoc4
-- Looking for dgettext
-- Looking for dgettext - not found
-- Looking for dgettext in /opt/local/lib/libintl.dylib
-- Looking for dgettext in /opt/local/lib/libintl.dylib - found
-- Found Gettext: in /opt/local/lib/libintl.dylib
-- Found MLT INSTALL PATH: /opt/local
-- Found MLT INCLUDES: /opt/local/include/mlt
-- Found MLT LIBR: /opt/local/lib/libmlt.dylib
-- Found MLT++ INCLUDES: /opt/local/include
-- Found MLT++ LIBR: /opt/local/lib/libmlt++.dylib
-- Found MLT library: /opt/local/lib/libmlt.dylib
-- Found msgfmt: /opt/local/bin/msgfmt
-- Found shared-mime-info version: 0.70
-- Found Soprano version 2.2.0: /opt/local/lib/libsoprano.dylib
-- Found Soprano includes: /opt/local/include
-- Found Soprano Index: /opt/local/lib/libsopranoindex.dylib
-- Found Soprano Client: /opt/local/lib/libsopranoclient.dylib
-- Found Soprano Plugin Dir: /opt/local/share/soprano/plugins
-- Found Soprano Plugins: nquadparser nquadserializer raptorparser raptorserializer redlandbackend sesame2backend
CMake Error at /opt/local/share/cmake-2.6/Modules/FindPackageHandleStandardArgs.cmake:57 (MESSAGE):
Could NOT find NEPOMUK (missing: NEPOMUK_LIBRARIES NEPOMUK_INCLUDE_DIR)
Call Stack (most recent call first):
/opt/local/share/apps/cmake/modules/FindNepomuk.cmake:53 (find_package_handle_standard_args)
src/CMakeLists.txt:4 (find_package)

-- Configuring incomplete, errors occurred!

Error: Status 1 encountered during processing.

**********************************************

Any idea?
Thanks, Matteo

When installing from Mac Ports, the installation failed here:

Seans-MacBook-2:~ SeanComp$ sudo port install kdenlive
---> Computing dependencies for kdenlive
---> Building opencv
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_opencv/work/opencv-1.0.0" && /usr/bin/make -j2 all " returned error 2
Command output: /usr/bin/make all-recursive
Making all in cxcore
Making all in src
if /bin/sh ../../libtool --tag=CXX --mode=compile /usr/bin/g++-4.2 -DHAVE_CONFIG_H -I. -I. -I../.. -I. -I../../cxcore/include -I../.. -DNDEBUG -I/opt/local/include -Wall -fno-rtti -pipe -O3 -g -march=prescott -ffast-math -fomit-frame-pointer -O2 -I/opt/local/include -L/opt/local/lib -arch x86_64 -MT dummy.lo -MD -MP -MF ".deps/dummy.Tpo" -c -o dummy.lo dummy.cpp; \
then mv -f ".deps/dummy.Tpo" ".deps/dummy.Plo"; else rm -f ".deps/dummy.Tpo"; exit 1; fi
if /bin/sh ../../libtool --tag=CXX --mode=compile /usr/bin/g++-4.2 -DHAVE_CONFIG_H -I. -I. -I../.. -I. -I../../cxcore/include -I../.. -DNDEBUG -I/opt/local/include -Wall -fno-rtti -pipe -O3 -g -march=prescott -ffast-math -fomit-frame-pointer -O2 -I/opt/local/include -L/opt/local/lib -arch x86_64 -MT cxalloc.lo -MD -MP -MF ".deps/cxalloc.Tpo" -c -o cxalloc.lo cxalloc.cpp; \
then mv -f ".deps/cxalloc.Tpo" ".deps/cxalloc.Plo"; else rm -f ".deps/cxalloc.Tpo"; exit 1; fi
/usr/bin/g++-4.2 -DHAVE_CONFIG_H -I. -I. -I../.. -I. -I../../cxcore/include -I../.. -DNDEBUG -I/opt/local/include -Wall -fno-rtti -pipe -O3 -g -march=prescott -ffast-math -fomit-frame-pointer -O2 -I/opt/local/include -L/opt/local/lib -arch x86_64 -MT cxalloc.lo -MD -MP -MF .deps/cxalloc.Tpo -c cxalloc.cpp -fno-common -DPIC -o .libs/cxalloc.o
/usr/bin/g++-4.2 -DHAVE_CONFIG_H -I. -I. -I../.. -I. -I../../cxcore/include -I../.. -DNDEBUG -I/opt/local/include -Wall -fno-rtti -pipe -O3 -g -march=prescott -ffast-math -fomit-frame-pointer -O2 -I/opt/local/include -L/opt/local/lib -arch x86_64 -MT dummy.lo -MD -MP -MF .deps/dummy.Tpo -c dummy.cpp -fno-common -DPIC -o .libs/dummy.o
cxalloc.cpp:1: error: CPU you selected does not support x86-64 instruction set
cxalloc.cpp:1: error: CPU you selected does not support x86-64 instruction set
dummy.cpp:1: error: CPU you selected does not support x86-64 instruction set
dummy.cpp:1: error: CPU you selected does not support x86-64 instruction set
make[3]: *** [cxalloc.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
make[3]: *** [dummy.lo] Error 1
make[2]: *** [all-recursive] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: The following dependencies failed to build: mlt frei0r-plugins opencv libdv libsamplerate fftw-3 libsndfile flac sox file libao libid3tag libmad wavpack
Error: Status 1 encountered during processing.
Seans-MacBook-2:~ SeanComp$

Hi! I resolved that, following this ticket: http://trac.macports.org/ticket/21014
I downloaded the attachment Portfile-sl_64bit_21014.diff and applied it with these steps:

1) cd /opt/local/var/macports/sources/rsync.macports.org/release/ports/graphics/opencv
(this is the default folder for macports source)

2) sudo patch Portfile -i ~/Downloads/Portfile-sl_64bit_21014.diff
(if the Portfile-sl_64bit_21014.diff is downloaded in Downloads folder)

3) cd ../..
(for returning to ports directory)

4) sudo portindex

5) sudo port install opencv +sl_64bit_21014

In this mode I've solved for opencv, but now I am unable to complete kdenlive configuration, as you can see on my previous post.
Bye bye, Matteo

I also opened a ticket on macports about configure problem:
http://trac.macports.org/ticket/22450
bye bye, Matteo

Bonsoir Jean-Michel

I am a newbie in Mac OS X and definitively in Terminal!
I ve got some errors messages while installing kdenlive.
Macports installed and upgraded successfully.
The command sudo port -u upgrade outdated returned an error as detailed in the enclosed file.
By the way, I proceeded to the sudo port install kdenlive command and get this error :
"Computing dependencies for kdenliveError: Unable to execute port: can't read "build.cmd": Failed to locate 'make' in path: '/opt/local/bin:/opt/local/sbin:/bin:/sbin:/usr/bin:/usr/sbin' or at its MacPorts configuration time location, did you move it?"

Thank you for your help

Guntag

All righty, I'm a newb when it comes to terminal and all this stuff, so bear with me a bit. Anyway, I managed to install MacPorts and all the necessary stuff (I think) and I was able to open and see the Kdenlive launch wizard (or whatever it's called). However, the wizard crashes immediately without letting me do anything. The only feedback I'm able to get about the crash comes from the crash report that OS X always throws on your face when something crashes. I wonder if this will help anything? I'm using the newest Leopard, Xcode is installed and X11 should be rolling smoothly. I may be a bit over my head here, so a detailed step by step explanation of the install and launch process would be welcome.

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000008
Crashed Thread: 0

Thread 0 Crashed:
0 QtCore 0x01526884 QDataStream::operator>>(int&) + 20
1 libkdecore.5.dylib 0x011be3e9 KMimeTypeFactory::KMimeTypeFactory() + 441
2 libkdecore.5.dylib 0x011be83c KMimeTypeFactory::self() + 156
3 libkdecore.5.dylib 0x011c4a15 __ZL20mimeTypeSycocaOffersRK7QString + 37
4 libkdecore.5.dylib 0x011c4f51 KMimeTypeTrader::preferredService(QString const&, QString const&) + 33
5 0x0027c764 Wizard::slotCheckPrograms() + 3828
6 0x0028908e Wizard::slotCheckMlt() + 846
7 0x0028988b Wizard::qt_metacall(QMetaObject::Call, int, void**) + 139
8 QtCore 0x015b10ac QMetaObject::activate(QObject*, int, int, void**) + 556
9 QtCore 0x015ba282 QSingleShotTimer::timeout() + 50
10 QtCore 0x015ba31c QSingleShotTimer::timerEvent(QTimerEvent*) + 44
11 QtCore 0x015b1ac8 QObject::event(QEvent*) + 424
12 QtGui 0x017d670f QApplicationPrivate::notify_helper(QObject*, QEvent*) + 191
13 QtGui 0x017dd23c QApplication::notify(QObject*, QEvent*) + 268
14 libkdeui.5.dylib 0x0060cf53 KApplication::notify(QObject*, QEvent*) + 147
15 QtCore 0x0159ed12 QCoreApplication::notifyInternal(QObject*, QEvent*) + 98
16 QtGui 0x017d474c qt_sendSpontaneousEvent(QObject*, QEvent*) + 60
17 QtGui 0x0177e9d8 QEventDispatcherMacPrivate::activateTimer(__CFRunLoopTimer*, void*) + 152
18 com.apple.CoreFoundation 0x9666e8f5 CFRunLoopRunSpecific + 4469
19 com.apple.CoreFoundation 0x9666eaa8 CFRunLoopRunInMode + 88
20 QtGui 0x0177ef30 QEventDispatcherMac::processEvents(QFlags<:processeventsflag>) + 528
21 QtCore 0x0159e2b1 QEventLoop::processEvents(QFlags<:processeventsflag>) + 65
22 QtCore 0x0159e47d QEventLoop::exec(QFlags<:processeventsflag>) + 189
23 QtGui 0x01c510ac QDialog::exec() + 268
24 0x00024990 MainWindow::readOptions() + 1136
25 0x0003c5be MainWindow::MainWindow(QString const&, KUrl const&, QWidget*) + 2606
26 0x00015212 main + 4242
27 0x0000c726 start + 54

Thread 1:
0 libSystem.B.dylib 0x954ce3ca select$DARWIN_EXTSN$NOCANCEL + 10
1 QtCore 0x0157f0bb QProcessManager::run() + 123
2 QtCore 0x014acc3f QThreadPrivate::start(void*) + 191
3 libSystem.B.dylib 0x954c8155 _pthread_start + 321
4 libSystem.B.dylib 0x954c8012 thread_start + 34

Thread 2:
0 libSystem.B.dylib 0x954e66fa select$DARWIN_EXTSN + 10
1 libSystem.B.dylib 0x954c8155 _pthread_start + 321
2 libSystem.B.dylib 0x954c8012 thread_start + 34

Thread 0 crashed with X86 Thread State (32-bit):
eax: 0xbfffe19c ebx: 0x011be23e ecx: 0x19d31bc0 edx: 0xbfffe19c
edi: 0x00000000 esi: 0x00000000 ebp: 0xbfffe138 esp: 0xbfffe110
ss: 0x0000001f efl: 0x00010282 eip: 0x01526884 cs: 0x00000017
ds: 0x0000001f es: 0x0000001f fs: 0x00000000 gs: 0x00000037
cr2: 0x00000008

i commited last in svn, that nepomuk is now optional.

update should help (if you use mac-ports, you must patch by hand, or wait for the next release).

i found also the reason, why the stop button will not stop the video:
the videogl widget takes 80-130 ms to draw a frame (much too long) , and this will stack too much frames (2.4 Ghz Dual Core Intel. 10.6.3).
i'll try to find out how to fix that

Pages