Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001009KdenliveEffectspublic2009-07-06 21:262010-02-02 10:38
Reportermcfrisk 
Assigned Toj-b-m 
PrioritynormalSeverityblockReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.6 
Summary0001009: GUI hung up with CPU usage at 98% and memory usage growing fast
DescriptionKdenlive svn3726, mlt commit bc30828d88ec690e4781704a58e2922f3d9df03b, ffmpeg commit d314d12ff724fd678e8e99f5b5359e39695ace7b on Debian unstable. Can't remember what I was doing, but here are some traces anyway.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filestxt file icon kdenlive_backtrace4_hang_memory_leak.txt [^] (26,387 bytes) 2009-07-06 21:26 [Show Content]

- Relationships

-  Notes
(0003951)
ddennedy (developer)
2009-09-17 02:09

JBM, does this look like some sort of circular signal handling at the Kdenlive level?

I agree that bugs that consume CPU and memory are "block" because they disrupt other activity on the computer including often the ability to kill the errant process.
(0003956)
j-b-m (administrator)
2009-09-17 15:20

Thanks. There was a stupid loop when moving a clip with speed effect from one track to another, fixed now in svn rev. 3904. It also made me discover other speed effect related issues (disappearing effects and crashes) that have been fixed in svn rev 3906.

- Issue History
Date Modified Username Field Change
2009-07-06 21:26 mcfrisk New Issue
2009-07-06 21:26 mcfrisk File Added: kdenlive_backtrace4_hang_memory_leak.txt
2009-07-06 21:26 mcfrisk Build/Install Method => Manual build from SVN
2009-09-17 02:09 ddennedy Note Added: 0003951
2009-09-17 15:20 j-b-m Note Added: 0003956
2009-09-17 15:20 j-b-m Status new => resolved
2009-09-17 15:20 j-b-m Fixed in Version => Recent git
2009-09-17 15:20 j-b-m Resolution open => fixed
2009-09-17 15:20 j-b-m Assigned To => j-b-m
2009-10-08 20:20 j-b-m Fixed in Version Recent git => 0.7.6
2010-02-02 10:35 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker