Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001035KdenliveEffectspublic2009-07-10 16:092010-02-02 10:38
ReporterRovanion 
Assigned ToGranjow 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version0.7.5 
Target VersionFixed in Version0.7.6 
Summary0001035: Application crashed when doubelclicked while editing a Titel.
DescriptionI was using kdenlive editing a titel with the font wargames on a black color bacground. I doubelclicked on the window and then the application crashed.
I am using Gnome under LinuxMint 7 which is Ubuntu 9.04 in the core.
Additional InformationApplication: Kdenlive (kdenlive), signal SIGSEGV
[Current thread is 0 (LWP 3518)]

Thread 4 (Thread 0xac6bbb90 (LWP 3771)):
#0 0xb807e430 in __kernel_vsyscall ()
#1 0xb67307b1 in select () from /lib/tls/i686/cmov/libc.so.6
0000002 0xb7448380 in ?? () from /usr/lib/libQtCore.so.4
0000003 0xb737696e in ?? () from /usr/lib/libQtCore.so.4
0000004 0xb663c4ff in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000005 0xb673849e in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 3 (Thread 0xad79eb90 (LWP 3886)):
#0 0xb807e430 in __kernel_vsyscall ()
#1 0xb6640412 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0xb6747344 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb805e9f9 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.1
0000004 0xb663d9ce in pthread_mutex_lock () from /lib/tls/i686/cmov/libpthread.so.0
0000005 0x00000000 in ?? ()

Thread 2 (Thread 0xadf9fb90 (LWP 3887)):
#0 0xb807e430 in __kernel_vsyscall ()
#1 0xb66400e5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0xb67472ed in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
0000003 0xb3cb2d7c in ?? () from /usr/lib/mlt/libmltsdl.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xb5caf920 (LWP 3518)):
[KCrash Handler]
0000006 0x081c158a in _start ()

TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships
has duplicate 0001354closedj-b-m I get a lot of (seemingly) random crashes 

-  Notes
(0003661)
Granjow (developer)
2009-07-11 19:35

Window bar?
(0003662)
Rovanion (reporter)
2009-07-12 01:27

No I doubelclicked the text or the background inside the window.
(0003663)
Granjow (developer)
2009-07-12 11:33

Cannot reproducable here with default font. Does this always happen with Wargames?
(0003665)
Rovanion (reporter)
2009-07-13 01:22

I've now been able to recreate the bug.
It's really simple and it's reacreatable at all times.
Simply open up a new titelclip and doubelclick the white area around the screenspace and the application will crash with this error. It does not matter which text style you are using.
(0003666)
Granjow (developer)
2009-07-13 10:13

Lol. Thank you. Gonna fix it.
(0003667)
Granjow (developer)
2009-07-13 14:05

Okay, the problem is that, when double-clicking, kdenlive is going to look for an item within 4 pixels. When adding text near the left border, the view is being moved rightwards and finding an item (respectively accessing it) fails.
(0003668)
Granjow (developer)
2009-07-13 14:11

Should be fixed in r3729.
(0003670)
Rovanion (reporter)
2009-07-13 14:34

Sounds great.
Anyway, you got to love the Open Source community where you can report a bug and someone actually cares. Best of luck with this project, it has exceeded all my expectations this far. It's the application I'm going to recommend if someone asks me for a video editing program.
(0003671)
Granjow (developer)
2009-07-13 14:48

Thank you :)

- Issue History
Date Modified Username Field Change
2009-07-10 16:09 Rovanion New Issue
2009-07-10 16:09 Rovanion Build/Install Method => Distribution package
2009-07-11 19:35 Granjow Note Added: 0003661
2009-07-11 19:35 Granjow Status new => feedback
2009-07-12 01:27 Rovanion Note Added: 0003662
2009-07-12 11:33 Granjow Note Added: 0003663
2009-07-13 01:22 Rovanion Note Added: 0003665
2009-07-13 10:13 Granjow Note Added: 0003666
2009-07-13 10:13 Granjow Assigned To => Granjow
2009-07-13 10:13 Granjow Status feedback => assigned
2009-07-13 14:05 Granjow Note Added: 0003667
2009-07-13 14:11 Granjow Note Added: 0003668
2009-07-13 14:11 Granjow Status assigned => feedback
2009-07-13 14:34 Rovanion Note Added: 0003670
2009-07-13 14:48 Granjow Note Added: 0003671
2009-10-08 15:52 j-b-m Status feedback => resolved
2009-10-08 15:52 j-b-m Fixed in Version => Recent git
2009-10-08 15:52 j-b-m Resolution open => fixed
2009-10-08 20:20 j-b-m Fixed in Version Recent git => 0.7.6
2009-12-27 18:45 j-b-m Relationship added has duplicate 0001354
2010-02-02 10:35 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker