Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001075KdenliveRenderingpublic2009-08-03 12:212010-09-22 17:53
Reporterxzhayon 
Assigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSFreeBSDOS Version7.2-STABLE
Product Version0.7.5 
Target Version0.7.6Fixed in Version0.7.6 
Summary0001075: crash when kdenlive_render is not in $PATH
Descriptioni'm copying this directly from freebsd.org: http://www.freebsd.org/cgi/query-pr.cgi?pr=136882 [^]
obviously this is NOT limited to ${KDE4_PREFIX}, which is specific to freebsd

when trying to render the project from GUI, script execution crashes. it happens when $PATH is not containing kde4 bin directory ( /usr/local/kde4/bin ), so the script cannot find kdenlive_render.
Steps To Reproducetry to render some kdenlive project in GUI without having ${KDE4_PREFIX}/bin in $PATH environment variable.
Additional Informationi guess no linux user is going to face this problem, but it would be nice to find a fix for it. not really important anyway, at the moment we patch it in the ports system

the interested code (then jb is aware of the problem described below):
QString renderer = QCoreApplication::applicationDirPath() + QString("/kdenlive_render");
if (!QFile::exists(renderer)) renderer = "kdenlive_render";

from http://doc.trolltech.com/4.5/qcoreapplication.html#applicationDirPath: [^]
Warning: On Linux, this function will try to get the path from the /proc file system. If that fails, it assumes that argv[0] contains the absolute file name of the executable. The function also assumes that the current directory has not been changed by the application.

conclusions:
it's quite difficult to find any linux user with /proc unmounted, that's why they're probably not going to suffer from this. also, i don't know if that statement applies to freebsd too. i can't reproduce this issue, since it works for me with /proc mounted and unmounted
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0003782)
j-b-m (administrator)
2009-08-10 22:05

Could you test if latest svn revision (3813) fixes the issue ?
thanks
(0003783)
xzhayon (developer)
2009-08-10 22:17

weee i wasn't even asking for a fix, thanks! :)

i won't be able to test this until 0.7.6 is out (and i make the port for it), but apparently it should be ok. anyway i can remember a situation where KStandardDirs() wasn't working as expected on freebsd, then we'll see

i'll be back when i'll have some feedback
(0004630)
xzhayon (developer)
2010-02-04 00:57

fixed in rev. 3813

- Issue History
Date Modified Username Field Change
2009-08-03 12:21 xzhayon New Issue
2009-08-03 12:21 xzhayon Build/Install Method => Distribution package
2009-08-10 22:05 j-b-m Note Added: 0003782
2009-08-10 22:05 j-b-m Status new => feedback
2009-08-10 22:17 xzhayon Note Added: 0003783
2009-08-10 22:18 xzhayon Target Version => future version
2010-02-04 00:57 xzhayon Note Added: 0004630
2010-02-04 00:57 xzhayon Status feedback => new
2010-02-04 00:57 xzhayon Status new => resolved
2010-02-04 00:57 xzhayon Fixed in Version => 0.7.6
2010-02-04 00:57 xzhayon Resolution open => fixed
2010-02-04 00:57 xzhayon Assigned To => xzhayon
2010-02-04 00:57 xzhayon Assigned To xzhayon =>
2010-02-20 08:16 j-b-m Status resolved => closed
2010-09-22 17:53 Granjow Target Version future version => 0.7.6


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker