Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001080KdenliveUser Interfacepublic2009-08-05 04:512010-09-22 17:53
Reportercompumike 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target Version0.7.6Fixed in Version0.7.6 
Summary0001080: Track view / timeline not matched to XML data with NTSC framerate 29.97fps
DescriptionI am having A/V sync issues with rendering HDV 30p video, but first I noticed a GUI issue which may or may not be related to the A/V sync problem. Even though clips can be correctly inserted and snapped to each other's start/end points, they are not necessarily drawn at the correct points when shown in the track view or in the project monitor. This is easy to demonstrate (borrowing from issue 1034):

1. Create new project with "HDV 1440x1080 30p" profile. (This has a 30000/1001 = 29.97fps frame rate.)
2. Create a "black" Color Clip.
3. Create a "white" Color Clip with duration 00:00:01:00. (1 second.)
4. Add the 1 second sound file http://www.mikeadkins.net/kdenlive/Tone.wav [^]
5. Create a project file with the following layout:
  a) BLACK start=00:00:00:00 duration=00:01:00:00 in track 0.
  b) WHITE start=00:01:00:00 duration=00:00:01:00 in track 0, and Tone.wav in track 1.
  c) BLACK start=00:01:01:00 duration=00:58:59:00 in track 0.
  d) WHITE start=01:00:00:00 duration=00:00:01:00 in track 0, and Tone.wav in track 1.
  e) BLACK start=01:00:01:00 duration=00:00:59:00 in track 0.
6. Using the mouse, zoom in around the end of the final BLACK segment in the track view. Start playback in the Project Monitor a few seconds from the end. Playback stops at the end, and the track monitor and project monitor timestamps both read "01:00:53:26" -- when they should actually be "01:01:00:00" or "01:00:59:29"! This is off by 6 seconds or about 0.1% -- likely because somewhere 30000/1001 is becoming 30.

(Oddly enough, after saving and re-opening the file, it then becomes "01:00:56:09"!)

7. Create a new project with "HDV 1440x1080 25p" profile (which seems to be require explicitly going to Project->Project Settings -- make sure yours changes in the title bar!) and repeat steps 2-6. The playback now stops at "01:00:59:24" -- which is at least within 1 frame of what I originally expected.

In all cases, including with 30p, double clicking a clip in the track to show its start and duration shows the correct value.

The audio clips are not necessarily important for this GUI bug but are simply there because I am also having A/V sync issues that may or may not be related to this bug.

This bug occurs whether or not I use Mike Adkins' "more complete" patch on the mlt-devel mailing list to make some changes relating to NTSC framerates.
http://sourceforge.net/mailarchive/forum.php?thread_name=47874c3081a0c270aacd34bdbc005f02.squirrel%40www.mikeadkins.net&forum_name=mlt-devel [^]

I am using kdenlive from svn -- revision 3799, and mlt from git -- with or without Mike Adkins' patch as described above, and ffmpeg r19547 from svn. (My A/V sync issues also occur with or without his patch but I will leave that as a separate issue to be handled later.)

Please let me know if any additional information is needed or if you can point me toward what part of the codebase to look at! Thanks.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files? file icon testtones_30p.kdenlive [^] (6,640 bytes) 2009-08-05 04:51
png file icon testtones_screenshot.png [^] (123,353 bytes) 2009-08-06 01:49

- Relationships

-  Notes
(0003776)
compumike (reporter)
2009-08-06 01:50

Added screenshot to demonstrate what's going on here.
(0003779)
j-b-m (administrator)
2009-08-09 22:27

Not perfect yet, but it now seems much better with latest Kdenlive svn revision (rev. 3811). Please try to update and report here, thanks
(0003807)
compumike (reporter)
2009-08-18 01:39

Yes, it is indeed much better, thanks.

No impact on resolving my 29.97fps A/V sync issues but I will try to come up with a simple test case for that and report a separate issue. Please mark as resolved. Thanks again!

- Issue History
Date Modified Username Field Change
2009-08-05 04:51 compumike New Issue
2009-08-05 04:51 compumike File Added: testtones_30p.kdenlive
2009-08-05 04:51 compumike Build/Install Method => Manual build from SVN
2009-08-06 01:49 compumike File Added: testtones_screenshot.png
2009-08-06 01:50 compumike Note Added: 0003776
2009-08-09 22:27 j-b-m Note Added: 0003779
2009-08-09 22:27 j-b-m Assigned To => j-b-m
2009-08-09 22:27 j-b-m Status new => feedback
2009-08-18 01:39 compumike Note Added: 0003807
2009-08-19 21:29 j-b-m Status feedback => assigned
2009-08-19 21:29 j-b-m Status assigned => resolved
2009-08-19 21:29 j-b-m Fixed in Version => Recent git
2009-08-19 21:29 j-b-m Resolution open => fixed
2009-09-10 01:46 xzhayon Target Version => future version
2009-10-08 20:20 j-b-m Fixed in Version Recent git => 0.7.6
2010-02-02 10:35 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-02 10:37 j-b-m Fixed in Version 0.7.7 => 0.7.6
2010-02-02 10:38 j-b-m Status resolved => closed
2010-09-22 17:53 Granjow Target Version future version => 0.7.6


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker