Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001082KdenliveEffectspublic2009-08-07 18:292011-11-01 18:57
Reporternadavkav 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.8.2 
Summary0001082: crash while removing "pan and zoom" effect from a video
Descriptioni clicked on the "X" to remove the "pan and zoom" effect
and it crashed.

(both mlt and kdenlive are build from git/svn repositories)
Additional InformationApplication that crashed: kdenlive
Version of the application: 0.7.5
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.30-1-amd64 x86_64
Distribution: Debian GNU/Linux unstable (sid)

What I was doing when the application crashed:
<In detail, tell us what you were doing when the application crashed.>

 -- Backtrace:
Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0x7fb2c2c5d740 (LWP 15676))]

Thread 3 (Thread 0x7fb2a4e69950 (LWP 15855)):
#0 pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:261
#1 0x00007fb2b2be9e9b in consumer_thread (arg=<value optimized out>) at consumer_sdl_preview.c:385
0000002 0x00007fb2be52efaa in start_thread (arg=<value optimized out>) at pthread_create.c:297
0000003 0x00007fb2bea1531d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000004 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb2a566a950 (LWP 16160)):
#0 pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:217
#1 0x00007fb2c297d903 in mlt_consumer_get_frame (this=0x1a52f80) at mlt_consumer.c:498
0000002 0x00007fb2c297db4d in mlt_consumer_rt_frame (this=0x1a5309c) at mlt_consumer.c:896
0000003 0x00007fb2b2bea714 in consumer_thread (arg=<value optimized out>) at consumer_sdl_still.c:556
0000004 0x00007fb2be52efaa in start_thread (arg=<value optimized out>) at pthread_create.c:297
0000005 0x00007fb2bea1531d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
0000006 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb2c2c5d740 (LWP 15676)):
[KCrash Handler]
0000005 ~QObjectPrivate (this=0x1dfd3e0) at kernel/qobject.cpp:128
0000006 0x00007fb2c040ec63 in ~QObject (this=0x5d74880) at kernel/qobject.cpp:857
0000007 0x00007fb2c04127af in ~QSingleShotTimer (this=0x5d74880) at kernel/qtimer.cpp:289
0000008 0x00007fb2c0407b73 in QObject::event (this=0x5d74880, e=0x7fffe30874c0) at kernel/qobject.cpp:1074
0000009 0x00007fb2bf6177ad in QApplicationPrivate::notify_helper (this=0x156fe90, receiver=0x5d74880, e=0x7fffe3087c20) at kernel/qapplication.cpp:4056
0000010 0x00007fb2bf61f80a in QApplication::notify (this=0x7fffe3087f60, receiver=0x5d74880, e=0x7fffe3087c20) at kernel/qapplication.cpp:4021
0000011 0x00007fb2c20d7b2b in KApplication::notify (this=0x7fffe3087f60, receiver=0x5d74880, event=0x7fffe3087c20) at ../../kdeui/kernel/kapplication.cpp:302
0000012 0x00007fb2c03f849c in QCoreApplication::notifyInternal (this=0x7fffe3087f60, receiver=0x5d74880, event=0x7fffe3087c20) at kernel/qcoreapplication.cpp:610
0000013 0x00007fb2c04247a6 in QTimerInfoList::activateTimers (this=0x1573ae0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
0000014 0x00007fb2c0420c1d in timerSourceDispatch (source=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:165
0000015 0x00007fb2bb5f110a in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
0000016 0x00007fb2bb5f4968 in ?? () from /usr/lib/libglib-2.0.so.0
0000017 0x00007fb2bb5f4b1c in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
0000018 0x00007fb2c0420b7f in QEventDispatcherGlib::processEvents (this=0x1556790, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
0000019 0x00007fb2bf6ae5ef in QGuiEventDispatcherGlib::processEvents (this=0x1dfd3e0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
0000020 0x00007fb2c03f6d62 in QEventLoop::processEvents (this=<value optimized out>, flags={i = -485982576}) at kernel/qeventloop.cpp:149
0000021 0x00007fb2c03f7134 in QEventLoop::exec (this=0x7fffe3087ed0, flags={i = -485982496}) at kernel/qeventloop.cpp:201
0000022 0x00007fb2c03f93a4 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
0000023 0x00000000004421d5 in main (argc=5, argv=0x7fffe30884b8) at /root/sources/kdenlive/src/main.cpp:90

Report to http://kdenlive.org/mantis [^]
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0003786)
j-b-m (administrator)
2009-08-12 08:12

I can reproduce now. Seems like this issue appeared with Qt 4.5.2. I will work on it this week-end
(0006869)
Granjow (developer)
2011-06-11 09:05

Has been fixed in the meantime (correct me if I'm wrong, but I could not reproduce it).

- Issue History
Date Modified Username Field Change
2009-08-07 18:29 nadavkav New Issue
2009-08-07 18:29 nadavkav Build/Install Method => Manual build from SVN
2009-08-12 08:12 j-b-m Note Added: 0003786
2009-08-12 08:12 j-b-m Assigned To => j-b-m
2009-08-12 08:12 j-b-m Status new => acknowledged
2011-06-11 09:05 Granjow Note Added: 0006869
2011-06-11 09:05 Granjow Status acknowledged => resolved
2011-06-11 09:05 Granjow Fixed in Version => 0.8
2011-06-11 09:05 Granjow Resolution open => fixed
2011-07-05 12:15 j-b-m Fixed in Version 0.8 => 0.8.2
2011-11-01 18:57 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker