Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001096KdenliveFile Loadingpublic2009-08-20 22:102010-11-14 22:18
Reportermeridius 
Assigned To 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionunable to reproduce 
Platform64 bitOSUbuntu LinuxOS Version9.04
Product Version0.7.5 
Target VersionFixed in Version0.7.7 
Summary0001096: Kdenlive crash when I trie to ad clip to timeline.
DescriptionKdenlive crash when I trie to ad clip to timeline.

Clip proportiers:
.mts
Video Codec H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10
Resolution 1920x1080
fps 50
Duration 00:04:46:02
File Size 551.1 MiB

But it did not crash while I tried to add larger nor longer clips with the exact same or diferent encoding.

Only solution is IMHO right click on clip and Re-load clip function in Project Structure tab. Then is no problem.
Steps To Reproduce- do some work in kdenlive
- from "Struktura projektu" (Project Structure) tab try to add (drag&drop) clip (described above) to timeline
- crash
Additional Informationkdenlive was installed from PPA http://ppa.launchpad.net/sunab/ppa/ubuntu [^]

--

crash appears only with this file and everytime generates slightly different crash log (below)

-FIRST-------------------------

Aplikace: Kdenlive (kdenlive), signál SIGSEGV
0x00007fb92da0cd21 in nanosleep () from /lib/libc.so.6
[Current thread is 0 (LWP 17762)]

Thread 3 (Thread 0x7fb91226b950 (LWP 17783)):
#0 0x00007fb92d55056d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007fb931994bb3 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.1
0000002 0x00007fb931994e25 in mlt_consumer_rt_frame () from /usr/lib/libmlt.so.1
0000003 0x00007fb91a5557f4 in ?? () from /usr/lib/mlt/libmltsdl.so
0000004 0x00007fb92d54c3ba in start_thread () from /lib/libpthread.so.0
0000005 0x00007fb92da4afcd in clone () from /lib/libc.so.6
0000006 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7fb911a6a950 (LWP 17784)):
#0 0x00007fb92d5502e9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007fb91a554f3b in ?? () from /usr/lib/mlt/libmltsdl.so
0000002 0x00007fb92d54c3ba in start_thread () from /lib/libpthread.so.0
0000003 0x00007fb92da4afcd in clone () from /lib/libc.so.6
0000004 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fb931d88750 (LWP 17762)):
[KCrash Handler]
0000005 0x00007fb93177419c in Mlt::Producer::cut () from /usr/lib/libmlt++.so.2
0000006 0x0000000000482feb in _start ()

-NEXT----------------------------------

Aplikace: Kdenlive (kdenlive), signál SIGSEGV
0x00007ff18516dd21 in nanosleep () from /lib/libc.so.6
[Current thread is 0 (LWP 18163)]

Thread 3 (Thread 0x7ff1699cc950 (LWP 18183)):
#0 0x00007ff184cb156d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007ff1890f5bb3 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.1
0000002 0x00007ff1890f5e25 in mlt_consumer_rt_frame () from /usr/lib/libmlt.so.1
0000003 0x00007ff171cb67f4 in ?? () from /usr/lib/mlt/libmltsdl.so
0000004 0x00007ff184cad3ba in start_thread () from /lib/libpthread.so.0
0000005 0x00007ff1851abfcd in clone () from /lib/libc.so.6
0000006 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ff1691cb950 (LWP 18184)):
#0 0x00007ff184cb12e9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007ff171cb5f3b in ?? () from /usr/lib/mlt/libmltsdl.so
0000002 0x00007ff184cad3ba in start_thread () from /lib/libpthread.so.0
0000003 0x00007ff1851abfcd in clone () from /lib/libc.so.6
0000004 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff1894e9750 (LWP 18163)):
[KCrash Handler]
0000005 0x00007ff188ed519c in Mlt::Producer::cut () from /usr/lib/libmlt++.so.2
0000006 0x0000000000482feb in _start ()

-ANOTHER--------------------------------

Aplikace: Kdenlive (kdenlive), signál SIGSEGV
0x00007f38e43f6d21 in nanosleep () from /lib/libc.so.6
[Current thread is 0 (LWP 18268)]

Thread 3 (Thread 0x7f38c8c55950 (LWP 18285)):
#0 0x00007f38e3f3a56d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007f38e837ebb3 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.1
0000002 0x00007f38e837ee25 in mlt_consumer_rt_frame () from /usr/lib/libmlt.so.1
0000003 0x00007f38d0f3f7f4 in ?? () from /usr/lib/mlt/libmltsdl.so
0000004 0x00007f38e3f363ba in start_thread () from /lib/libpthread.so.0
0000005 0x00007f38e4434fcd in clone () from /lib/libc.so.6
0000006 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f38c8454950 (LWP 18286)):
#0 0x00007f38e3f3a2e9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007f38d0f3ef3b in ?? () from /usr/lib/mlt/libmltsdl.so
0000002 0x00007f38e3f363ba in start_thread () from /lib/libpthread.so.0
0000003 0x00007f38e4434fcd in clone () from /lib/libc.so.6
0000004 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f38e8772750 (LWP 18268)):
[KCrash Handler]
0000005 0x00007f38e815e19c in Mlt::Producer::cut () from /usr/lib/libmlt++.so.2
0000006 0x0000000000482feb in _start ()
TagsNo tags attached.
Build/Install MethodOther Method?
Attached Files

- Relationships

-  Notes
(0003916)
ddennedy (developer)
2009-09-16 08:34

Thanks, all the backtraces show the same problem. Can you post this clip somewhere to download? If you do not know any other way, consider rapidshare.com.
(0006056)
ttill (developer)
2010-11-14 22:18

Closing, lack of response.

- Issue History
Date Modified Username Field Change
2009-08-20 22:10 meridius New Issue
2009-08-20 22:10 meridius Build/Install Method => Other Method?
2009-09-16 08:34 ddennedy Note Added: 0003916
2009-09-16 08:34 ddennedy Status new => feedback
2010-11-14 22:18 ttill Status feedback => resolved
2010-11-14 22:18 ttill Resolution open => unable to reproduce
2010-11-14 22:18 ttill Fixed in Version => 0.7.7
2010-11-14 22:18 ttill Note Added: 0006056
2010-11-14 22:18 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker