Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001101KdenliveUser Interfacepublic2009-08-24 01:552013-04-07 08:45
Reporterx1250 
Assigned Toptitmain 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.9.6 
Summary0001101: Pulseaudio makes clip and project monitor unusable.
DescriptionHi, I'm confirming bug http://www.kdenlive.org/mantis/view.php?id=388 [^]

I'm a Ubuntu (karmic) user, compiled kdenlive myself, will all needed stuff compiled also by hand.

Kdenlive SVN revision 3833.

I installed kdenlive without pulseaudio (I had purged it). Playback in the video clip and monitor was fine, maybe a little slower than a regular player, but fine. Yesterday I needed pulseaudio again because my sound recorder didn't work without it, so I installed it. Pulseaudio makes kdenlive unable to play at a decent performance in the project or clip monitor. Video play back was like 2, 1, or even 0.x FPS. Fortunately I began thinking and the only different thing I had done was installing pulseaudio. While in kdenlive, and with pulseaudio, changing the audio driver in kdenlive preferences has no effect. Uninstalling pulseaudio package FIXED the issue completely.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0003915)
ddennedy (developer)
2009-09-16 08:30

Thanks for the good testing and feedback. The situation sucks, that's for sure. I wonder if you are able to force Kdenlive to use OSS, then it might bypass PulseAudio. Last I checked, there was no automatic hook to force OSS apps to route through PulseAudio, and one is required to invoke the app with the padsp wrapper. Of course, make sure your ALSA snd_pcm_oss and snd_mixer_oss kernel modules are loaded if you give this a test.
(0009196)
ptitmain (developer)
2013-02-06 07:56

I think this bug is fixed because it is quite old. Now, kdenlive works fine with pulseaudio. Thank you for reporting and do not hesitate to report again in case you think this bug still exist :)

- Issue History
Date Modified Username Field Change
2009-08-24 01:55 x1250 New Issue
2009-08-24 01:55 x1250 Build/Install Method => Manual build from SVN
2009-09-16 08:30 ddennedy Note Added: 0003915
2013-02-06 07:56 ptitmain Note Added: 0009196
2013-02-06 07:56 ptitmain Status new => resolved
2013-02-06 07:56 ptitmain Fixed in Version => 0.9.4
2013-02-06 07:56 ptitmain Resolution open => fixed
2013-02-06 07:56 ptitmain Assigned To => ptitmain
2013-04-07 08:45 j-b-m Fixed in Version 0.9.4 => 0.9.6
2013-04-07 08:45 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker