Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001137KdenliveUser Interfacepublic2009-09-15 08:152010-09-14 23:01
ReporterGranjow 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target Version0.7.8Fixed in Version0.7.8 
Summary0001137: Loading old titler files produces strange results, images too big
DescriptionSee attachment (for 840x474). When loading Info.kdenlivetitle the background image is too big. Creating a new one with the same content (Info2) works.

Info has been created before the new titler had been implemented,
Info2 today (r3890).
Additional Information$ diff Info.kdenlivetitle Info2.kdenlivetitle
1c1
< <kdenlivetitle>
---
> <kdenlivetitle width="840" height="474" out="150" >
9c9
< <position x="700" y="4" >
---
> <position x="696" y="4" >
14,16c14,16
< <startviewport x="0" y="0" size="40" rect="0,0,336,189.6" z-index="-1000" />
< <endviewport x="0" y="0" size="40" rect="0,0,336,189.6" z-index="-1000" />
< <background color="80,80,80,0" />
---
> <startviewport rect="0,0,840,474" />
> <endviewport rect="0,0,840,474" />
> <background color="0,0,0,0" />
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Fileszip file icon titles.zip [^] (2,817 bytes) 2009-09-15 08:17
? file icon test.kdenlivetitle [^] (1,137 bytes) 2009-11-02 20:39
? file icon ArtifactDarkvalley.kdenlive [^] (37,523 bytes) 2010-09-04 08:51

- Relationships

-  Notes
(0003892)
Granjow (developer)
2009-09-15 08:16

PS: .kdenlivetitle not allowed for upload
(0003897)
j-b-m (administrator)
2009-09-15 20:48

I fixed the attachment issue, and send a patch on MLT's mailing list that solves the issue, so I hope this will be ok for the next MLT release.
(0003936)
j-b-m (administrator)
2009-09-16 22:37

The fix has been committed to MLT's git repository, could you please test?
(0004234)
Granjow (developer)
2009-11-02 20:38

Finally had time for testing.
Newest MLT from today. Either there is something screwed up in my system, or it still isn't working. -> Attachment.
(0005710)
Granjow (developer)
2010-08-30 20:20

Still not fixed; The title clip says
<kdenlivetitle width="840" height="474" out="125" >
but even when loading it into an 1080p project it is much bigger.
(0005766)
j-b-m (administrator)
2010-09-04 01:52

Can you please check with svn rev. 4832, I think I might have fixed the problem
(0005767)
Granjow (developer)
2010-09-04 08:51

The attached project file still shows this problem.
(0005768)
j-b-m (administrator)
2010-09-04 11:49

I just remember that older versions of the titler used cached images for the titles. Your project file ArtifactDarkValley seems to use these cached images. Can you try to rename the folder:

/data/video/Stalker/ArtifactDarkvalley/titles

So that it is not found and we can be sure that the titles will be recreated.

If that does not solve the issue, can you post a screenshot of the issue, because here all the titles seem to display ok...
(0005769)
Granjow (developer)
2010-09-04 12:05

Indeed. I've cleared the cache in the project settings, and it is working now! Thank you!

- Issue History
Date Modified Username Field Change
2009-09-15 08:15 Granjow New Issue
2009-09-15 08:15 Granjow Build/Install Method => Manual build from SVN
2009-09-15 08:16 Granjow Note Added: 0003892
2009-09-15 08:17 Granjow File Added: titles.zip
2009-09-15 20:48 j-b-m Note Added: 0003897
2009-09-15 20:48 j-b-m Status new => acknowledged
2009-09-16 22:37 j-b-m Note Added: 0003936
2009-09-16 22:37 j-b-m Status acknowledged => feedback
2009-11-02 20:38 Granjow Note Added: 0004234
2009-11-02 20:39 Granjow File Added: test.kdenlivetitle
2010-08-30 20:20 Granjow Note Added: 0005710
2010-08-30 20:20 Granjow Status feedback => new
2010-09-01 13:55 j-b-m Target Version => 0.7.8
2010-09-04 01:52 j-b-m Note Added: 0005766
2010-09-04 01:52 j-b-m Assigned To => j-b-m
2010-09-04 01:52 j-b-m Status new => feedback
2010-09-04 08:51 Granjow File Added: ArtifactDarkvalley.kdenlive
2010-09-04 08:51 Granjow Note Added: 0005767
2010-09-04 08:51 Granjow Status feedback => assigned
2010-09-04 11:49 j-b-m Note Added: 0005768
2010-09-04 12:05 Granjow Note Added: 0005769
2010-09-04 12:05 Granjow Status assigned => resolved
2010-09-04 12:05 Granjow Fixed in Version => Recent git
2010-09-04 12:05 Granjow Resolution open => fixed
2010-09-14 11:00 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:01 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker