Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001143KdenliveUser Interfacepublic2009-09-16 02:182010-11-14 21:47
Reportervshader 
Assigned To 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.6 
Summary0001143: crash while removing clip from project tree
DescriptionI was trying to remove clip from project tree, when application unexpectedly crashed.
Additional InformationApplication that crashed: kdenlive
Version of the application: 0.7.5 (rev. 3882)
KDE Version: 4.3.00 (KDE 4.3.0)
Qt Version: 4.5.2
Operating System: Linux 2.6.31custom1 x86_64
Distribution: "Fedora release 11 (Leonidas)"

 -- Backtrace:
Application: Kdenlive (kdenlive), signal: Segmentation fault
[KCrash Handler]
0000005 0x0000003aaba772ca in _int_free (av=0x7f977c000020, p=0x7f977c217dc0, have_lock=<value optimized out>) at malloc.c:4912
0000006 0x00007f97943dc35c in av_freep () from /usr/local/kdenlive/trunk//lib/libavutil.so.50
0000007 0x00007f97946f8f6d in MPV_common_end () from /usr/local/kdenlive/trunk//lib/libavcodec.so.52
0000008 0x00007f9794807eb8 in ff_h263_decode_end () from /usr/local/kdenlive/trunk//lib/libavcodec.so.52
0000009 0x00007f97946a6942 in avcodec_close () from /usr/local/kdenlive/trunk//lib/libavcodec.so.52
0000010 0x00007f9795463968 in producer_codec_close (codec=0x7f9784009b40) at producer_avformat.c:246
0000011 0x00007f97a12d974a in mlt_property_clear (this=<value optimized out>) at mlt_property.c:107
0000012 mlt_property_close (this=<value optimized out>) at mlt_property.c:475
0000013 0x00007f97a12da254 in mlt_properties_close (this=0x2f4bbb0) at mlt_properties.c:1161
0000014 0x00007f97a12de90a in mlt_producer_close (this=0x2f4bbb0) at mlt_producer.c:1024
0000015 0x00007f97a12de54a in mlt_service_connect_producer (this=0x26aa330, producer=0x33c0b30, index=0) at mlt_service.c:255
0000016 0x00007f97a10c4123 in Mlt::Service::connect_producer(Mlt::Service&, int) () from /usr/local/kdenlive/trunk/lib/libmlt++.so.3
0000017 0x00007f97a10bb6ec in Mlt::Consumer::connect(Mlt::Service&) () from /usr/local/kdenlive/trunk/lib/libmlt++.so.3
0000018 0x000000000048604d in Render::connectPlaylist (this=0x26a9e50) at /home/vshader/kdenlive-trunk/kdenlive/src/renderer.cpp:1099
0000019 0x000000000048500e in Render::setProducer (this=0x26a9e50, producer=0x0, position=-1) at /home/vshader/kdenlive-trunk/kdenlive/src/renderer.cpp:881
0000020 0x000000000047cf34 in Monitor::slotSetXml (this=0x2693b00, clip=0x0, position=-1) at /home/vshader/kdenlive-trunk/kdenlive/src/monitor.cpp:705
0000021 0x000000000047e071 in Monitor::qt_metacall (this=0x2693b00, _c=QMetaObject::InvokeMetaMethod, _id=20, _a=0x7fffdc5b3710) at /home/vshader/kdenlive-trunk/kdenlive/src/cmake_bindir/monitor.moc:253
0000022 0x0000003ab93547dc in QMetaObject::activate (sender=0x239d440, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
0000023 0x000000000047174b in ProjectList::clipSelected (this=0x239d440, _t1=0x0) at /home/vshader/kdenlive-trunk/kdenlive/src/cmake_bindir/projectlist.moc:215
0000024 0x000000000046a5c5 in ProjectList::slotClipSelected (this=0x239d440) at /home/vshader/kdenlive-trunk/kdenlive/src/projectlist.cpp:262
0000025 0x000000000046c076 in ProjectList::slotDeleteClip (this=0x239d440, clipId=@0x3006650) at /home/vshader/kdenlive-trunk/kdenlive/src/projectlist.cpp:434
0000026 0x000000000047101c in ProjectList::qt_metacall (this=0x239d440, _c=QMetaObject::InvokeMetaMethod, _id=13, _a=0x7fffdc5b3a50)
    at /home/vshader/kdenlive-trunk/kdenlive/src/cmake_bindir/projectlist.moc:170
0000027 0x0000003ab93547dc in QMetaObject::activate (sender=0x31f0cc0, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
0000028 0x00000000004a7ab1 in KdenliveDoc::signalDeleteProjectClip (this=0x31f0cc0, _t1=@0x3006650) at /home/vshader/kdenlive-trunk/kdenlive/src/cmake_bindir/kdenlivedoc.moc:149
0000029 0x00000000004a5a89 in KdenliveDoc::deleteClip (this=0x31f0cc0, clipId=@0x3006650) at /home/vshader/kdenlive-trunk/kdenlive/src/kdenlivedoc.cpp:1033
0000030 0x0000000000440e60 in AddClipCommand::redo (this=0x3006630) at /home/vshader/kdenlive-trunk/kdenlive/src/addclipcommand.cpp:50
0000031 0x0000003abb9843d3 in QUndoStack::push (this=0x2ed5ed0, cmd=0x0) at util/qundostack.cpp:543
0000032 0x0000000000518a00 in ClipManager::slotDeleteClip (this=0x2ec28b0, clipId=@0x2d842e8) at /home/vshader/kdenlive-trunk/kdenlive/src/clipmanager.cpp:156
0000033 0x00000000004a5a39 in KdenliveDoc::deleteProjectClip (this=0x31f0cc0, ids=
        {{p = {static shared_null = {ref = {_q_value = 1}, alloc = 0, begin = 0, end = 0, sharable = 1, array = {0x0}}, d = 0x2d842d0}, d = 0x2d842d0}})
    at /home/vshader/kdenlive-trunk/kdenlive/src/kdenlivedoc.cpp:1026
0000034 0x000000000046bdcd in ProjectList::slotRemoveClip (this=0x239d440) at /home/vshader/kdenlive-trunk/kdenlive/src/projectlist.cpp:405
0000035 0x000000000047118e in ProjectList::qt_metacall (this=0x239d440, _c=QMetaObject::InvokeMetaMethod, _id=21, _a=0x7fffdc5b3ff0)
    at /home/vshader/kdenlive-trunk/kdenlive/src/cmake_bindir/projectlist.moc:178
0000036 0x0000003ab93547dc in QMetaObject::activate (sender=0x2d79a80, from_signal_index=<value optimized out>, to_signal_index=<value optimized out>, argv=0x0) at kernel/qobject.cpp:3113
0000037 0x0000003abb389857 in QAction::triggered (this=0x0, _t1=false) at .moc/release-shared/moc_qaction.cpp:236
0000038 0x0000003abb38acbf in QAction::activate (this=0x2d79a80, event=<value optimized out>) at kernel/qaction.cpp:1160
0000039 0x0000003abb773215 in QMenuPrivate::activateCausedStack (this=<value optimized out>, causedStack=@0x7fffdc5b4110, action=0x2d79a80, action_e=QAction::Trigger, self=true) at widgets/qmenu.cpp:967
0000040 0x0000003abb7790fa in QMenuPrivate::activateAction (this=0x2d7d6e0, action=0x2d79a80, action_e=QAction::Trigger, self=<value optimized out>) at widgets/qmenu.cpp:1060
0000041 0x0000003abb3ddd88 in QWidget::event (this=0x2322990, event=0x7fffdc5b4870) at kernel/qwidget.cpp:7549
0000042 0x0000003abb77b863 in QMenu::event (this=0x2322990, e=0x7fffdc5b4870) at widgets/qmenu.cpp:2353
0000043 0x0000003abb38f69c in QApplicationPrivate::notify_helper (this=0x20d0cf0, receiver=0x2322990, e=0x7fffdc5b4870) at kernel/qapplication.cpp:4056
0000044 0x0000003abb396741 in QApplication::notify (this=<value optimized out>, receiver=0x2322990, e=0x7fffdc5b4870) at kernel/qapplication.cpp:3758
0000045 0x0000003abc411296 in KApplication::notify(QObject*, QEvent*) () from /usr/lib64/libkdeui.so.5
0000046 0x0000003ab933f59c in QCoreApplication::notifyInternal (this=0x7fffdc5b6790, receiver=0x2322990, event=0x7fffdc5b4870) at kernel/qcoreapplication.cpp:610
0000047 0x0000003abb396030 in QCoreApplication::sendSpontaneousEvent (event=<value optimized out>, receiver=<value optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:216
0000048 QApplicationPrivate::sendMouseEvent (event=<value optimized out>, receiver=<value optimized out>) at kernel/qapplication.cpp:2924
0000049 0x0000003abb3fbe6e in QETWidget::translateMouseEvent (this=0x2322990, event=<value optimized out>) at kernel/qapplication_x11.cpp:4338
0000050 0x0000003abb3fab08 in QApplication::x11ProcessEvent (this=<value optimized out>, event=0x7fffdc5b63a0) at kernel/qapplication_x11.cpp:3545
0000051 0x0000003abb4227dc in x11EventSourceDispatch (s=<value optimized out>, callback=<value optimized out>, user_data=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:146
0000052 0x0000003aade37abe in g_main_context_dispatch () from /lib64/libglib-2.0.so.0
0000053 0x0000003aade3b278 in ?? () from /lib64/libglib-2.0.so.0
0000054 0x0000003aade3b3a0 in g_main_context_iteration () from /lib64/libglib-2.0.so.0
0000055 0x0000003ab9367936 in QEventDispatcherGlib::processEvents (this=0x20b6f60, flags=<value optimized out>) at kernel/qeventdispatcher_glib.cpp:327
0000056 0x0000003abb421f8e in QGuiEventDispatcherGlib::processEvents (this=0x0, flags=<value optimized out>) at kernel/qguieventdispatcher_glib.cpp:202
0000057 0x0000003ab933ded2 in QEventLoop::processEvents (this=<value optimized out>, flags={i = 36}) at kernel/qeventloop.cpp:149
#58 0x0000003ab933e2a4 in QEventLoop::exec (this=0x7fffdc5b66d0, flags={i = 0}) at kernel/qeventloop.cpp:201
0000059 0x0000003ab9340439 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
0000060 0x0000000000441c53 in main (argc=1, argv=0x7fffdc5b6ce8) at /home/vshader/kdenlive-trunk/kdenlive/src/main.cpp:86
Warning: the current language does not match this frame.

Wy?lij raport do http://kdenlive.org/mantis [^]
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0004028)
j-b-m (administrator)
2009-09-28 12:07

Can you reproduce the issue? Some changes in MLT recently fixed a concurrency issue that might be the cause for that crash...
(0004200)
vshader (reporter)
2009-10-22 00:02

Kdenlive crashed on my machine some more times, but I didn't notice similar backtrace.

- Issue History
Date Modified Username Field Change
2009-09-16 02:18 vshader New Issue
2009-09-16 02:18 vshader Build/Install Method => Manual build from SVN
2009-09-28 12:07 j-b-m Note Added: 0004028
2009-09-28 12:07 j-b-m Status new => feedback
2009-10-22 00:02 vshader Note Added: 0004200
2010-11-14 21:46 ttill Status feedback => resolved
2010-11-14 21:46 ttill Resolution open => fixed
2010-11-14 21:46 ttill Fixed in Version => 0.7.6
2010-11-14 21:47 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker