Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001197KdenliveUser Interfacepublic2009-10-10 01:222010-09-14 23:00
Reporterraps 
Assigned Toddennedy 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel OSXubuntuOS Version9.04
Product Version0.7.6 
Target VersionFixed in Version0.7.8 
Summary0001197: Render in format Vimeo 640x480 2 pass crashes
DescriptionThe render in format Vimeo 640x480 2 pass crashes before/when starting the second pass.
The render in format Vimeo 640x480 1 pass works fine.
Additional InformationError message:
Le rendu de /home/../Vimeo_2009-09-11_V2.mp4 a été interrompu par une erreur fatale
[libx264 @ 0x96509d0]statistics are damaged at line 17, parser out=3
[ac3 @ 0x955d190]frame sync error

I only got a 48 b file (extension of the attached file changed from .mp4 in .txt) to get it uploaded.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filestxt file icon Vimeo_2009-09-11_V2.txt [^] (48 bytes) 2009-10-10 01:22 [Show Content]
log file icon x264_2pass.log [^] (409,780 bytes) 2009-10-10 07:21

- Relationships

-  Notes
(0004100)
raps (reporter)
2009-10-10 07:22

I got a crash again and couls save the x264_2pass.log file.
See attachment.

Error message:
Le rendu de /home/thomas/videofactory/MathieuPlaineDeJeux_Vimeo_2009-09-11_V2.mp4 a été interrompu par une erreur fatale
[libx264 @ 0x9b44dd0]statistics are damaged at line 17, parser out=3
[ac3 @ 0xa0ff940]frame sync error
[ac3 @ 0xb97fdd0]frame sync error
[ac3 @ 0xb539bb0]incomplete frame
[ac3 @ 0xb539bb0]invalid frame size
[ac3 @ 0xbc9f030]frame sync error
[ac3 @ 0xa0ff940]incomplete frame
[ac3 @ 0xa0ff940]invalid frame size
[ac3 @ 0xa148af0]incomplete frame
[ac3 @ 0xa148af0]invalid frame size
(0004110)
raps (reporter)
2009-10-11 14:00
edited on: 2009-10-14 01:47

Vimeo 640x480 2 pass worked with the same project on 0.7.5 and even on the sunab2 snapshot package for Ubuntu.

Don't know if there is a correlation, but in my project I have exactly 10 video clips, that means 9 transitions from one to the next.

I got both errors with the same project, created originally with the version 0.7.5.
The first time I chose to render only the selection, and there were only 1 transition between 2 video clips => only 1 error.

I made a new project with only 1 video clip => no error.

(0004159)
raps (reporter)
2009-10-14 01:49

DVD pass 2 does not work, simply the pass 1 file is leaved on the harddrive.
Therefore I edited my last comment.

I don't think anymore there is a correlation between the amount of transition in the timeline and the number of entries in the error message.
(0004160)
raps (reporter)
2009-10-14 01:50

Seems to be the same as issue 1212.
Possibly are all render with pass 2 affected?
(0004205)
raps (reporter)
2009-10-24 23:20

Threat were started on forum.
http://www.kdenlive.org/forum/crashing-2-pass [^]
(0004216)
raps (reporter)
2009-10-27 08:50

I have some more test results. I cannot get 2 pass render successes.
Before that I want to say that I am very sorry for the bad, hysterical and incomplete info I give about my problem. I am quite disoriented because it seems that sometimes it works, sometime not.

So I finally tested a project saved on my local drive. And the pass 2 does not works.
The project duration is 29 sec and 4 frames (is it long enough for you, ddennedy?).
As source I use 2 kind of originals .MTS from canon and their conversion in .avi (DVD PAL).
I created one project with the DVD sources and after that I edited a copy and changed all .avi in .MTS.

Both projects reacts equally.
Render to DVD PAL, 1 or 2 passes are working.
Render to Vimeo 1 pass is working.
When I render to Vimeo 2 passes doesn't works.
All my files are saved on my local drive.

Curiously, when I use a rendered DVD PAL project as source and render it in Vimeo 2 passes is working (640x480)!

When rendering with two passes the first pass works, the x264_2pass.log.temp is created, and the second pass is started. In Knotify I can see the progress bar growing but the rendered file does not grows: it stay at 48 bytes.

At the end of the rendering (the progress bar is at 100%) an error message appears.

At the moment I use a 3rd party package (Ubuntu), version 0.7.6.
My OS is Xubuntu 9.04.

The problem was not apparent with the temporary package of sunab (deb http://ppa.launchpad.net/sunab/sunab2/ubuntu [^] jaunty main), version 0.7.5. with two build version before the update to 0.7.6. I don't know the build number.
I think it was a build not younger than the 25st September.
When I render my CPU usage goes to 97% with melt using 70 to 85% (the second task is xorg with 4 to 7%).

Summary: the WiFi connection to a NAS is not the cause, a one-clip-project can render with 2 passes, DVD 2 passes rendering is always working and an multiple-clip-project can nor render with 2 passes.

I'm looking forward to getting suggestions to test / diagnose my problem.
Thank you for reading ;)
(0004217)
raps (reporter)
2009-10-27 08:51

I am confused...
Same project, same conditions, a render in Vimeo 2 passes from the .MTS project. This time it worked. Maybe because it is the second try?
Unfortunately is it very long to test (on my computer), about one hour.
I'll try on a very short project and give feedback as soon as I have results.
(0004237)
ddennedy (developer)
2009-11-03 07:20

I understand it is frustrating, and you are not alone. I need to test this on some other systems to see if reproduces outside my main dev box. I have another problem report on Ubuntu 9.10, but when I upgraded my Ubuntu box this morning, it became unbootable. So, I have to do a fresh install, and then try to reproduce and debug.
(0004253)
raps (reporter)
2009-11-08 23:27

*back from holidays*
I simply try to give as much info as possible. Maybe my poor English
sounds not friendly, be sure it was not my intention.

Please tell me if I can test / get a particular output for you, I'm not really confident with problem analysis on Linux systems. Tell me also if you need a particular information about my system.
(0004506)
raps (reporter)
2010-01-09 23:36

Synaptic updated mlt to 0.4.10 (i guess it comes from sunab's package not from Xubuntu).

After test the problem is still there. I hoped it is gone with the new version. I'm still on Kdenlive 0.7.6.
(0004811)
raps (reporter)
2010-03-11 23:11

Some info after an update to Kdenlive 0.7.7.1 and mlt 0.5:

The problem is still there: at each attempt to render with two passes the render fails.
The error message is a little different this time:

Le rendu de /home/thomas/videofactory/sports_hiver_HD2.mp4 a été interrompu par une erreur fatale
[ac3 @ 0x941feb80]frame sync error

Another attempt of the same project gave (i think it choose another resolution that time):

Le rendu de /home/thomas/videofactory/sports_hiver_HD2.mp4 a été interrompu par une erreur fatale
[ac3 @ 0xb323490]frame sync error

It seems that the address is different.

Now i tried to render the test project "test_file.kdenlive" found on:
http://www.kdenlive.org/bug-reports [^]

The render was successfull.
Could it be that the problem is triggered by an effect or by the source video format?

I use theses effects:
freeze (geler)
wipe? (Fondu à la fermeture).

Regarding the video format ffmpeg gave as output:
Input #0, mpeg, from '00078.avi':
  Duration: 00:01:30.68, start: 0.500000, bitrate: 2320 kb/s
    Stream #0.0[0x1e0]: Video: mpeg2video, yuv420p, 720x576 [PAR 64:45 DAR 16:9], 9000 kb/s, 25 tbr, 90k tbn, 50 tbc
    Stream #0.1[0x80]: Audio: ac3, 48000 Hz, stereo, s16, 448 kb/s

For any further test please ask me.

raps
(0004924)
raps (reporter)
2010-04-05 22:46
edited on: 2010-04-05 22:48

Recently I tried to render the test project (found here: http://www.kdenlive.org/bug-reports [^]) and was surprised to see that it worked!

After that I tried to change that test project to have a stand repeating the problem (first pass works, second pass fails after first pass).

My conclusions after a lot of tests:

- A project 30 sec of color clips does succeeded to render
- A project where I changed the color clips in .avi files (see last post to have encoding parameters), same clip length did not succeed.

Both projects have no transitions and no effects. There are created with a succession of 10 clips 2:10 s long, to reach a total of 0:28:10.

The difference between both cases is, that when rendering the .avi clips my computer resources are used at full capacity (and it would use even more resources, if it was possible). Even my mouse pointer is drawn only every 2 seconds or less.

So my thought is, that the system does not responds enough after the first pass, and the second pass cannot start properly and produces the error message (sync error):
Le rendu de /home/thomas/videofactory/Sans titre.mp4 a été interrompu par une erreur fatale
[ac3 @ 0xa585eb0]incomplete frame [ac3 @ 0xa585eb0]invalid frame size
[ac3 @ 0xb3812c0]incomplete frame [ac3 @ 0xb3812c0]invalid frame size
[ac3 @ 0xa585eb0]incomplete frame [ac3 @ 0xa585eb0]invalid frame size
[ac3 @ 0xb3812c0]incomplete frame [ac3 @ 0xb3812c0]invalid frame size
[ac3 @ 0xa585eb0]incomplete frame [ac3 @ 0xa585eb0]invalid frame size

My system is very bad to use Kdenlive:
laptop Fujitsu Amilo L 7300.
512 RAM, Intel celeron M processor 1.4 GHz.

BUT until Kdenlive 0.7.5 as documented it worked. Since 0.7.6 it does not work any more (actual version: 0.7.7.1).

After reading the forum today, especially this topic:
http://www.kdenlive.org/forum/cant-render-0771 [^]
I tried then to create a new render profile without the scaling (option s).
In that case the render works. So the problem is the scaling or the transition between the first and the second pass?

(0004927)
ddennedy (developer)
2010-04-06 05:46

Thank you. I reproduced it. I hope to have it fixed very soon.
(0004930)
ddennedy (developer)
2010-04-07 05:36

Fixed in MLT Git commit a79bed5.
(0004931)
ddennedy (developer)
2010-04-07 05:39

There is a corresponding bug in MLT tracker:
https://sourceforge.net/tracker/?func=detail&atid=613414&aid=2976110&group_id=96039 [^]
(0004932)
ddennedy (developer)
2010-04-07 06:13

The MLT release that will contain this fix will be 0.5.4 - no date has been set yet, but it should not be too long from now.

- Issue History
Date Modified Username Field Change
2009-10-10 01:22 raps New Issue
2009-10-10 01:22 raps File Added: Vimeo_2009-09-11_V2.txt
2009-10-10 01:22 raps Build/Install Method => Distribution package
2009-10-10 07:21 raps File Added: x264_2pass.log
2009-10-10 07:22 raps Note Added: 0004100
2009-10-11 14:00 raps Note Added: 0004110
2009-10-11 14:04 raps Note Edited: 0004110 View Revisions
2009-10-14 01:47 raps Note Edited: 0004110 View Revisions
2009-10-14 01:49 raps Note Added: 0004159
2009-10-14 01:50 raps Note Added: 0004160
2009-10-24 23:20 raps Note Added: 0004205
2009-10-27 08:50 raps Note Added: 0004216
2009-10-27 08:51 raps Note Added: 0004217
2009-11-03 07:20 ddennedy Note Added: 0004237
2009-11-03 07:20 ddennedy Status new => assigned
2009-11-03 07:20 ddennedy Assigned To => ddennedy
2009-11-08 23:27 raps Note Added: 0004253
2010-01-09 23:36 raps Note Added: 0004506
2010-03-11 23:11 raps Note Added: 0004811
2010-04-05 22:46 raps Note Added: 0004924
2010-04-05 22:47 raps Note Edited: 0004924 View Revisions
2010-04-05 22:48 raps Note Edited: 0004924 View Revisions
2010-04-06 05:46 ddennedy Note Added: 0004927
2010-04-07 05:36 ddennedy Note Added: 0004930
2010-04-07 05:36 ddennedy Status assigned => resolved
2010-04-07 05:36 ddennedy Fixed in Version => Recent git
2010-04-07 05:36 ddennedy Resolution open => fixed
2010-04-07 05:39 ddennedy Note Added: 0004931
2010-04-07 06:13 ddennedy Note Added: 0004932
2010-09-14 11:01 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:00 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker