Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001236KdenliveUser Interfacepublic2009-11-01 19:562010-10-02 23:04
Reportergsking1 
Assigned To 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusclosedResolutionunable to reproduce 
Platform32 bit intelOSKubuntu LinuxOS Version9.10
Product Version0.7.6 
Target VersionFixed in Version0.7.7 
Summary0001236: Crash when deleting composite transition.
DescriptionI had been messing with options of the composite transition such as keyframes and tweaking transitions settings with a title. Then I decided to delete the transition entirely. This caused the crash.

BackTrace info below..
Additional InformationApplication: Kdenlive (kdenlive), signal: Aborted
[Current thread is 1 (Thread 0xb77f3700 (LWP 10416))]

Thread 3 (Thread 0xac7ffb70 (LWP 10765)):
#0 0x0016f422 in __kernel_vsyscall ()
#1 0x00a27e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0x0148a78d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
0000003 0x00cb780b in consumer_thread (arg=0x88c71b8) at consumer_sdl_preview.c:385
0000004 0x00a2380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000005 0x0147d7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xb2084b70 (LWP 10822)):
#0 0x0016f422 in __kernel_vsyscall ()
#1 0x00a28142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0x0148a7e4 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
0000003 0x004f8429 in mlt_consumer_get_frame (this=0x88d5ee0) at mlt_consumer.c:498
0000004 0x004f8588 in mlt_consumer_rt_frame (this=0x88d5ee0) at mlt_consumer.c:896
0000005 0x00cb7f64 in consumer_thread (arg=0x88d5ee0) at consumer_sdl_still.c:556
0000006 0x00a2380e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000007 0x0147d7ee in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb77f3700 (LWP 10416)):
[KCrash Handler]
0000006 0x0016f422 in __kernel_vsyscall ()
0000007 0x013db4d1 in raise () from /lib/tls/i686/cmov/libc.so.6
0000008 0x013de932 in abort () from /lib/tls/i686/cmov/libc.so.6
0000009 0x01411ee5 in ?? () from /lib/tls/i686/cmov/libc.so.6
0000010 0x0141bff1 in ?? () from /lib/tls/i686/cmov/libc.so.6
0000011 0x0141d6f2 in ?? () from /lib/tls/i686/cmov/libc.so.6
0000012 0x0142079d in free () from /lib/tls/i686/cmov/libc.so.6
0000013 0x004f9f1b in mlt_transition_close (this=0x400) at mlt_transition.c:384
0000014 0x004f1fbf in mlt_service_close (this=0x9c2f4e8) at mlt_service.c:620
0000015 0x004f21db in mlt_service_connect_producer (this=0x9c43c40, producer=0x9c3d4d8, index=4) at mlt_service.c:255
0000016 0x004fa6e0 in mlt_field_disconnect_service (self=0x9c2df38, service=0x9c40b00) at mlt_field.c:260
0000017 0x080cb434 in Render::mltDeleteTransition (this=0x88c69a0, tag=..., b_track=6, in=..., out=...) at /home/gsking/programs/src/kdenlive-0.7.6/src/renderer.cpp:3039
0000018 0x08129f77 in CustomTrackView::deleteTransition (this=0x94541b0, transitionInfo=..., endTrack=4, refresh=<value optimized out>)
    at /home/gsking/programs/src/kdenlive-0.7.6/src/customtrackview.cpp:1893
0000019 0x08220375 in AddTransitionCommand::redo (this=0xa9df780) at /home/gsking/programs/src/kdenlive-0.7.6/src/addtransitioncommand.cpp:52
0000020 0x07840973 in QUndoCommand::redo (this=0xaa389e8) at util/qundostack.cpp:209
0000021 0x07842135 in QUndoStack::push (this=0x8f89e98, cmd=0xaa389e8) at util/qundostack.cpp:543
0000022 0x08134740 in CustomTrackView::deleteSelectedClips (this=0x94541b0) at /home/gsking/programs/src/kdenlive-0.7.6/src/customtrackview.cpp:3214
0000023 0x080a0b5d in MainWindow::qt_metacall (this=0x854cf18, _c=QMetaObject::InvokeMetaMethod, _id=0, _a=0xbfd028f8)
    at /home/gsking/programs/src/kdenlive-0.7.6/build/src/cmake_bindir/mainwindow.moc:319
0000024 0x02220263 in QMetaObject::activate (sender=0x8cc90a8, from_signal_index=5, to_signal_index=6, argv=0xbfd028f8) at kernel/qobject.cpp:3113
0000025 0x022206d8 in QMetaObject::activate (sender=0x8cc90a8, m=0x82d6740, from_local_signal_index=1, to_local_signal_index=2, argv=0xbfd028f8) at kernel/qobject.cpp:3207
0000026 0x071b79b1 in QAction::triggered (this=0x8cc90a8, _t1=false) at .moc/release-shared/moc_qaction.cpp:236
0000027 0x071b8f32 in QAction::activate (this=0x8cc90a8, event=QAction::Trigger) at kernel/qaction.cpp:1160
0000028 0x071bba18 in QAction::event (this=0x6, e=0x0) at kernel/qaction.cpp:1079
0000029 0x005edeb3 in KAction::event (this=0x8cc90a8, event=0xbfd02d48) at ../../kdeui/actions/kaction.cpp:88
0000030 0x071bdf54 in QApplicationPrivate::notify_helper (this=0x84add80, receiver=0x8cc90a8, e=0xbfd02d48) at kernel/qapplication.cpp:4056
0000031 0x071c567c in QApplication::notify (this=0xbfd04c7c, receiver=0x8cc90a8, e=0xbfd02d48) at kernel/qapplication.cpp:3603
0000032 0x006d4bfa in KApplication::notify (this=0xbfd04c7c, receiver=0x8cc90a8, event=0xbfd02d48) at ../../kdeui/kernel/kapplication.cpp:302
0000033 0x0220a6cb in QCoreApplication::notifyInternal (this=0xbfd04c7c, receiver=0x8cc90a8, event=0xbfd02d48) at kernel/qcoreapplication.cpp:610
0000034 0x071f6dfd in QCoreApplication::sendEvent (this=0x84ade20, e=0xbfd030f4) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:213
0000035 QShortcutMap::dispatchEvent (this=0x84ade20, e=0xbfd030f4) at kernel/qshortcutmap.cpp:884
0000036 0x071f8c7e in QShortcutMap::tryShortcutEvent (this=0x84ade20, o=0x94541b0, e=0xbfd030f4) at kernel/qshortcutmap.cpp:369
0000037 0x071c6a0d in QApplication::notify (this=0xbfd04c7c, receiver=0x94541b0, e=0xbfd030f4) at kernel/qapplication.cpp:3645
0000038 0x006d4bfa in KApplication::notify (this=0xbfd04c7c, receiver=0x94541b0, event=0xbfd030f4) at ../../kdeui/kernel/kapplication.cpp:302
0000039 0x0220a6cb in QCoreApplication::notifyInternal (this=0xbfd04c7c, receiver=0x94541b0, event=0xbfd030f4) at kernel/qcoreapplication.cpp:610
0000040 0x071bee2e in QCoreApplication::sendSpontaneousEvent (receiver=0x94541b0, event=0x6) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:216
0000041 qt_sendSpontaneousEvent (receiver=0x94541b0, event=0x6) at kernel/qapplication.cpp:4958
0000042 0x0725b440 in QKeyMapper::sendKeyEvent (keyWidget=0x94541b0, grab=false, type=QEvent::KeyPress, code=16777223, modifiers=..., text=..., autorepeat=<value optimized out>,
    count=<value optimized out>, nativeScanCode=119, nativeVirtualKey=65535, nativeModifiers=16) at kernel/qkeymapper_x11.cpp:1861
0000043 0x0725d989 in QKeyMapperPrivate::translateKeyEvent (this=0x84d9a18, keyWidget=0x94541b0, event=0xbfd048dc, grab=false) at kernel/qkeymapper_x11.cpp:1831
0000044 0x07231ed7 in QApplication::x11ProcessEvent (this=0xbfd04c7c, event=0xbfd048dc) at kernel/qapplication_x11.cpp:3443
0000045 0x0725f502 in x11EventSourceDispatch (s=0x84b0f68, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
0000046 0x03af0e78 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000047 0x03af4720 in ?? () from /lib/libglib-2.0.so.0
0000048 0x03af4853 in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000049 0x0223502c in QEventDispatcherGlib::processEvents (this=0x8497cc8, flags=...) at kernel/qeventdispatcher_glib.cpp:327
0000050 0x0725ebe5 in QGuiEventDispatcherGlib::processEvents (this=0x8497cc8, flags=...) at kernel/qguieventdispatcher_glib.cpp:202
0000051 0x02208c79 in QEventLoop::processEvents (this=0xbfd04bd4, flags=) at kernel/qeventloop.cpp:149
0000052 0x022090ca in QEventLoop::exec (this=0xbfd04bd4, flags=...) at kernel/qeventloop.cpp:201
0000053 0x0220b53f in QCoreApplication::exec () at kernel/qcoreapplication.cpp:888
0000054 0x071bddd7 in QApplication::exec () at kernel/qapplication.cpp:3525
0000055 0x080804bd in main (argc=1, argv=0xbfd04e74) at /home/gsking/programs/src/kdenlive-0.7.6/src/main.cpp:86
TagsNo tags attached.
Build/Install MethodManual build from release
Attached Files

- Relationships

-  Notes
(0004229)
j-b-m (administrator)
2009-11-02 12:00

Cannot reproduce... It would be great if you can find a way to reproduce that issue starting from a blank document...
(0005947)
ttill (developer)
2010-10-02 23:04

Closing, lack of response.

- Issue History
Date Modified Username Field Change
2009-11-01 19:56 gsking1 New Issue
2009-11-01 19:56 gsking1 Build/Install Method => Manual build from release
2009-11-02 12:00 j-b-m Note Added: 0004229
2009-11-02 12:00 j-b-m Status new => feedback
2010-10-02 23:04 ttill Status feedback => resolved
2010-10-02 23:04 ttill Resolution open => unable to reproduce
2010-10-02 23:04 ttill Fixed in Version => 0.7.7
2010-10-02 23:04 ttill Note Added: 0005947
2010-10-02 23:04 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker