Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001249KdenliveFile Loadingpublic2009-11-06 17:202010-02-20 08:17
ReporterBigWhale 
Assigned Toj-b-m 
PriorityhighSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformIntel Core2QuadOSUbuntuOS Version9.10
Product Version0.7.6 
Target VersionFixed in Version0.7.7 
Summary0001249: Each time that appended file is loaded Kdenlive will segfault
DescriptionTitle says it all. I was working on a project which had two video tracks each containing one clip (a .png file) and I had a transition between them. Them I added a bunch of .wav clips and added two audio tracks. There was a lot of cutting on the audio tracks.

Later I removed video tracks since I didn't need them at that point. I wanted to add them later.

I am doing a voiceover for a bunch of slides. Wav files are 16 bit 16kHz and slides were .png files.

Now each time I try to open the project file Kdenlive blows up and segfaults.

Steps To ReproduceTry opening attached file.
Additional Information4 hours of work are gone ... :(
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files? file icon Ubuntu Release English Talk.kdenlive [^] (30,933 bytes) 2009-11-06 17:20
? file icon crash3.kdenlive [^] (30,276 bytes) 2009-11-06 23:04

- Relationships
has duplicate 0001254closedj-b-m Crash when opening Kdenlive Project file (Segmentation Fault) 

-  Notes
(0004249)
j-b-m (administrator)
2009-11-06 23:05

You have an invalid transition in the project file. I removed it and uploaded the doc as crash3.kdenlive

Can you try to open the file and tell me if you still get the crash or if any error message is displayed?
(0004250)
BigWhale (reporter)
2009-11-07 07:56

It works now. I wonder how that transition got there and why I didn't see it when I was inspecting the file ... :)

Thanks for the help and quick response! Very much appreciated.
(0004251)
j-b-m (administrator)
2009-11-07 08:17

Great. The transition was not visible in Kdenlive, and it was corrupted because of a bug in Kdenlive when deleting a track. I fixed the issue that corrupted the transition and the crash on loading in Kdenlive svn now.

- Issue History
Date Modified Username Field Change
2009-11-06 17:20 BigWhale New Issue
2009-11-06 17:20 BigWhale File Added: Ubuntu Release English Talk.kdenlive
2009-11-06 17:20 BigWhale Build/Install Method => Distribution package
2009-11-06 23:04 j-b-m File Added: crash3.kdenlive
2009-11-06 23:05 j-b-m Note Added: 0004249
2009-11-06 23:05 j-b-m Status new => feedback
2009-11-07 07:56 BigWhale Note Added: 0004250
2009-11-07 08:17 j-b-m Note Added: 0004251
2009-11-07 08:17 j-b-m Status feedback => resolved
2009-11-07 08:17 j-b-m Fixed in Version => Recent git
2009-11-07 08:17 j-b-m Resolution open => fixed
2009-11-07 08:17 j-b-m Assigned To => j-b-m
2009-11-10 10:19 j-b-m Relationship added has duplicate 0001254
2010-02-02 10:34 j-b-m Fixed in Version Recent git => 0.7.7
2010-02-20 08:17 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker