Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001254KdenliveFile Loadingpublic2009-11-09 07:372010-10-02 23:06
ReporterCharlie 
Assigned Toj-b-m 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformDell Precision M65 LaptopOSUbuntu (Karmic)OS Version9.10
Product Version0.7.6 
Target VersionFixed in Version0.7.7 
Summary0001254: Crash when opening Kdenlive Project file (Segmentation Fault)
DescriptionCrash occurs after reopening a previous project that locked up Kdenlive while playing the project. That lock-up appeared to happen while playing a title clip with text only that had a Composite transition with 4 keyframes defined to make the text "fly" into the scene (starting small going to normal size) and then back out. Not an overly complicated transition. I had started Kdenlive from the command line and saw the following message repeat several times prior to the lock-up:

QObject::startTimer: QTimer can only be used with threads started with QThread

After "killing" Kdenlive, restarting then reopening the saved project, this is when the segmentation fault crash occurs.
Steps To ReproduceOpening a project that previously locked-up with QTimer errors.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filestxt file icon kdenlive-20091108.txt [^] (5,499 bytes) 2009-11-09 07:37 [Show Content]
? file icon Eli Test Video.kdenlive [^] (29,460 bytes) 2009-11-10 03:59
? file icon Eli+Fixed.kdenlive [^] (28,459 bytes) 2009-11-10 10:20

- Relationships
duplicate of 0001249closedj-b-m Each time that appended file is loaded Kdenlive will segfault 

-  Notes
(0004254)
Charlie (reporter)
2009-11-09 07:49

Sorry for the duplicate bug report. Don't know why the system posted it twice. Also, I missed reported the platform of my laptop; I'm using 32-bit Ubuntu Karmic.
(0004256)
j-b-m (administrator)
2009-11-09 23:06

Looks like your project file is corrupted... could you attach it here (the .kdenlive project file)
(0004262)
Charlie (reporter)
2009-11-10 04:01

That would make sense that the project is corrupted since I had the lockup while playing the project on the title clip I described above. I have attached my project file and I hope it helps.
(0004265)
j-b-m (administrator)
2009-11-10 10:21

This is a duplicate of issue 0001249.
Issue was fixed in svn. I attached the fixed project file that you should be able to open.
(0004268)
Charlie (reporter)
2009-11-10 18:19

The project file opens now without seg-faulting.

Will this fix be in the next release or patched with an update?

Thanks for the fix and quick responses!

- Issue History
Date Modified Username Field Change
2009-11-09 07:37 Charlie New Issue
2009-11-09 07:37 Charlie File Added: kdenlive-20091108.txt
2009-11-09 07:37 Charlie Build/Install Method => Distribution package
2009-11-09 07:49 Charlie Note Added: 0004254
2009-11-09 23:06 j-b-m Note Added: 0004256
2009-11-09 23:06 j-b-m Status new => feedback
2009-11-10 03:59 Charlie File Added: Eli Test Video.kdenlive
2009-11-10 04:01 Charlie Note Added: 0004262
2009-11-10 10:19 j-b-m Relationship added duplicate of 0001249
2009-11-10 10:20 j-b-m File Added: Eli+Fixed.kdenlive
2009-11-10 10:21 j-b-m Note Added: 0004265
2009-11-10 18:19 Charlie Note Added: 0004268
2010-10-02 23:06 ttill Assigned To => j-b-m
2010-10-02 23:06 ttill Status feedback => resolved
2010-10-02 23:06 ttill Resolution open => fixed
2010-10-02 23:06 ttill Fixed in Version => 0.7.7
2010-10-02 23:06 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker