Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001265KdenliveRenderingpublic2009-11-10 20:022011-10-02 12:52
Reportertidris769 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityalways
StatusfeedbackResolutionopen 
Platform32 bit intel and alikeOSUbuntu LinuxOS Version9.04
Product VersionRecent git 
Target VersionFixed in Version 
Summary0001265: Cannot render if two copies of kdenlive are running
DescriptionIf two copies of kdenlive are running simultaneously, the second copy will be unable to render in some cases. No error message or warning is displayed, all the user sees is the render job in the second copy waiting forever.

I have ended with two copies of kdenlive running simultaneously by accident several times. You know, open first copy, go away from computer for a while, come back and open second copy because I forgot the first copy was already open and the window for the first copy was hidden behind other windows.
Steps To Reproduce1- Make sure no copies of kdenlive are running.
2- Launch kdenlive. Create a color clip, add to a track, render the project. Wait for render to finish. Leave kdenlive running.
3- Launch second copy of kdenlive. Create color clip, add to a track, render the project. Notice the rendering job stays in the "Waiting..." state forever.

Additional InformationUsing rev 4104.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0007084)
eSyr (reporter)
2011-07-14 10:36

Looks like project is rendering fine, but job have attached to another job manager. This leads to another, much more severe problem: if some job in waiting queue have been started manually, then it starts, but job manager, in which queue this job stated, doesn't know anything about this. And it starts job (again), when other jobs have been completed already. And this leads to two jobs rendering to single file (and failing doing it correctly). This bugs costs me about several hundreds of hours of cpu time.
(0007391)
j-b-m (administrator)
2011-10-02 12:52

This should finally be fixed in svn rev. 5936

- Issue History
Date Modified Username Field Change
2009-11-10 20:02 tidris769 New Issue
2009-11-10 20:02 tidris769 Build/Install Method => Manual build from SVN
2011-07-14 10:36 eSyr Note Added: 0007084
2011-10-02 12:52 j-b-m Note Added: 0007391
2011-10-02 12:52 j-b-m Assigned To => j-b-m
2011-10-02 12:52 j-b-m Status new => feedback


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker