Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001299KdenliveFile Loadingpublic2009-11-21 16:412009-11-30 22:06
ReporterMunaciello 
Assigned To 
PriorityhighSeveritycrashReproducibilityalways
StatusfeedbackResolutionopen 
Platform32 bit intel and alikeOSUbuntu LinuxOS Version9.10
Product Version0.7.6 
Target VersionFixed in Version 
Summary0001299: Crash for pulseaudio or WMV?
DescriptionOpened KDEnlive and try to load a wmv clip.
As soon as the load operation are closed through the Project Tree view, KDEnlive crashes. On the other hand, while doing the load operation, KDEnlive shows me a notification message about some imposibility to do something with my audio card.
Steps To ReproduceOpen KDEnlive.
Try to load a WMV file.
Additional InformationAudio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

Kernel 2.6.31-14-generic

KDEnlive produced a "usevul" kcrash file but I'm unable to attach it to this bug report.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filestxt file icon kdenlive-20091121.kcrash.txt [^] (8,892 bytes) 2009-11-21 16:41 [Show Content]
txt file icon kdenlive-20091128.kcrash.txt [^] (1,195 bytes) 2009-11-28 09:58 [Show Content]

- Relationships

-  Notes
(0004321)
Granjow (developer)
2009-11-21 16:44

WMV only? Could you try a different video format? Google for the error message kdenlive gives you? Try different settings in Preferences > Playback (or so) > Audio driver?

(Yes I know, mantis again. I'll delete the other bug.)

Ah, and what is your mlt version? (standard question)
(0004323)
Munaciello (reporter)
2009-11-21 17:13

No, sorry. The problem persists even with other video types: tried with 2 AVI files and an MP4, too.

mlt-python 0.4.7e-0ubuntu4~ppa1k

As for audio driver, I've just set to Automatic, ALSA and before it was set on Pulseaudio: the crashes continue.

KDEnlive error message (running from terminal) is:

kdenlive
<unknown>: Fatal IO error 9 (Bad file descriptor) on X server :0.0.
KCrash: Application 'kdenlive' crashing...
sock_file=/home/manolo/.kde/socket-manolo-laptop/kdeinit4__0
Assertion 'pa_close(fds[0]) == 0' failed at pulsecore/core-util.c:2165, function pa_close_pipe(). Aborting.
Unable to start Dr. Konqi
(0004326)
Granjow (developer)
2009-11-21 17:57

Uh, this does not sound cool.
Could you try installing mlt 0.4.6? There were problems with 0.4.7. Does not sound related to the ones we experienced, but might be worth a try.
(0004329)
Munaciello (reporter)
2009-11-22 00:06

Actually I've got:

mlt-python 0.4.7e-0ubuntu4~ppa1k
libmlt1 0.4.6-0ubuntu0~karmic2
libmlt++2 0.4.6-0ubuntu0~karmic2
libmlt-data 0.4.6-0ubuntu0~karmic2

Could it be a problem having that mix of 0.4.6 and 0.4.7 versions?
(0004330)
Munaciello (reporter)
2009-11-22 12:34

Granjow, what should I do in order not to make mess with KDEnlive, MLT, OpenShot and so on?

Should I remove all of those packages of above? Could you please send me a link where to download the correct mlt packages (possibly .deb)?

Thanks for your time.
(0004331)
xzhayon (developer)
2009-11-23 00:16

the mix shouldn't be a problem, since mlt-python should only contain python bindings to mlt library... problems could then arise in openshot, but not in kdenlive or mlt itself, i think

could you try setting the audio driver to OSS?
and could you try running `melt VIDEOFILE`?
(0004332)
Munaciello (reporter)
2009-11-23 02:31

xzhayon, thanks for your reply.

Changing from ALSA to OSS did not prevented KDEnlive to crash.

On the other hand, melt executed the video file perfectly!
(0004355)
Munaciello (reporter)
2009-11-26 10:03

Bump :(
(0004356)
xzhayon (developer)
2009-11-26 14:11

ok, i've read the crash report
as far as i understand, it's something about mlt trying to fetch a NULL producer... i'll try to look into this, but i won't assign the issue to me

please, confirm: you get the crash when importing, in a NEW project, ANY kind of (video?) file, with ANY kind of audio driver selected... correct?
and that message about your audio card... does it pop out even when you select OSS as the audio driver? can you write the exact message?
(0004358)
Munaciello (reporter)
2009-11-26 14:39

xzhayon thanks for your time.
Unfortunately my problems with KDEnlive persist and as time passes I'm trying different solutions which led me to different conditions.

All that I've been writing was true when I wrote it.
At the moment the crash produces, whichever is the selected audio driver, just as for .wmv video files.

More infos here:
http://www.kdenlive.org/forum/audio-problems-when-editing-videos [^]
(0004365)
ddennedy (developer)
2009-11-28 04:48

The reason the Phonon messages appear even though Kdenlive does not directly use Phonon for the multimedia subsystem is because KDE via Kdenlive is trying to raise some notification (as seen in Thread 6 of the attached backtrace).

The real crashing bug is in Thread 2, which is related to audio thumbnailing. However, it is not clear from the backtrace what the problem is, and I am not familiar with that part of the code. You should see if it helps to turn off audio thumbnails in the Kdenlive Settings.

I see you are using Ubuntu 9.10. You must install libsdl1.2debian-pulseaudio for Kdenlive to work properly.
(0004368)
Munaciello (reporter)
2009-11-28 10:04

ddennedy, thanks for your time.

As for the Phonon message, they appear when running Amarok too even if audio seems to work fine with it.

Yesterday I've been running Computer Janitor which removed a lot of "unsupported" programs and libraries. As a result, today I'm completely unable to start KDEnlive. The crash report kdenlive-20091128.kcrash.txt is attached and downloadable from here:
http://www.kdenlive.org/mantis/file_download.php?file_id=596&type=bug [^]

libsdl1.2debian-pulseaudio 1.2.13-4ubuntu4 was already installed. I reinstalled it together with kdenlive, kdenlive-data and kdenlive-dbg but I'm still unable to run kdenlive at all.

Any suggestion, please?
Thanks for your time.
(0004369)
Granjow (developer)
2009-11-28 10:18

Could you try a
# alsa froce-reload
and then start kdenlive or amarok?
(0004370)
Munaciello (reporter)
2009-11-28 14:40

~$ alsa force-reload
Terminating processes: 2007 2648 (failed: processes still using sound devices: 2667(pulseaudio)).
/sbin/alsa: Warning: Processes using sound devices: 2667(pulseaudio).
mkdir: cannot create directory `/var/run/alsa': Permission denied
/sbin/alsa: Warning: Failed to create /var/run/alsa/.
/sbin/alsa: Warning: Not keeping list of removed modules because /var/run/alsa is absent.
It will not be possible automatically to reload these modules.
Unloading ALSA sound driver modules:/sbin/alsa: 219: cannot create /var/run/alsa/modules-removed: Directory nonexistent
 snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm-oss snd-mixer-oss snd-pcm snd-seq-dummy snd-seq-oss snd-seq-midi snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc.
mkdir: cannot create directory `/var/run/alsa': Permission denied
Loading ALSA sound driver modules: (none to reload).

~$ sudo alsa force-reload
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/manolo/.gvfs
      Output information may be incomplete.
Terminating processes: 1913 2667lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/manolo/.gvfs
      Output information may be incomplete.
 2749lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/manolo/.gvfs
      Output information may be incomplete.
 2788lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/manolo/.gvfs
      Output information may be incomplete.
 2811lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/manolo/.gvfs
      Output information may be incomplete.
 (with SIGKILL:) 2849lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/manolo/.gvfs
      Output information may be incomplete.
 (failed: processes still using sound devices: 2897(pulseaudio)).
lsof: WARNING: can't stat() fuse.gvfs-fuse-daemon file system /home/manolo/.gvfs
      Output information may be incomplete.
/sbin/alsa: Warning: Processes using sound devices: 2897(pulseaudio).
Unloading ALSA sound driver modules: snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm-oss snd-mixer-oss snd-pcm snd-seq-dummy snd-seq-oss snd-seq-midi snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc (failed: modules still loaded: snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm snd-timer snd-page-alloc).
Loading ALSA sound driver modules: snd-hda-codec-realtek snd-hda-intel snd-hda-codec snd-hwdep snd-pcm-oss snd-mixer-oss snd-pcm snd-seq-dummy snd-seq-oss snd-seq-midi snd-rawmidi snd-seq-midi-event snd-seq snd-timer snd-seq-device snd-page-alloc.

After that, the Phonon message appeared but I'm still unable to run KDEnlive,which crashes as before.
(0004378)
Munaciello (reporter)
2009-11-30 12:35

Bump.
(0004379)
ddennedy (developer)
2009-11-30 17:56

Are you able to run Kdenlive long enough to access the Settings dialog and turn off audio thumbnails? And if you can get that far, can you create a Color Clip before trying to load any a/v clip?
(0004387)
Munaciello (reporter)
2009-11-30 22:06

ddennedy, thanks for your reply and sorry for not replying about thumbnails before.

AFAICR, I disabled audio thumbnailing but the problem persisted. Of course, now I cannot check it since KDEnlive interface doesn't run at all: just the "crash report" interface is shown. Also, running KDEnlive from terminal I get:

~$ kdenlive
KCrash: Application 'kdenlive' crashing...
sock_file=/home/manolo/.kde/socket-manolo-laptop/kdeinit4__0
Warning: connect() failed: : No such file or directory
KCrash cannot reach kdeinit, launching directly.

[1]+ Stopped kdenlive

Purging and reinstalling KDEnlive and related packages hasn't solved this problem.

Another question: Kdenlive is shown into the
 Applications -> Others

menu... I expected to find it into the
 Applications -> Sound & Video

menu. Is it somehow related to my problems? (I know... silly question...)

Thanks for your time.
Regards.

- Issue History
Date Modified Username Field Change
2009-11-21 16:41 Munaciello New Issue
2009-11-21 16:41 Munaciello File Added: kdenlive-20091121.kcrash.txt
2009-11-21 16:41 Munaciello Build/Install Method => Distribution package
2009-11-21 16:44 Granjow Note Added: 0004321
2009-11-21 16:44 Granjow Status new => feedback
2009-11-21 16:44 Granjow OS => Ubuntu Linux
2009-11-21 16:44 Granjow OS Version => 9.10
2009-11-21 16:44 Granjow Platform => 32 bit intel and alike
2009-11-21 17:13 Munaciello Note Added: 0004323
2009-11-21 17:57 Granjow Note Added: 0004326
2009-11-22 00:06 Munaciello Note Added: 0004329
2009-11-22 12:34 Munaciello Note Added: 0004330
2009-11-23 00:16 xzhayon Note Added: 0004331
2009-11-23 02:31 Munaciello Note Added: 0004332
2009-11-26 10:03 Munaciello Note Added: 0004355
2009-11-26 14:11 xzhayon Note Added: 0004356
2009-11-26 14:39 Munaciello Note Added: 0004358
2009-11-28 04:48 ddennedy Note Added: 0004365
2009-11-28 09:58 Munaciello File Added: kdenlive-20091128.kcrash.txt
2009-11-28 10:04 Munaciello Note Added: 0004368
2009-11-28 10:18 Granjow Note Added: 0004369
2009-11-28 14:40 Munaciello Note Added: 0004370
2009-11-30 12:35 Munaciello Note Added: 0004378
2009-11-30 17:56 ddennedy Note Added: 0004379
2009-11-30 22:06 Munaciello Note Added: 0004387


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker