Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001312KdenliveMLTpublic2009-11-25 20:392010-02-20 08:17
ReporterWeevil 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSUbuntu LinuxOS Version9.10
Product VersionRecent git 
Target VersionFixed in Version0.7.7 
Summary0001312: File loading: Crash when loading images with 10.06 aspect ratio.
DescriptionWhen loading a file with aspect ratio of about 10.06 (width divided by hight) Kdenlive crashes. At least this seems to be the case so far as I have been able to pin down.
Steps To ReproduceLoad an image with aspect ratio of about 10.06.
Additional InformationAdded are backtrace, jpg, png and gif file that crash Kdenlive.

./kdenlive_start --version
Kdenlive Builder Wizard version: 0.9.90
frei0r: commit 7a54884be6e7969397b913b865f4d815b6cdc385 Date: Mon Nov 9 14:06:50 2009 +0100
ffmpeg: Revision: 20601 Last Changed Date: 2009-11-24 16:54:17 +0100 (Tue, 24 Nov 2009)
mlt: commit a807fb153824fd78325728d424fb86bea38fb8e6 Date: Sat Nov 21 00:08:02 2009 -0800
kdenlive: Revision: 4144 Last Changed Date: 2009-11-24 12:37:39 +0100 (Tue, 24 Nov 2009)
Qt: 4.5.2
KDE: 4.3.2 (KDE 4.3.2)
Kdenlive: 0.7.7 (rev. 4144)
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Filesgz file icon images_backtrace.tar.gz [^] (3,343 bytes) 2009-11-25 20:39
png file icon 1006x100.png [^] (462 bytes) 2010-01-19 12:42

- Relationships

-  Notes
(0004534)
j-b-m (administrator)
2010-01-19 12:41
edited on: 2010-01-19 12:47

I can confirm the crash. For me it looks like an MLT issue. The crash somehow happens when resizing the image. You can reproduce in melt by creating a profile with width=48 and height=36 for example (it seems to be triggered by small image sizes).

For a test, edit width / height of the cif_pal profile to 48X36, then just call:
melt -profile cif_pal 1006x100.png

It crashes.
I uploaded the 1006x100.png image for easier testing

(0004535)
ddennedy (developer)
2010-01-19 18:30

The smallest image the scaler can produce is 6x6. My hunch is that it hits this limit and then the rescale (pad) filter assumes scaling succeeded (or rescale sets some properties incorrectly). So, I expect to be able to fix the crash but perhaps not give you an interesting result. I will look into this further soon.
(0004537)
ddennedy (developer)
2010-01-20 06:37

Fixed in mlt git commit d9df508.

- Issue History
Date Modified Username Field Change
2009-11-25 20:39 Weevil New Issue
2009-11-25 20:39 Weevil File Added: images_backtrace.tar.gz
2009-11-25 20:39 Weevil Build/Install Method => Build Wizard
2010-01-19 12:41 j-b-m Note Added: 0004534
2010-01-19 12:41 j-b-m Status new => acknowledged
2010-01-19 12:42 j-b-m File Added: 1006x100.png
2010-01-19 12:42 j-b-m Category File Loading => MLT
2010-01-19 12:47 j-b-m Note Edited: 0004534 View Revisions
2010-01-19 18:30 ddennedy Note Added: 0004535
2010-01-20 06:37 ddennedy Note Added: 0004537
2010-01-20 06:37 ddennedy Status acknowledged => resolved
2010-01-20 06:37 ddennedy Resolution open => fixed
2010-01-20 06:37 ddennedy Assigned To => ddennedy
2010-02-02 10:34 j-b-m Fixed in Version => 0.7.7
2010-02-20 08:17 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker