Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001329KdenliveBuild Systempublic2009-11-30 14:492010-02-20 08:17
Reporterassem046 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformX64OSopenSusseOS Version11.2
Product VersionRecent git 
Target VersionFixed in Version0.7.7 
Summary0001329: Kdenlive svn would not compile.
DescriptionI try to compile kdenlive svn 4161 and it exits with following output:

[ 0%] Built target kdenlive_automoc
[ 1%] Generating ui_keyframeeditor_ui.h
[ 2%] Generating kdenlivesettings.h, kdenlivesettings.cpp
[ 2%] Generating mainwindowadaptor.cpp, mainwindowadaptor.h
[ 3%] Generating mainwindowadaptor.moc
[ 3%] Generating ui_timeline_ui.h
[ 4%] Generating ui_monitor_ui.h
[ 4%] Generating ui_recmonitor_ui.h
[ 5%] Generating ui_colorclip_ui.h
[ 6%] Generating ui_slideshowclip_ui.h
[ 6%] Generating ui_configmisc_ui.h
[ 7%] Generating ui_configenv_ui.h
[ 7%] Generating ui_configdisplay_ui.h
[ 8%] Generating ui_configsdl_ui.h
[ 8%] Generating ui_configcapture_ui.h
[ 9%] Generating ui_configtranscode_ui.h
[ 9%] Generating ui_effectlist_ui.h
[ 10%] Generating ui_effectstack_ui.h
[ 10%] Generating ui_profiledialog_ui.h
[ 11%] Generating ui_projectsettings_ui.h
[ 12%] Generating ui_keyframewidget_ui.h
[ 12%] Generating ui_constval_ui.h
[ 13%] Generating ui_listval_ui.h
[ 13%] Generating ui_wipeval_ui.h
[ 14%] Generating ui_boolval_ui.h
[ 14%] Generating ui_colorval_ui.h
[ 15%] Generating ui_positionval_ui.h
[ 15%] Generating ui_titlewidget_ui.h
[ 16%] Generating ui_unicodedialog_ui.h
[ 17%] Generating ui_timelinebuttons_ui.h
[ 17%] Generating ui_renderwidget_ui.h
[ 18%] Generating ui_saveprofile_ui.h
[ 18%] Generating ui_transitionsettings_ui.h
[ 19%] Generating ui_configjogshuttle_ui.h
[ 19%] Generating ui_trackheader_ui.h
[ 20%] Generating ui_clipproperties_ui.h
'verticalSpacer_3' isn't a valid widget
[ 20%] Generating ui_markerdialog_ui.h
'verticalSpacer' isn't a valid widget
[ 21%] Generating ui_keyframedialog_ui.h
[ 22%] Generating ui_clipdurationdialog_ui.h
[ 22%] Generating ui_managecaptures_ui.h
[ 23%] Generating ui_geometryval_ui.h
[ 23%] Generating ui_wizardstandard_ui.h
[ 24%] Generating ui_wizardextra_ui.h
[ 24%] Generating ui_wizardcheck_ui.h
[ 25%] Generating ui_wizardmltcheck_ui.h
[ 25%] Generating ui_spacerdialog_ui.h
[ 26%] Generating ui_addtrack_ui.h
[ 27%] Generating ui_dvdwizardvob_ui.h
[ 27%] Generating ui_dvdwizardmenu_ui.h
[ 28%] Generating ui_dvdwizardstatus_ui.h
[ 28%] Generating ui_dvdwizardchapters_ui.h
[ 29%] Generating ui_missingclips_ui.h
[ 29%] Generating ui_cliptranscode_ui.h
[ 30%] Generating ui_geometryposition_ui.h
[ 30%] Generating ui_templateclip_ui.h
Scanning dependencies of target kdenlive
[ 30%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/kdenlive_automoc.o
[ 31%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/jogshuttle.o
[ 31%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/addclipcommand.o
[ 32%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/main.o
[ 32%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/mainwindow.o
[ 33%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/customruler.o
[ 33%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/smallruler.o
[ 34%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/projectlist.o
[ 34%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/projectitem.o
[ 35%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/monitor.o
[ 36%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/gentime.o
[ 36%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/renderer.o
/usr/src/packages/BUILD/kdenlive-0.7.7/src/renderer.cpp:2021: warning: unused parameter ‘oldspeed’
/usr/src/packages/BUILD/kdenlive-0.7.7/src/renderer.cpp:2809: warning: unused parameter ‘insert’
[ 37%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/kdenlivedoc.o
[ 37%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/projectlistview.o
[ 38%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/trackview.o
[ 38%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/docclipbase.o
/usr/src/packages/BUILD/kdenlive-0.7.7/src/docclipbase.cpp: In member function ‘void DocClipBase::setProperty(const QString&, const QString&)’:
/usr/src/packages/BUILD/kdenlive-0.7.7/src/docclipbase.cpp:814: error: call of overloaded ‘setProducerProperty(const char [19], NULL)’ is ambiguous
/usr/src/packages/BUILD/kdenlive-0.7.7/src/docclipbase.cpp:608: note: candidates are: void DocClipBase::setProducerProperty(const char*, const char*)
/usr/src/packages/BUILD/kdenlive-0.7.7/src/docclipbase.cpp:592: note: void DocClipBase::setProducerProperty(const char*, int)
/usr/src/packages/BUILD/kdenlive-0.7.7/src/docclipbase.cpp:600: note: void DocClipBase::setProducerProperty(const char*, double)
/usr/src/packages/BUILD/kdenlive-0.7.7/src/docclipbase.cpp:819: error: call of overloaded ‘setProducerProperty(const char [18], NULL)’ is ambiguous
/usr/src/packages/BUILD/kdenlive-0.7.7/src/docclipbase.cpp:608: note: candidates are: void DocClipBase::setProducerProperty(const char*, const char*)
/usr/src/packages/BUILD/kdenlive-0.7.7/src/docclipbase.cpp:592: note: void DocClipBase::setProducerProperty(const char*, int)
/usr/src/packages/BUILD/kdenlive-0.7.7/src/docclipbase.cpp:600: note: void DocClipBase::setProducerProperty(const char*, double)
make[2]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/docclipbase.o] Fout 1
make[1]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/all] Fout 2
make: *** [all] Fout 2
TagsNo tags attached.
Build/Install Method(select)
Attached Filestxt file icon kdenlive.4161.compile.txt [^] (27,450 bytes) 2009-11-30 22:06 [Show Content]

- Relationships

-  Notes
(0004383)
Granjow (developer)
2009-11-30 19:41
edited on: 2009-11-30 23:02

Could you try a «make clean» before compiling?
r4161 compiles here without any problem.

edit: gcc version 4.3.4

(0004386)
assem046 (reporter)
2009-11-30 22:05

I build RPM's for openSuse. I attached a file with the complete output. I removed the installed version svn 4151 and the source folder. Downloaded it again make no difference.
Note: I build my packages with 0.7.7 version number so it is always newer than packman versions.
(0004389)
mfranz (reporter)
2009-11-30 23:09

Same problem here with gcc 4.4.1. And I *did* clean before -- very clean. I have to cast the NULLs with (const char *).
(0004391)
j-b-m (administrator)
2009-12-01 00:16

Can you try to update, should be fixed now (svn rev. 4162)
(0004393)
mfranz (reporter)
2009-12-01 00:54

Works for me. Thanks.
(0004394)
assem046 (reporter)
2009-12-01 10:19

Works for me too. Thanks!

- Issue History
Date Modified Username Field Change
2009-11-30 14:49 assem046 New Issue
2009-11-30 14:49 assem046 Build/Install Method => (select)
2009-11-30 19:41 Granjow Note Added: 0004383
2009-11-30 19:41 Granjow Status new => feedback
2009-11-30 19:41 Granjow Summary Kdenlive svn would compile. => Kdenlive svn would not compile.
2009-11-30 22:05 assem046 Note Added: 0004386
2009-11-30 22:06 assem046 File Added: kdenlive.4161.compile.txt
2009-11-30 23:02 Granjow Note Edited: 0004383 View Revisions
2009-11-30 23:09 mfranz Note Added: 0004389
2009-12-01 00:16 j-b-m Note Added: 0004391
2009-12-01 00:54 mfranz Note Added: 0004393
2009-12-01 10:19 assem046 Note Added: 0004394
2009-12-02 09:19 j-b-m Status feedback => resolved
2009-12-02 09:19 j-b-m Fixed in Version => Recent git
2009-12-02 09:19 j-b-m Resolution open => fixed
2009-12-02 09:19 j-b-m Assigned To => j-b-m
2010-02-02 10:34 j-b-m Fixed in Version Recent git => 0.7.7
2010-02-20 08:17 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker