Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001352KdenliveMLTpublic2009-12-23 05:032010-02-20 08:17
Reporterwseverin 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionno change required 
PlatformDell Inspiron 9100 2GB (32bX86)OSUbuntu LinuxOS Version9.10 (Karmic)
Product Version0.7.6 
Target VersionFixed in Version0.7.7 
Summary0001352: Clip play in Kdenlive hangs due apparent MLT hang
DescriptionClips (and projects) from Sony HDR-XR500 (SD video) hang in play. CPU goes to 100%. Only way out is to kill (not end) Kdenlive and/or MLT.
* No multiple MLT installations. (Completely removed and reinstalled)
* ffplay *will* play the clip
* MELT will not play the clip
* MELT will not play "test_file.kdenlive" (hangs with purple/pink empty window)
Steps To ReproducePlay any SD video clip from Sony HDR-XR500. Sample clip here:

http://theseverinoption.org/video/20091212193900.mpg [^]
Additional InformationInstalled, from Synaptic:
Kdenlive 0.7.6-0ubuntu0~karmic4
Kdenlive-data 0.7.6-0ubuntu0~karmic4
libmlt++2 0.4.10-0ubuntu0~karmic1
libmlt-data 0.4.10-0ubuntu0~karmic1
libmlt1 0.4.10-0ubuntu0~karmic1
frei0r-plugins 1.1.22git20090409+repack
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0004442)
akirk (reporter)
2009-12-23 05:15
edited on: 2009-12-23 05:16

Plays perfectly for me, both melt and kdenlive, using dv_ntsc_wide profile.
Ubuntu 9.10 - AMD64
Qt: 4.5.2
KDE: 4.3.2 (KDE 4.3.2)
Kdenlive: 0.7.7 (rev. 4190)
FFmpeg version SVN-r20672
mlt 4.10

(0004443)
wseverin (reporter)
2009-12-23 06:27

The clip I submitted may be a bit too short to reproduce the problem in every case. The clip is less than ten seconds long which usually illustrates the problem. The timing to hang seems variable. Sometimes play hangs almost immediately, sometimes a clip can play for as long as 15 seconds before hanging. The timing may be environmentally dependent (processor/memory speed, video chipset, phase of moon, etc.)
(0004445)
wseverin (reporter)
2009-12-24 03:59

I think you can mark this as solved. I can't seem to see a way to do that on this web page.

Here's what I found. The important thing that I'd forgotten was that I'd upgraded to ubuntu 9.10 from 9.04 since I'd last used Kdenlive. I went back and tried to play some old videos from a different camcorder, before I'd updated to 9.10, and found that Kdenlive/MLT exhibited the same problems with those clips. Many hours of googling turned up a solution. That is:

Replace the equivalent alsa library with the pulseaudio library libsdl1.2debian-pulseaudio. See the thread in Ubuntu forums here:

http://ubuntuforums.org/showthread.php?t=1309656 [^]

So far this seems to work well, although I've not yet done exhaustive testing.

- Issue History
Date Modified Username Field Change
2009-12-23 05:03 wseverin New Issue
2009-12-23 05:15 akirk Note Added: 0004442
2009-12-23 05:16 akirk Note Edited: 0004442 View Revisions
2009-12-23 06:27 wseverin Note Added: 0004443
2009-12-24 03:59 wseverin Note Added: 0004445
2010-01-03 16:00 j-b-m Status new => resolved
2010-01-03 16:00 j-b-m Resolution open => no change required
2010-01-03 16:00 j-b-m Assigned To => j-b-m
2010-02-02 10:34 j-b-m Fixed in Version => 0.7.7
2010-02-20 08:17 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker