Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001354KdenliveEffectspublic2009-12-23 22:242010-02-20 08:17
Reporterjakob lund 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityhave not tried
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSKubuntu LinuxOS Version8.10
Product Version0.7.5 
Target VersionFixed in Version0.7.7 
Summary0001354: I get a lot of (seemingly) random crashes
DescriptionI installed kdenlive straight from apt-get. It works, and the system-test procedure doesn't complain much. The program looks really good, but crashes too often to be useful, mostly when clicking about effects settings etc (I don't know the first thing about video editing).
Additional InformationCrash report (generated automatically from kdenlive-dbg)

Application that crashed: kdenlive
Version of the application: 0.7.5
KDE Version: 4.3.3 (KDE 4.3.3)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-16-generic i686
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
<In detail, tell us what you were doing when the application crashed.>

 -- Backtrace:
Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0xb771c700 (LWP 4024))]

Thread 3 (Thread 0xaebffb70 (LWP 4556)):
#0 0x004ab422 in __kernel_vsyscall ()
#1 0x00772e15 in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_wait.S:122
0000002 0x06b2678d in __pthread_cond_wait (cond=0x8cc41cc, mutex=0x8cc41fc) at forward.c:139
0000003 0x011ffeab in ?? () from /usr/lib/mlt/libmltsdl.so
0000004 0x0076e80e in start_thread (arg=0xaebffb70) at pthread_create.c:300
0000005 0x06b197ee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 2 (Thread 0xb2993b70 (LWP 4567)):
#0 0x004ab422 in __kernel_vsyscall ()
#1 0x00773142 in pthread_cond_timedwait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i686/../i486/pthread_cond_timedwait.S:179
0000002 0x06b267e4 in __pthread_cond_timedwait (cond=0x8cd2ee0, mutex=0x8cd2ec8, abstime=0xb29931cc) at forward.c:152
0000003 0x00cfb539 in mlt_consumer_get_frame () from /usr/lib/libmlt.so.1
0000004 0x00cfb698 in mlt_consumer_rt_frame () from /usr/lib/libmlt.so.1
0000005 0x0120066c in ?? () from /usr/lib/mlt/libmltsdl.so
0000006 0x0076e80e in start_thread (arg=0xb2993b70) at pthread_create.c:300
0000007 0x06b197ee in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb771c700 (LWP 4024)):
[KCrash Handler]
0000006 GraphicsSceneRectMove::mouseDoubleClickEvent (this=0x973a178, e=0xbfed5744) at /build/buildd/kdenlive-0.7.5/src/graphicsscenerectmove.cpp:129
0000007 0x0515ef67 in QGraphicsScene::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000008 0x04b22f54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000009 0x04b2a67c in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000010 0x00ab114a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
0000011 0x010916cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
0000012 0x0516bafc in QGraphicsView::mouseDoubleClickEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
0000013 0x04b77e47 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000014 0x04f27633 in QFrame::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000015 0x04fc6494 in QAbstractScrollArea::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
0000016 0x0517051f in QGraphicsView::viewportEvent(QEvent*) () from /usr/lib/libQtGui.so.4
0000017 0x04fc8a95 in ?? () from /usr/lib/libQtGui.so.4
0000018 0x0109083a in QCoreApplicationPrivate::sendThroughObjectEventFilters(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
0000019 0x04b22f2c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000020 0x04b2b033 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000021 0x00ab114a in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
0000022 0x010916cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
0000023 0x04b29f6e in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from /usr/lib/libQtGui.so.4
0000024 0x04b987c0 in ?? () from /usr/lib/libQtGui.so.4
0000025 0x04b97c4b in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
0000026 0x04bc4502 in ?? () from /usr/lib/libQtGui.so.4
0000027 0x0156ae88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000028 0x0156e730 in ?? () from /lib/libglib-2.0.so.0
0000029 0x0156e863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000030 0x010bc02c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000031 0x04bc3be5 in ?? () from /usr/lib/libQtGui.so.4
0000032 0x0108fc79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000033 0x010900ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000034 0x0109253f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
0000035 0x04b22dd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
0000036 0x0807d4ed in main (argc=1, argv=0xbfed7934) at /build/buildd/kdenlive-0.7.5/src/main.cpp:89

Report to http://kdenlive.org/mantis [^]
TagsNo tags attached.
Build/Install Method(select)
Attached Files

- Relationships
duplicate of 0001035closedGranjow Application crashed when doubelclicked while editing a Titel. 

-  Notes
(0004448)
jakob lund (reporter)
2009-12-27 12:09

I realize that 0.7.5 is already old. I installed 0.7.6 from the `sunab' ppa, and I get fewer crashes.

This bug report should probably be closed.
(0004450)
j-b-m (administrator)
2009-12-27 18:45

This issue was fixed in Kdenlive 0.7.6, see bug 0001035

- Issue History
Date Modified Username Field Change
2009-12-23 22:24 jakob lund New Issue
2009-12-27 12:09 jakob lund Note Added: 0004448
2009-12-27 18:45 j-b-m Note Added: 0004450
2009-12-27 18:45 j-b-m Relationship added duplicate of 0001035
2009-12-27 18:45 j-b-m Status new => resolved
2009-12-27 18:45 j-b-m Fixed in Version => 0.7.6
2009-12-27 18:45 j-b-m Resolution open => fixed
2009-12-27 18:45 j-b-m Assigned To => j-b-m
2010-02-02 10:34 j-b-m Fixed in Version 0.7.6 => 0.7.7
2010-02-20 08:17 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker