Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001360KdenliveUser Interfacepublic2009-12-30 11:282010-02-20 08:16
Reportermayiv 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSKubuntu LinuxOS Version9.10
Product Version0.7.6 
Target VersionFixed in Version0.7.7 
Summary0001360: Corrupted property meta.attr.comment.markup corrupts project file and eventually crashes kdenlive
DescriptionThis is what happened a few days ago:
1. while editing a project kdenlive crashed;
2. after restart it asked about recovery;
3. project file was loaded from recovery; everything seemed to be fine;
4. I saved the project;
5. after one or two moves kdenlive crashed;
6. the project file crashed kdenlive on load every time.

After some investigation I found that:
a. At some point between 1-3 one of the video clips got following property:
<property name="meta.attr.comment.markup" >???</property>
The characters from property text in hex: 3e ef bf bd ef bf bd ef bf bd 18. I got also another copy of the project file with slightly different chars: 3e ef bf bf ef bf bf 0c 1c 31 7f. These files were probably saved before the first crash.
b. Only one of other clips - mp3 file - has that property set (to a value " YEAR: 1986"), and was added to the project not long before the first crash. The property was set automatically.
c. Loading a project file with corrupted property shows all the clips on tracks at the place, everything seems to be fine, but after saving (without any other actions) kdenlive crashes while loading the project file, which is now corrupted.
d. Corrupted project file contains all the kdenlive_producer, markers, guides, groups elements (kdenlivedoc), and no longer contains producer, playlist, tractor elements.
Steps To ReproduceSteps to corrupt comment property: unknown.
Steps to corrupt project file:
1. corrupt any comment property;
2. load project file;
3. save project file.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0004455)
j-b-m (administrator)
2010-01-02 20:17

As a first step to fix the issue, I just committed a change (svn rev. 4191) so that corrupted projects are not loaded anymore, instead a warning is displayed.
(0004456)
j-b-m (administrator)
2010-01-02 20:53

svn revision 4192 fixes the issue by removing the invalid characters when loading a project file. Now we only have a problem with the reason for the data corruption, but I think it is somewhere in MLT or FFMpeg... let me know if you can reproduce the problem, but anyways, now if some corrupted characters are passed by MLT, they will be deleted anyways, so it should be safer now...

- Issue History
Date Modified Username Field Change
2009-12-30 11:28 mayiv New Issue
2010-01-02 13:45 j-b-m Status new => acknowledged
2010-01-02 20:17 j-b-m Note Added: 0004455
2010-01-02 20:53 j-b-m Note Added: 0004456
2010-01-02 20:53 j-b-m Status acknowledged => feedback
2010-02-09 09:13 j-b-m Status feedback => resolved
2010-02-09 09:13 j-b-m Fixed in Version => 0.7.7
2010-02-09 09:13 j-b-m Resolution open => fixed
2010-02-09 09:13 j-b-m Assigned To => j-b-m
2010-02-20 08:16 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker