Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001376KdenliveUser Interfacepublic2010-01-08 00:192010-02-20 08:16
Reporterwseverin 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformDell Inspirion 9100OSUbuntu Linux LinuxOS Version9.10 (Karmic)
Product Version0.7.6 
Target VersionFixed in Version0.7.7 
Summary0001376: Math problem with manual of entering time codes, Guides and Markers
DescriptionThis issue is common to manual entry of times for both guides and markers.

I am editing a long clip (over one hour), 29.97 FPS wide NTSC MPEG2. Project settings are set to wide NTSC DV/DVD 29.97.

External reviewers provide time codes for edit. The problem is, manually entering time codes to place guides or markers results in incorrect placement on the timeline. This occurs with clips of all time duration. The longer the time into the clip, the bigger the error.
Steps To ReproducePut a relatively long NTSC (29.97 FPS) clip onto the timeline. Right click on the timeline and select 'add guide'. Enter "01:00:00:00", one hour, into the time position. You will see that the guide shows up on the timeline at "00:59:56:12", an error of over 3.5 seconds. The exact same thing occurs when manually entering markers.

The time entered onto the timeline is ALWAYS before the time manually entered, and (big hint) always by the ratio 29.97/30.
Additional InformationKdenlive 0.7.6, Ubuntu (synaptic distribution)
Ubuntu 9.10 (Karmic Koala)
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0004500)
j-b-m (administrator)
2010-01-08 14:52

Confirmed. There are probably other places where NTSC fps will create such problems. I will work on that. If you find other places where the same frame offset problem appears, please also report them here.
(0004502)
wseverin (reporter)
2010-01-09 00:46

Looking over the code. Possible issues in timecode.cpp at lines 105 and 125. Time in seconds is calculated with rounded integer for 'fps'.
        int seconds = frames / (int) floor(fps + 0.5);
It might work better to let the division carry out in floating point, without rounding 'fps', and then cast to integer.
(0004507)
j-b-m (administrator)
2010-01-10 19:53

should be fixed in latest svn (rev. 4222), please test if you can
(0004510)
wseverin (reporter)
2010-01-11 07:00

Downloaded the svn, compiled it and ran it. Initial test looks good; hopefully the problem is fixed. I will 'put it through the wringer' over the next couple of days.

- Issue History
Date Modified Username Field Change
2010-01-08 00:19 wseverin New Issue
2010-01-08 14:52 j-b-m Note Added: 0004500
2010-01-08 14:52 j-b-m Status new => acknowledged
2010-01-09 00:46 wseverin Note Added: 0004502
2010-01-10 19:53 j-b-m Note Added: 0004507
2010-01-10 19:53 j-b-m Status acknowledged => feedback
2010-01-11 07:00 wseverin Note Added: 0004510
2010-01-11 07:00 wseverin Status feedback => new
2010-02-09 09:05 j-b-m Status new => resolved
2010-02-09 09:05 j-b-m Fixed in Version => 0.7.7
2010-02-09 09:05 j-b-m Resolution open => fixed
2010-02-09 09:05 j-b-m Assigned To => j-b-m
2010-02-20 08:16 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker