Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001383KdenliveFile Loadingpublic2010-01-16 14:552010-11-15 14:00
Reportertogloss 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platformi7-920 2.66GHz based PCOSUbuntu 64bitOS Version9.10
Product Version0.7.6 
Target VersionFixed in Version0.7.7 
Summary0001383: Kdenlive crashed when adding clips
DescriptionFirst of all, to make kdenlive work stable I installed a clean ubuntu (actually 9.04 and the did the upgrade to 9.10) then I uninstalled pulseaudio updated to 0.76 through instructions in the internet and it workes now.

I had about 430 clips added to my project already, then I added 106 more clips
I tried it again and it crashed again.
This time I clicked restart kdenlive and clicked the auto recover function as it gave me the option

-> it worked, all clips are in now
Steps To Reproduceadd 230 clips to the project, let it create thumbnails
add 199 clips to the project, let it create thumbnails

add 106 clips and while thumbnail creation it crashes
Additional InformationApplication that crashed: kdenlive
Version of the application: 0.7.6
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-17-generic x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
<In detail, tell us what you were doing when the application crashed.>

 -- Backtrace:
Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f44c3e3d750 (LWP 3416))]

Thread 4 (Thread 0x7f449b7fe910 (LWP 4333)):
#0 0x00007f44bf63b5a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007f44a7c7108d in ?? () from /usr/lib/mlt/libmltsdl.so
0000002 0x00007f44bf636a04 in start_thread () from /lib/libpthread.so.0
0000003 0x00007f44bfb2f80d in clone () from /lib/libc.so.6
0000004 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f4499b07910 (LWP 4346)):
#0 0x00007f44bf63b82d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007f44c3a414ba in mlt_consumer_get_frame () from /usr/lib/libmlt.so.2
0000002 0x00007f44c3a4161d in mlt_consumer_rt_frame () from /usr/lib/libmlt.so.2
0000003 0x00007f44a7c7174c in ?? () from /usr/lib/mlt/libmltsdl.so
0000004 0x00007f44bf636a04 in start_thread () from /lib/libpthread.so.0
0000005 0x00007f44bfb2f80d in clone () from /lib/libc.so.6
0000006 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f44a2b77910 (LWP 23605)):
#0 0x00007f44bf63dc34 in __lll_lock_wait () from /lib/libpthread.so.0
#1 0x00007f44bf639295 in _L_lock_949 () from /lib/libpthread.so.0
0000002 0x00007f44bf6390b8 in pthread_mutex_lock () from /lib/libpthread.so.0
0000003 0x00007f44ab492bf0 in ?? () from /usr/lib/mlt/libmltavformat.so
0000004 0x00007f44ab49399d in ?? () from /usr/lib/mlt/libmltavformat.so
0000005 0x00007f44c382292e in Mlt::Producer::~Producer() () from /usr/lib/libmlt++.so.3
0000006 0x00000000005267ec in MyThread::run (this=0x1140cc060) at /build/buildd/kdenlive-0.7.6/src/kthumb.cpp:115
0000007 0x00007f44c13d4445 in ?? () from /usr/lib/libQtCore.so.4
0000008 0x00007f44bf636a04 in start_thread () from /lib/libpthread.so.0
0000009 0x00007f44bfb2f80d in clone () from /lib/libc.so.6
0000010 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f44c3e3d750 (LWP 3416)):
[KCrash Handler]
0000005 0x00007f44ab1b7464 in av_find_stream_info () from /usr/lib/libavformat.so.52
0000006 0x00007f44ab4925c3 in ?? () from /usr/lib/mlt/libmltavformat.so
0000007 0x00007f44ab492b58 in producer_avformat_init () from /usr/lib/mlt/libmltavformat.so
0000008 0x00007f44c3a4481a in mlt_factory_producer () from /usr/lib/libmlt.so.2
0000009 0x00007f44acf8f29e in ?? () from /usr/lib/mlt/libmltcore.so
0000010 0x00007f44acf8f5fa in producer_loader_init () from /usr/lib/mlt/libmltcore.so
0000011 0x00007f44c3a4481a in mlt_factory_producer () from /usr/lib/libmlt.so.2
0000012 0x00007f44c3822f89 in Mlt::Producer::Producer(Mlt::Profile&, char const*, char const*) () from /usr/lib/libmlt++.so.3
0000013 0x0000000000494b41 in Render::getFileProperties (this=<value optimized out>, xml=) at /build/buildd/kdenlive-0.7.6/src/renderer.cpp:611
0000014 0x000000000049860b in Render::qt_metacall (this=0x2201c40, _c=<value optimized out>, _id=<value optimized out>, _a=<value optimized out>)
    at /build/buildd/kdenlive-0.7.6/obj-x86_64-linux-gnu/src/cmake_bindir/renderer.moc:138
0000015 0x00007f44c14cfddc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
0000016 0x0000000000467b69 in ProjectList::getFileProperties (this=0x0, _t1=<value optimized out>, _t2=<value optimized out>, _t3=false)
    at /build/buildd/kdenlive-0.7.6/obj-x86_64-linux-gnu/src/cmake_bindir/projectlist.moc:225
0000017 0x000000000046b088 in ProjectList::slotProcessNextClipInQueue (this=0x1de34e0) at /build/buildd/kdenlive-0.7.6/src/projectlist.cpp:612
0000018 0x0000000000472a84 in ProjectList::qt_metacall (this=0x1de34e0, _c=QMetaObject::InvokeMetaMethod, _id=-2, _a=0x7fffebb21d50)
    at /build/buildd/kdenlive-0.7.6/obj-x86_64-linux-gnu/src/cmake_bindir/projectlist.moc:203
0000019 0x00007f44c14cfddc in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
0000020 0x00007f44c14d4e1f in ?? () from /usr/lib/libQtCore.so.4
0000021 0x00007f44c14c9d83 in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
0000022 0x00007f44c070aefc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000023 0x00007f44c07121ce in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000024 0x00007f44c319bab6 in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
0000025 0x00007f44c14bac2c in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
0000026 0x00007f44c14e5862 in ?? () from /usr/lib/libQtCore.so.4
0000027 0x00007f44c14e325d in ?? () from /usr/lib/libQtCore.so.4
0000028 0x00007f44bc4d5bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000029 0x00007f44bc4d9598 in ?? () from /lib/libglib-2.0.so.0
0000030 0x00007f44bc4d96c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000031 0x00007f44c14e31a6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000032 0x00007f44c079f4be in ?? () from /usr/lib/libQtGui.so.4
0000033 0x00007f44c14b9532 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000034 0x00007f44c14b9904 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000035 0x00007f44c14bbab9 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
0000036 0x0000000000444ee5 in main (argc=<value optimized out>, argv=<value optimized out>) at /build/buildd/kdenlive-0.7.6/src/main.cpp:86

TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0004519)
soeren (reporter)
2010-01-17 15:13
edited on: 2010-01-17 15:14

seems that i have the same bug.
After crashing i found a few empty-.thumb files in the thumb-dir.

Please try this:
Delete / or rename you ~/kdenlive/thumb dir. (So the thumb must be new created.)
Then deactivate the audio-thumb (wave-icon under the timeline) and import all the files. What happens?

For me, then all works.
Then after all is files are loaded (and video-thumbs are ready), i active audio-thumb without trouble.

------------
Sidux 64Bit, FFMPEG, MLT and Kdenlive from SVN

(0004708)
ddennedy (developer)
2010-02-12 09:53

j-b-m,
I notice that when you add multiple clips at once through multi-select in the file dialog or drag-n-drop from Dolphin, that kdenlive launches a separate audio thumbnail thread for each clip. This can be a very large amount of threads thrashing the cpu, mem cache, and especially disk! OTOH, when you disable audio thumbnails, add many clips, and then enable audio thumbnails; that thumbnail jobs are processed in a queue, which is nicer to the system. I think that add-multiple should queue the audio thumbnails as well.

Since mlt v0.4.10, in git master, I added caching of the avformat producer private object. This means only 10 are active at one time per process and the private object (memory, avcodec threads if any, and file descriptors) is released and re-instated automatically as needed. However, this has introduced a race condition somewhere under extreme conditions. I feel I do need to fix this, but the many audio thumbnail threads is a problem too.

togloss,
MLT v0.4.10 and earlier have a maximum file limit that you can be hitting. This has been addressed for the next release through caching described above.

soeren,
Since you are using the unreleased MLT, you are hitting the concurrency issue described above, and you have found a workaround for now.
(0004711)
j-b-m (administrator)
2010-02-16 09:01

I just committed the change to create audio thumbnails one after another (svn rev. 4309)
(0004712)
ddennedy (developer)
2010-02-16 09:32

I confirmed that this change by j-b-m works as expected and safely with MLT v0.5.0.

- Issue History
Date Modified Username Field Change
2010-01-16 14:55 togloss New Issue
2010-01-17 15:13 soeren Note Added: 0004519
2010-01-17 15:14 soeren Note Edited: 0004519 View Revisions
2010-02-12 09:52 ddennedy Status new => assigned
2010-02-12 09:52 ddennedy Assigned To => jmpoure
2010-02-12 09:53 ddennedy Assigned To jmpoure => j-b-m
2010-02-12 09:53 ddennedy Note Added: 0004708
2010-02-16 09:01 j-b-m Note Added: 0004711
2010-02-16 09:32 ddennedy Note Added: 0004712
2010-11-15 14:00 ttill Status assigned => resolved
2010-11-15 14:00 ttill Resolution open => fixed
2010-11-15 14:00 ttill Fixed in Version => 0.7.7
2010-11-15 14:00 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker