Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001391KdenliveUser Interfacepublic2010-01-19 07:402011-04-27 23:53
Reporterevorster 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
PlatformIntel Core2 DuoOSGNU/Linux (Sorcerer)OS Version2.6.32.2
Product Version0.7.6 
Target VersionFixed in Version0.7.7 
Summary0001391: Crash when loading a custom effect.
DescriptionI want to add a few clips that fade in and out. It's in DNxHD format, transcoded from AVCHD with the transcoding wizard at 120mb/s
Steps To Reproduceadd the following effects to a clip: audio fade in, audio fade out, video fade from black, video fade to black. Adjusted the fades so that they do not overlap.
Select the clip, and save the effects ( I called it in_out )
Then add the next clip to the timeline. Right-click on the new clip, and apply custom effect. Once you click on the new custom effect, kdenlive crashes.
Additional InformationApplication: Kdenlive (kdenlive), signal: Segmentation fault
[KCrash Handler]
0000006 0x0816bdf4 in EffectsList::getEffectByTag(QString const&, QString const&) const ()
0000007 0x08088aee in MainWindow::slotAddCustomEffect(QAction*) ()
0000008 0x0809db2b in MainWindow::qt_metacall(QMetaObject::Call, int, void**) ()
0000009 0xb6b10f81 in QMetaObject::activate(QObject*, int, int, void**) () from /opt/kde4/lib/libQtCore.so.4
0000010 0xb6b11c03 in QMetaObject::activate(QObject*, QMetaObject const*, int, void**) () from /opt/kde4/lib/libQtCore.so.4
0000011 0xb651e3d4 in QMenu::triggered(QAction*) () from /opt/kde4/lib/libQtGui.so.4
0000012 0xb651fc2d in ?? () from /opt/kde4/lib/libQtGui.so.4
0000013 0xb6528bfe in QMenu::qt_metacall(QMetaObject::Call, int, void**) () from /opt/kde4/lib/libQtGui.so.4
0000014 0xb75aca1b in KMenu::qt_metacall(QMetaObject::Call, int, void**) () from /opt/kde4/lib/libkdeui.so.5
0000015 0xb6b10f81 in QMetaObject::activate(QObject*, int, int, void**) () from /opt/kde4/lib/libQtCore.so.4
0000016 0xb6b11391 in QMetaObject::activate(QObject*, QMetaObject const*, int, int, void**) () from /opt/kde4/lib/libQtCore.so.4
0000017 0xb60dc112 in QAction::triggered(bool) () from /opt/kde4/lib/libQtGui.so.4
0000018 0xb60dd6a3 in QAction::activate(QAction::ActionEvent) () from /opt/kde4/lib/libQtGui.so.4
0000019 0xb651fb54 in ?? () from /opt/kde4/lib/libQtGui.so.4
0000020 0xb65262f3 in ?? () from /opt/kde4/lib/libQtGui.so.4
0000021 0xb6526e46 in QMenu::mouseReleaseEvent(QMouseEvent*) () from /opt/kde4/lib/libQtGui.so.4
0000022 0xb75ab386 in KMenu::mouseReleaseEvent(QMouseEvent*) () from /opt/kde4/lib/libkdeui.so.5
0000023 0xb6139641 in QWidget::event(QEvent*) () from /opt/kde4/lib/libQtGui.so.4
0000024 0xb6529151 in QMenu::event(QEvent*) () from /opt/kde4/lib/libQtGui.so.4
0000025 0xb60e293c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /opt/kde4/lib/libQtGui.so.4
0000026 0xb60eb69f in QApplication::notify(QObject*, QEvent*) () from /opt/kde4/lib/libQtGui.so.4
0000027 0xb74c265e in KApplication::notify(QObject*, QEvent*) () from /opt/kde4/lib/libkdeui.so.5
0000028 0xb6afb8e2 in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /opt/kde4/lib/libQtCore.so.4
0000029 0xb60ea774 in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from /opt/kde4/lib/libQtGui.so.4
0000030 0xb615a4a9 in ?? () from /opt/kde4/lib/libQtGui.so.4
0000031 0xb6159716 in QApplication::x11ProcessEvent(_XEvent*) () from /opt/kde4/lib/libQtGui.so.4
0000032 0xb6182bf2 in ?? () from /opt/kde4/lib/libQtGui.so.4
0000033 0xb57048ef in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
0000034 0xb570827b in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
0000035 0xb5708409 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
0000036 0xb6b27169 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/kde4/lib/libQtCore.so.4
0000037 0xb6182336 in ?? () from /opt/kde4/lib/libQtGui.so.4
0000038 0xb6af9ebb in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/kde4/lib/libQtCore.so.4
0000039 0xb6afa31a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /opt/kde4/lib/libQtCore.so.4
0000040 0xb6afc7d9 in QCoreApplication::exec() () from /opt/kde4/lib/libQtCore.so.4
0000041 0xb60e27a8 in QApplication::exec() () from /opt/kde4/lib/libQtGui.so.4
0000042 0x0807df73 in main ()
Tagsold
Build/Install MethodManual build from release
Attached Files

- Relationships

-  Notes
(0004531)
j-b-m (administrator)
2010-01-19 10:17

Crash should be fixed in current svn (rev. 4238). If I remember correctly, you can only save one effect at a time, not a group of effects. If you just want to copy / paste effects from one clip to another, right click on the first clip, select "copy", then right click the second clip and do "paste effects".
(0005078)
evorster (reporter)
2010-04-26 09:19

Thanks for the update. I'll watch out for this in the next release.

However, from what it looks like in the menu, a group of effects should be able to be saved and used.
(0006377)
Granjow (developer)
2011-02-03 13:44

Is this issue still present?
There were some changes regarding custom effects, including them being stored in the project file for portability.

- Issue History
Date Modified Username Field Change
2010-01-19 07:40 evorster New Issue
2010-01-19 10:17 j-b-m Note Added: 0004531
2010-01-19 10:17 j-b-m Status new => feedback
2010-04-26 09:19 evorster Note Added: 0005078
2010-04-26 09:19 evorster Status feedback => new
2011-02-03 13:43 Granjow Tag Attached: old
2011-02-03 13:44 Granjow Note Added: 0006377
2011-02-03 13:44 Granjow Assigned To => Granjow
2011-02-03 13:44 Granjow Status new => feedback
2011-04-27 23:52 ttill Assigned To Granjow => j-b-m
2011-04-27 23:52 ttill Status feedback => resolved
2011-04-27 23:52 ttill Resolution open => fixed
2011-04-27 23:52 ttill Fixed in Version => 0.7.7
2011-04-27 23:53 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker