Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001392KdenliveUser Interfacepublic2010-01-20 16:042010-02-20 08:16
ReporterGranjow 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version0.7.7 
Summary0001392: Vignette effect: Sliders out of sync
DescriptionFor the Vignette effect I've got two sliders: Position and value.But there are 6 entries: Position, smooth, x, y, opacity, radius.

Position changes the position of a point. IF the first cell is selected (smooth). If not, then nothing seems to happen, but when re-selecting the clip there is a new point added.

The value slider changes the selected value in the table.

There should be one slider for each property, and the position slider should not corrupt the points.
Additional Informationkdenlive, mlt and ffmpeg: current SVN from today.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships
related to 0001304closedddennedy Vignette effect: Parameters cannot be changed 

-  Notes
(0004552)
akirk (reporter)
2010-01-21 22:39

I agree. In addition, I think you need to sync the timeline cursor to the position slider.
(0004564)
j-b-m (administrator)
2010-01-23 00:02

All issues mentionned should be fixed in svn rev. 4244, please test
(0004565)
akirk (reporter)
2010-01-23 01:16

Nicely done. Works fine here. Thanks for the speedy fix. I needed this for a memorial video I'm working on.
(0004566)
akirk (reporter)
2010-01-23 01:18

P.S. could you get a note to Dan about setting the time on his machine? It seems he is running 12 hours ahead of the rest of the world!!
(0004567)
j-b-m (administrator)
2010-01-23 01:25

By the way, I also discovered an issue in the vignette filter which caused the keyframes to be broken if the clip was not placed at the very beginning of the timeline.

Fix for the MLT module is in my git repo:
http://github.com/j-b-m/mlt/commit/722370739b805ac267e0e969c5a57998d7a5632e [^]

Dan will probably merge it in the official repository in the next days.
(0004570)
ddennedy (developer)
2010-01-24 00:56

I fixed the date/time on my git/web server.
(0004575)
akirk (reporter)
2010-01-24 23:38

Dan: thanks.
j-b-m:
I applied the above fix, played around a bit and crashed kdenlive. I had the ui in 'seek to active keyframe' mode, and moved the little square on the timeline clip. At the point that it crashed, the smooth value had disappeared. Haven't had time to follow up on it. I'll get back to testing tomorrow morning.
I'm not sure what 'seek to active keyframe' is supposed to do.... What I was looking for with 'sync the timeline cursor to the position slider' was this:
If I create a new keyframe point between the begin/end points, move the cursor on the project time line to the position indicated by the keyframes position value.
(0004576)
Granjow (developer)
2010-01-25 00:02

When changing the «smooth» slider the value only gets updated when I move my cursor over the table (however the keyframe point in the timeline moves around in real-time). Intended? radius etc get updated in real-time.
(0004582)
j-b-m (administrator)
2010-01-26 01:28

I just fixed keyframes corruption when moving the keyframes directly in timeline. Let me know if you still exerience any crash. The "Seek to active keyframe" moves the timeline cursor to the currently selected keyframe in the table view.

@Granjow: I Cannot reproduce your problem, maybe related to your Qt version? Moving the "smooth" slider updates correctly for me.

Now I still need to fix the keyframe editing by double clicking in timeline keyframes...
(0004686)
j-b-m (administrator)
2010-02-09 08:50

Is that ok for everyone now?
(0004698)
ttill (developer)
2010-02-09 20:42

I had the same issue as Granjow (slider not updating)
This is resolved now after updating to QT 4.6 today.
(0004714)
Granjow (developer)
2010-02-16 21:09

I will mark this as resolved. Qt 4.6 is not available for Debian testing yet, so I cannot test this too ;) Anyway, thank you, jbm.

- Issue History
Date Modified Username Field Change
2010-01-20 16:04 Granjow New Issue
2010-01-20 16:05 Granjow Relationship added related to 0001304
2010-01-21 22:39 akirk Note Added: 0004552
2010-01-23 00:02 j-b-m Note Added: 0004564
2010-01-23 00:02 j-b-m Status new => feedback
2010-01-23 01:16 akirk Note Added: 0004565
2010-01-23 01:18 akirk Note Added: 0004566
2010-01-23 01:25 j-b-m Note Added: 0004567
2010-01-24 00:56 ddennedy Note Added: 0004570
2010-01-24 23:38 akirk Note Added: 0004575
2010-01-25 00:02 Granjow Note Added: 0004576
2010-01-25 00:02 Granjow Status feedback => new
2010-01-26 01:28 j-b-m Note Added: 0004582
2010-02-09 08:50 j-b-m Note Added: 0004686
2010-02-09 08:50 j-b-m Status new => feedback
2010-02-09 20:42 ttill Note Added: 0004698
2010-02-16 21:09 Granjow Note Added: 0004714
2010-02-16 21:09 Granjow Status feedback => new
2010-02-16 21:09 Granjow Assigned To => j-b-m
2010-02-16 21:09 Granjow Status new => resolved
2010-02-16 21:09 Granjow Resolution open => fixed
2010-02-16 21:09 Granjow Fixed in Version => 0.7.7
2010-02-20 08:16 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker