Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001401KdenliveFile Loadingpublic2010-02-01 20:472010-02-20 08:17
ReporterWeevil 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSUbuntu LinuxOS Version9.10
Product VersionRecent git 
Target VersionFixed in Version0.7.7 
Summary0001401: Crash on opening project file
DescriptionEvery time I open this project file, Kdenlive crashes. It might have something to do with the amount of effects I have added because after that this occurred.
Steps To ReproduceTry to open the project file
Additional InformationSeems the backtrace isn't always the exact same, I can produce more on request.

./kdenlive_start --version
Kdenlive Builder Wizard version: 0.9.90
frei0r: commit 7a54884be6e7969397b913b865f4d815b6cdc385 Date: Mon Nov 9 14:06:50 2009 +0100
ffmpeg: Revision: 21596 Last Changed Date: 2010-02-01 16:51:05 +0100 (Mon, 01 Feb 2010)
mlt: commit 98af4cef1f1b20f1f6364cd4dbd923cc6456260e Date: Thu Jan 28 15:23:03 2010 -0800
kdenlive: Revision: 4265 Last Changed Date: 2010-02-01 10:12:11 +0100 (Mon, 01 Feb 2010)
Qt: 4.5.2
KDE: 4.3.2 (KDE 4.3.2)
Kdenlive: 0.7.7 (rev. 4265)


-------------------



Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0xb778b700 (LWP 30024))]

Thread 3 (Thread 0xb40e7b70 (LWP 30037)):
#0 0x0018c422 in __kernel_vsyscall ()
#1 0x00547142 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0x01d0a8d4 in pthread_cond_timedwait () from /lib/tls/i686/cmov/libc.so.6
0000003 0x00fd6579 in mlt_consumer_get_frame (this=0x8c80290) at mlt_consumer.c:502
0000004 0x00fd66d8 in mlt_consumer_rt_frame (this=0x8c80290) at mlt_consumer.c:900
0000005 0x028e0944 in consumer_thread (arg=0x8c80290) at consumer_sdl_still.c:558
0000006 0x0054280e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000007 0x01cfd8de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 2 (Thread 0xb38e6b70 (LWP 30038)):
#0 0x0018c422 in __kernel_vsyscall ()
#1 0x00546e15 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/tls/i686/cmov/libpthread.so.0
0000002 0x01d0a87d in pthread_cond_wait () from /lib/tls/i686/cmov/libc.so.6
0000003 0x028e01eb in consumer_thread (arg=0x8c71610) at consumer_sdl_preview.c:385
0000004 0x0054280e in start_thread () from /lib/tls/i686/cmov/libpthread.so.0
0000005 0x01cfd8de in clone () from /lib/tls/i686/cmov/libc.so.6

Thread 1 (Thread 0xb778b700 (LWP 30024)):
[KCrash Handler]
0000006 0x0041ebdf in QDomNode::QDomNode(QDomNodePrivate*) () from /usr/lib/libQtXml.so.4
0000007 0x0042950e in QDomNodeList::item(int) const () from /usr/lib/libQtXml.so.4
0000008 0x080de90a in QDomNodeList::at (this=0xbf86065c, index=-1) at /usr/include/qt4/QtXml/qdom.h:265
0000009 0x0816c8ee in EffectsList::insert (this=0x9d92ed0, ix=-1, effect=...) at /home/waggle/src/kdenlive/src/effectslist.cpp:268
0000010 0x08158817 in ClipItem::addEffect (this=0x9d92db8, effect=...) at /home/waggle/src/kdenlive/src/clipitem.cpp:1308
0000011 0x080fb422 in TrackView::slotAddProjectTrack (this=0x9cff020, ix=3, xml=..., locked=false) at /home/waggle/src/kdenlive/src/trackview.cpp:816
0000012 0x080f3f68 in TrackView::parseDocument (this=0x9cff020, doc=...) at /home/waggle/src/kdenlive/src/trackview.cpp:248
0000013 0x080f2e6e in TrackView (this=0x9cff020, doc=0x90f8350, ok=0xbf86175f, parent=0x8948f70) at /home/waggle/src/kdenlive/src/trackview.cpp:108
0000014 0x080962ed in MainWindow::doOpenFile (this=0x8948f70, url=..., stale=0x9ce3fb0) at /home/waggle/src/kdenlive/src/mainwindow.cpp:1662
0000015 0x080960e8 in MainWindow::openFile (this=0x8948f70, url=...) at /home/waggle/src/kdenlive/src/mainwindow.cpp:1643
0000016 0x08095b3d in MainWindow::openFile (this=0x8948f70) at /home/waggle/src/kdenlive/src/mainwindow.cpp:1592
0000017 0x080a2156 in MainWindow::qt_metacall (this=0x8948f70, _c=QMetaObject::InvokeMetaMethod, _id=11, _a=0xbf861a28) at /home/waggle/src/kdenlive/src/cmake_bindir/mainwindow.moc:321
0000018 0x01135263 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQtCore.so.4
0000019 0x011356d8 in QMetaObject::activate(QObject*, QMetaObject const*, int, int, void**) () from /usr/lib/libQtCore.so.4
0000020 0x013ad9b1 in QAction::triggered(bool) () from /usr/lib/libQtGui.so.4
0000021 0x013aef32 in QAction::activate(QAction::ActionEvent) () from /usr/lib/libQtGui.so.4
0000022 0x01850f02 in QToolButton::nextCheckState() () from /usr/lib/libQtGui.so.4
0000023 0x0176b163 in ?? () from /usr/lib/libQtGui.so.4
0000024 0x0176b431 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
0000025 0x018513fc in QToolButton::mouseReleaseEvent(QMouseEvent*) () from /usr/lib/libQtGui.so.4
0000026 0x01409012 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000027 0x017693ee in QAbstractButton::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000028 0x01853d9a in QToolButton::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000029 0x013b3f54 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000030 0x013bc033 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000031 0x00b5bbfa in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
0000032 0x0111f6cb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
0000033 0x013baf6e in QApplicationPrivate::sendMouseEvent(QWidget*, QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from /usr/lib/libQtGui.so.4
0000034 0x014297c0 in ?? () from /usr/lib/libQtGui.so.4
0000035 0x01428c4b in QApplication::x11ProcessEvent(_XEvent*) () from /usr/lib/libQtGui.so.4
0000036 0x01455502 in ?? () from /usr/lib/libQtGui.so.4
0000037 0x01daee88 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000038 0x01db2730 in ?? () from /lib/libglib-2.0.so.0
0000039 0x01db2863 in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000040 0x0114a02c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000041 0x01454be5 in ?? () from /usr/lib/libQtGui.so.4
0000042 0x0111dc79 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000043 0x0111e0ca in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000044 0x0112053f in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
0000045 0x013b3dd7 in QApplication::exec() () from /usr/lib/libQtGui.so.4
0000046 0x08083641 in main (argc=3, argv=0xbf863c24) at /home/waggle/src/kdenlive/src/main.cpp:86
TagsNo tags attached.
Build/Install MethodBuild Wizard
Attached Files

- Relationships

-  Notes
(0004600)
j-b-m (administrator)
2010-02-01 23:28

The crash happens because Kdenlive stores a value called "kdenlive_ix" for each effect to remember their order for each clip. For some reason that I don't understand, one of your effect received an index value of -1, which causes a crash in Kdenlive.

I just committed a change in Kdenlive that will cause all effects indexes to be rebuild when loading a document, that should solve your crash and also other possible side effects. Please try latest svn rev. 4268
(0004602)
Weevil (reporter)
2010-02-01 23:55

I can open the projectfile without crashing, thanks!

- Issue History
Date Modified Username Field Change
2010-02-01 20:47 Weevil New Issue
2010-02-01 23:28 j-b-m Note Added: 0004600
2010-02-01 23:28 j-b-m Status new => feedback
2010-02-01 23:55 Weevil Note Added: 0004602
2010-02-01 23:55 Weevil Status feedback => new
2010-02-02 00:10 j-b-m Status new => resolved
2010-02-02 00:10 j-b-m Fixed in Version => Recent git
2010-02-02 00:10 j-b-m Resolution open => fixed
2010-02-02 00:10 j-b-m Assigned To => j-b-m
2010-02-02 10:34 j-b-m Fixed in Version Recent git => 0.7.7
2010-02-20 08:17 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker