Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001413KdenliveEffectspublic2010-02-02 16:312010-11-19 21:25
Reporterttill 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSArch LinuxOS Versioncurrent
Product VersionRecent git 
Target VersionFixed in Version0.7.8 
Summary0001413: Deleting the first keyframe will crash kdenlive
DescriptionWhen deleting the first keyframe (in a keyframeable effect) kdenlive will segfault:

Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f58a77be760 (LWP 24867))]

Thread 5 (Thread 0x7f588f94a710 (LWP 24878)):
[KCrash Handler]
0000005 0x00007f58988bf351 in yuv422ptoyuy2_MMX2 () from /usr/lib/libswscale.so.0
0000006 0x00007f58988d00c0 in yuv422pToYuy2Wrapper () from /usr/lib/libswscale.so.0
0000007 0x00007f58988d5942 in sws_scale () from /usr/lib/libswscale.so.0
0000008 0x00007f5899da2b43 in convert_image (frame=0x7f5888030fb0, buffer=0x7f58804b5020 "\020\200\020\200\020\200\020\200\001", pix_fmt=<value optimized out>, format=<value optimized out>, width=1920,
    height=1080) at producer_avformat.c:733
0000009 0x00007f5899da5645 in producer_get_image (frame=<value optimized out>, buffer=<value optimized out>, format=<value optimized out>, width=<value optimized out>, height=<value optimized out>,
    writable=<value optimized out>) at producer_avformat.c:983
0000010 0x00007f58a73cd19a in mlt_frame_get_image (this=0x7f5888313620, buffer=0x7f588f949e38, format=0x7f588f949e4c, width=0x7f588f949a3c, height=0x7f588f949a38, writable=<value optimized out>)
    at mlt_frame.c:389
0000011 0x00007f589355788b in filter_get_image (this=0x7f5888313620, image=<value optimized out>, format=0x7f588f949e4c, width=0x7f588f949a3c, height=0x7f588f949a38, writable=1) at filter_crop.c:75
0000012 0x00007f58a73cd19a in mlt_frame_get_image (this=0x7f5888313620, buffer=0x7f588f949e38, format=0x7f588f949e4c, width=0x7f588f949a3c, height=0x7f588f949a38, writable=<value optimized out>)
    at mlt_frame.c:389
0000013 0x00007f58928827f5 in filter_get_image (this=0x7f5888313620, image=0x7f588f949e38, format=0x7f588f949e4c, width=<value optimized out>, height=<value optimized out>, writable=1080)
    at filter_deinterlace.c:49
0000014 0x00007f58a73cd19a in mlt_frame_get_image (this=0x7f5888313620, buffer=0x7f588f949e38, format=0x7f588f949e4c, width=0x7f588f949a3c, height=0x7f588f949a38, writable=<value optimized out>)
    at mlt_frame.c:389
0000015 0x00007f589355bca8 in filter_get_image (this=0x7f5888313620, image=0x7f588f949e38, format=<value optimized out>, width=0x7f588f949b5c, height=0x7f588f949b58, writable=<value optimized out>)
    at filter_rescale.c:218
0000016 0x00007f58a73cd19a in mlt_frame_get_image (this=0x7f5888313620, buffer=0x7f588f949e38, format=0x7f588f949e4c, width=0x7f588f949b5c, height=0x7f588f949b58, writable=<value optimized out>)
    at mlt_frame.c:389
0000017 0x00007f589355c16a in filter_get_image (this=0x7f5888313620, image=0x7f588f949e38, format=0x7f588f949e4c, width=0x7f588f949e44, height=0x7f588f949e48, writable=0) at filter_resize.c:260
0000018 0x00007f58a73cd19a in mlt_frame_get_image (this=0x7f5888313620, buffer=0x7f588f949e38, format=0x7f588f949e4c, width=0x7f588f949e44, height=0x7f588f949e48, writable=<value optimized out>)
    at mlt_frame.c:389
0000019 0x00007f58958561c4 in filter_get_image (this=0x7f5888313620, image=0x7f588f949e38, format=0x7f588f949e4c, width=0x7f588f949e44, height=0x7f588f949e48, writable=<value optimized out>)
    at filter_frei0r.c:31
0000020 0x00007f58a73cd19a in mlt_frame_get_image (this=0x7f5888313620, buffer=0x7f588f949e38, format=0x7f588f949e4c, width=0x7f588f949e44, height=0x7f588f949e48, writable=<value optimized out>)
    at mlt_frame.c:389
0000021 0x00007f58a73dc143 in producer_get_image (this=0x7f588801c6b0, buffer=0x7f588f949e38, format=0x7f588f949e4c, width=0x7f588f949e44, height=0x7f588f949e48, writable=<value optimized out>)
    at mlt_tractor.c:274
0000022 0x00007f58a73cd19a in mlt_frame_get_image (this=0x7f588801c6b0, buffer=0x7f588f949e38, format=0x7f588f949e4c, width=0x7f588f949e44, height=0x7f588f949e48, writable=<value optimized out>)
    at mlt_frame.c:389
0000023 0x00007f589bae8dea in consumer_play_video (arg=<value optimized out>) at consumer_sdl_still.c:466
0000024 consumer_thread (arg=<value optimized out>) at consumer_sdl_still.c:565
0000025 0x00007f58a507081a in start_thread () from /lib/libpthread.so.0
0000026 0x00007f58a3a5ac7d in clone () from /lib/libc.so.6
0000027 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f589014b710 (LWP 24879)):
#0 0x00007f58a507507c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007f589bae8494 in consumer_thread (arg=<value optimized out>) at consumer_sdl_preview.c:385
0000002 0x00007f58a507081a in start_thread () from /lib/libpthread.so.0
0000003 0x00007f58a3a5ac7d in clone () from /lib/libc.so.6
0000004 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f5885a43710 (LWP 24880)):
#0 0x00007f58a50753e9 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007f58a73d95e9 in mlt_consumer_get_frame (this=0xe06b30) at mlt_consumer.c:502
0000002 0x00007f58a73d9725 in mlt_consumer_rt_frame (this=0xe06c4c) at mlt_consumer.c:900
0000003 0x00007f589bae8b2c in consumer_thread (arg=<value optimized out>) at consumer_sdl_still.c:558
0000004 0x00007f58a507081a in start_thread () from /lib/libpthread.so.0
0000005 0x00007f58a3a5ac7d in clone () from /lib/libc.so.6
0000006 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f5885242710 (LWP 24881)):
#0 0x00007f58a507507c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007f589bae8494 in consumer_thread (arg=<value optimized out>) at consumer_sdl_preview.c:385
0000002 0x00007f58a507081a in start_thread () from /lib/libpthread.so.0
0000003 0x00007f58a3a5ac7d in clone () from /lib/libc.so.6
0000004 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f58a77be760 (LWP 24867)):
#0 0x00007f58a5077ae4 in __lll_lock_wait () from /lib/libpthread.so.0
#1 0x00007f58a5072fe9 in _L_lock_512 () from /lib/libpthread.so.0
0000002 0x00007f58a5072e0b in pthread_mutex_lock () from /lib/libpthread.so.0
0000003 0x00007f5899da203e in producer_avformat_close (this=0x1559480) at producer_avformat.c:1949
0000004 0x00007f58a73de69f in cache_object_close (cache=0x15e8d80, object=<value optimized out>, data=0x0) at mlt_cache.c:132
0000005 0x00007f58a73deb77 in mlt_cache_close (cache=0x15e8d80) at mlt_cache.c:227
0000006 0x00007f58a73cf60a in mlt_property_clear (this=0xd7c410) at mlt_property.c:107
0000007 mlt_property_close (this=0xd7c410) at mlt_property.c:475
0000008 0x00007f58a73d010c in mlt_properties_close (this=0x1227f80) at mlt_properties.c:1161
0000009 0x00007f58a73cf60a in mlt_property_clear (this=0x14e97a0) at mlt_property.c:107
0000010 mlt_property_close (this=0x14e97a0) at mlt_property.c:475
0000011 0x00007f58a73d010c in mlt_properties_close (this=0xabfd20) at mlt_properties.c:1161
0000012 0x00007f58a73dc396 in mlt_factory_close () at mlt_factory.c:366
0000013 0x00007f58a39c0af2 in __run_exit_handlers () from /lib/libc.so.6
0000014 0x00007f58a39c0b45 in exit () from /lib/libc.so.6
0000015 0x00007f58a445e4a8 in ?? () from /usr/lib/libQtGui.so.4
0000016 0x00007f58a6b38b28 in KApplication::xioErrhandler(_XDisplay*) () from /usr/lib/libkdeui.so.5
0000017 0x00007f58a28ff68e in _XIOError () from /usr/lib/libX11.so.6
0000018 0x00007f58a2906a25 in process_responses () from /usr/lib/libX11.so.6
0000019 0x00007f58a29072d7 in _XEventsQueued () from /usr/lib/libX11.so.6
0000020 0x00007f58a28efcdb in XEventsQueued () from /usr/lib/libX11.so.6
0000021 0x00007f58a44964bc in ?? () from /usr/lib/libQtGui.so.4
0000022 0x00007f58a054e13a in g_main_context_check () from /usr/lib/libglib-2.0.so.0
0000023 0x00007f58a054e920 in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
0000024 0x00007f58a054ed50 in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
0000025 0x00007f58a53ecf73 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000026 0x00007f58a44962fe in ?? () from /usr/lib/libQtGui.so.4
0000027 0x00007f58a53c33b2 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000028 0x00007f58a53c3784 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000029 0x00007f58a53c5939 in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
0000030 0x0000000000442d1d in main (argc=<value optimized out>, argv=<value optimized out>) at /home/till/abs/kdenlive-svn/src/kdenlive-build/src/main.cpp:86
Additional InformationKdenlive from SVN,
MLT from git
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0004617)
j-b-m (administrator)
2010-02-03 18:34

I cannot reproduce and your crash seems to happen in FFMpeg... Could you please make sure you are running the latest svn revision of Kdenlive and MLT's current git and describe more precisely how to reproduce:

what kind of clip, which effect, ...
(0004642)
ttill (developer)
2010-02-04 22:24

Sorry for the missing information...
Kdenlive went crazy today :(
Sometimes I'm not able to delete effects, sometimes it crashes when clicking on clips in the timeline, it crashes when switching focus to another window and than back to kdenlive again...
I'm not sure what produced this buggy behavior. I updated kdenlive from r4281 to r4291 and ffmpeg from r21602 to r21635.
So likely no big differences.

The segfault is always reproducible with the vignette effect.
Yesterday it was also with other effects.
Steps to reproduce:
Activate "Seek to active keyframe"
Select first keyframe in table
delete it

If you are not able to reproduce with the vignette effect it's maybe better to wait until I figured out what went wrong with my kdenlive installation before you spend any time on this issue.
(0004685)
j-b-m (administrator)
2010-02-09 08:46

Cannot reproduce so I guess there might be something wrong in your install
(0006077)
ttill (developer)
2010-11-19 21:24

There was nothing wrong with my install.
This was a bug in MLT triggered by some DNxHD files.
Closed somewhere between 0.5.6 and 0.5.8

- Issue History
Date Modified Username Field Change
2010-02-02 16:31 ttill New Issue
2010-02-03 18:34 j-b-m Note Added: 0004617
2010-02-04 22:24 ttill Note Added: 0004642
2010-02-09 08:46 j-b-m Note Added: 0004685
2010-02-09 08:46 j-b-m Status new => feedback
2010-11-19 21:24 ttill Note Added: 0006077
2010-11-19 21:24 ttill Status feedback => new
2010-11-19 21:25 ttill Assigned To => ddennedy
2010-11-19 21:25 ttill Status new => resolved
2010-11-19 21:25 ttill Resolution open => fixed
2010-11-19 21:25 ttill Fixed in Version => 0.7.8
2010-11-19 21:25 ttill Status resolved => closed
2010-11-19 21:25 ttill Relationship added related to 0001563
2010-11-19 21:27 ttill Relationship deleted related to 0001563


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker