Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001464KdenliveEffectspublic2010-02-26 23:072011-06-10 10:50
Reporterblaubeerina 
Assigned Toddennedy 
PrioritynoneSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
Platform64 bitOSUbuntu LinuxOS Version8.04
Product Version0.7.7 
Target VersionFixed in Version0.8 
Summary0001464: kdenlive collapse if i try to use the effekt: transparent
Descriptionif i put the transparent effekt to on clip an try to play it twiche the whole programm collapse

report see: file
Steps To Reproduceput one or more transparent effekt into yout work an push play more than one time
TagsNo tags attached.
Build/Install Method
Attached Files

- Relationships

-  Notes
(0004765)
blaubeerina (reporter)
2010-02-26 23:09

sorry
(0004766)
j-b-m (administrator)
2010-02-26 23:13

There are some problems with file attachment in our bug tracker which sometimes causes duplicate entries, not your fault.

When trying to remove the older duplicates, I removed your last report, sorry. Can you please attach the other informations to this bug report again?

regards
(0004771)
blaubeerina (reporter)
2010-02-27 16:07

i hope you mean this:


Summary: kdenlive collapse if i try to use the effekt:
transparent
Description:
if i put the transparent effekt to on clip an try to play it twiche the whole
programm collapse

report see:Additional Information

Steps to Reproduce:
put one or more transparent effekt into yout work an push play more than one
time

Additional Information:
Application that crashed: kdenlive
Version of the application: 0.7.5
KDE Version: 4.3.2 (KDE 4.3.2)
Qt Version: 4.5.2
Operating System: Linux 2.6.31-9-rt x86_64
Distribution: Ubuntu 9.10

What I was doing when the application crashed:
<In detail, tell us what you were doing when the application crashed.>

 -- Backtrace:
Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f5927f36750 (LWP 4951))]

Thread 5 (Thread 0x7f590ac88910 (LWP 4969)):
[KCrash Handler]
0000005 0x00007f59258f032b in ?? () from /usr/lib/libQtDBus.so.4
0000006 0x00007f59258f0b6a in ?? () from /usr/lib/libQtDBus.so.4
0000007 0x00007f59255d1ddc in QMetaObject::activate(QObject*, int, int, void**) ()
from /usr/lib/libQtCore.so.4
0000008 0x00007f59255d2314 in QObject::destroyed(QObject*) () from
/usr/lib/libQtCore.so.4
0000009 0x00007f59255d317b in QObject::~QObject() () from /usr/lib/libQtCore.so.4
0000010 0x00007f5926d4ac37 in KIO::Scheduler::~Scheduler() () from
/usr/lib/libkio.so.5
0000011 0x00007f5926d4e431 in ?? () from /usr/lib/libkio.so.5
0000012 0x00007f5923b8ac12 in exit () from /lib/libc.so.6
0000013 0x00007f591b704726 in ?? () from /usr/lib/libgdk-x11-2.0.so.0
0000014 0x00007f592729d498 in KApplication::xioErrhandler(_XDisplay*) () from
/usr/lib/libkdeui.so.5
0000015 0x00007f5922ae4fae in _XIOError () from /usr/lib/libX11.so.6
0000016 0x00007f5922aed12a in _XReply () from /usr/lib/libX11.so.6
0000017 0x00007f5922acae48 in _XGetWindowAttributes () from /usr/lib/libX11.so.6
0000018 0x00007f5922acafe1 in XGetWindowAttributes () from /usr/lib/libX11.so.6
0000019 0x00007f5915994713 in ?? () from /usr/lib/mlt/libmltsdl.so
0000020 0x00007f5915994968 in ?? () from /usr/lib/mlt/libmltsdl.so
0000021 0x00007f5923738a04 in start_thread () from /lib/libpthread.so.0
0000022 0x00007f5923c3180d in clone () from /lib/libc.so.6
0000023 0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f590a487910 (LWP 4970)):
#0 0x00007f592373d5a9 in pthread_cond_wait@@GLIBC_2.3.2 () from
/lib/libpthread.so.0
#1 0x00007f591599411d in ?? () from /usr/lib/mlt/libmltsdl.so
0000002 0x00007f5923738a04 in start_thread () from /lib/libpthread.so.0
0000003 0x00007f5923c3180d in clone () from /lib/libc.so.6
0000004 0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f59091f9910 (LWP 4971)):
#0 0x00007f592373d82d in pthread_cond_timedwait@@GLIBC_2.3.2 () from
/lib/libpthread.so.0
#1 0x00007f5927b447ea in mlt_consumer_get_frame () from /usr/lib/libmlt.so.1
0000002 0x00007f5927b4494d in mlt_consumer_rt_frame () from /usr/lib/libmlt.so.1
0000003 0x00007f591599483c in ?? () from /usr/lib/mlt/libmltsdl.so
0000004 0x00007f5923738a04 in start_thread () from /lib/libpthread.so.0
0000005 0x00007f5923c3180d in clone () from /lib/libc.so.6
0000006 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f59089f8910 (LWP 4972)):
#0 0x00007f592373d5a9 in pthread_cond_wait@@GLIBC_2.3.2 () from
/lib/libpthread.so.0
#1 0x00007f591599411d in ?? () from /usr/lib/mlt/libmltsdl.so
0000002 0x00007f5923738a04 in start_thread () from /lib/libpthread.so.0
0000003 0x00007f5923c3180d in clone () from /lib/libc.so.6
0000004 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f5927f36750 (LWP 4951)):
#0 0x00007f5923c253c3 in poll () from /lib/libc.so.6
#1 0x00007f591f43429a in ?? () from /usr/lib/libxcb.so.1
0000002 0x00007f591f4347d7 in ?? () from /usr/lib/libxcb.so.1
0000003 0x00007f591f434a85 in xcb_writev () from /usr/lib/libxcb.so.1
0000004 0x00007f5922aecd4a in _XSend () from /usr/lib/libX11.so.6
0000005 0x00007f5922ade73e in _XSetClipRectangles () from /usr/lib/libX11.so.6
0000006 0x00007f5922ade833 in XSetClipRectangles () from /usr/lib/libX11.so.6
0000007 0x00007f59249c44c9 in ?? () from /usr/lib/libQtGui.so.4
0000008 0x00007f59249c4e26 in ?? () from /usr/lib/libQtGui.so.4
0000009 0x00007f592491e423 in ?? () from /usr/lib/libQtGui.so.4
0000010 0x00007f592491e502 in ?? () from /usr/lib/libQtGui.so.4
0000011 0x00007f592491e887 in QPainter::restore() () from /usr/lib/libQtGui.so.4
0000012 0x00007f5915bb32a0 in ?? () from /usr/lib/kde4/plugins/styles/oxygen.so
0000013 0x00007f5915bbc944 in ?? () from /usr/lib/kde4/plugins/styles/oxygen.so
0000014 0x00007f5915bc243b in ?? () from /usr/lib/kde4/plugins/styles/oxygen.so
0000015 0x00007f59272b4959 in KStyle::drawPrimitive(QStyle::PrimitiveElement,
QStyleOption const*, QPainter*, QWidget const*) const () from
/usr/lib/libkdeui.so.5
0000016 0x00007f5924ba5c6e in ?? () from /usr/lib/libQtGui.so.4
0000017 0x00007f5924ba5df6 in ?? () from /usr/lib/libQtGui.so.4
0000018 0x00007f5924ba5f85 in ?? () from /usr/lib/libQtGui.so.4
0000019 0x00007f5924bd1c47 in QMainWindow::event(QEvent*) () from
/usr/lib/libQtGui.so.4
0000020 0x00007f59273a9773 in KXmlGuiWindow::event(QEvent*) () from
/usr/lib/libkdeui.so.5
0000021 0x00007f592480cefc in QApplicationPrivate::notify_helper(QObject*, QEvent*)
() from /usr/lib/libQtGui.so.4
0000022 0x00007f59248141ce in QApplication::notify(QObject*, QEvent*) () from
/usr/lib/libQtGui.so.4
0000023 0x00007f592729dab6 in KApplication::notify(QObject*, QEvent*) () from
/usr/lib/libkdeui.so.5
0000024 0x00007f59255bcc2c in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
from /usr/lib/libQtCore.so.4
0000025 0x00007f5924862b93 in QWidgetPrivate::drawWidget(QPaintDevice*, QRegion
const&, QPoint const&, int, QPainter*, QWidgetBackingStore*) () from
/usr/lib/libQtGui.so.4
0000026 0x00007f59249d4e1e in ?? () from /usr/lib/libQtGui.so.4
0000027 0x00007f5924854fa0 in QWidgetPrivate::syncBackingStore() () from
/usr/lib/libQtGui.so.4
0000028 0x00007f592485b5b8 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000029 0x00007f5924bd19db in QMainWindow::event(QEvent*) () from
/usr/lib/libQtGui.so.4
0000030 0x00007f59273a9773 in KXmlGuiWindow::event(QEvent*) () from
/usr/lib/libkdeui.so.5
0000031 0x00007f592480cefc in QApplicationPrivate::notify_helper(QObject*, QEvent*)
() from /usr/lib/libQtGui.so.4
0000032 0x00007f59248141ce in QApplication::notify(QObject*, QEvent*) () from
/usr/lib/libQtGui.so.4
0000033 0x00007f592729dab6 in KApplication::notify(QObject*, QEvent*) () from
/usr/lib/libkdeui.so.5
0000034 0x00007f59255bcc2c in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
from /usr/lib/libQtCore.so.4
0000035 0x00007f59249d2317 in ?? () from /usr/lib/libQtGui.so.4
0000036 0x00007f59249d54f6 in ?? () from /usr/lib/libQtGui.so.4
0000037 0x00007f5924856f1b in QWidget::repaint(QRect const&) () from
/usr/lib/libQtGui.so.4
0000038 0x00007f5924856fe3 in QWidget::repaint() () from /usr/lib/libQtGui.so.4
0000039 0x00007f5924b72008 in ?? () from /usr/lib/libQtGui.so.4
0000040 0x00007f5924b72275 in QAbstractButton::mouseReleaseEvent(QMouseEvent*) ()
from /usr/lib/libQtGui.so.4
0000041 0x00007f5924c40cba in QToolButton::mouseReleaseEvent(QMouseEvent*) () from
/usr/lib/libQtGui.so.4
0000042 0x00007f592485b9c0 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000043 0x00007f592480cefc in QApplicationPrivate::notify_helper(QObject*, QEvent*)
() from /usr/lib/libQtGui.so.4
0000044 0x00007f5924814011 in QApplication::notify(QObject*, QEvent*) () from
/usr/lib/libQtGui.so.4
0000045 0x00007f592729dab6 in KApplication::notify(QObject*, QEvent*) () from
/usr/lib/libkdeui.so.5
0000046 0x00007f59255bcc2c in QCoreApplication::notifyInternal(QObject*, QEvent*) ()
from /usr/lib/libQtCore.so.4
0000047 0x00007f59248138e0 in QApplicationPrivate::sendMouseEvent(QWidget*,
QMouseEvent*, QWidget*, QWidget*, QWidget**, QPointer<QWidget>&) () from
/usr/lib/libQtGui.so.4
0000048 0x00007f5924879a0e in ?? () from /usr/lib/libQtGui.so.4
0000049 0x00007f5924878aa9 in QApplication::x11ProcessEvent(_XEvent*) () from
/usr/lib/libQtGui.so.4
0000050 0x00007f59248a1d0c in ?? () from /usr/lib/libQtGui.so.4
0000051 0x00007f59205d7bce in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000052 0x00007f59205db598 in ?? () from /lib/libglib-2.0.so.0
0000053 0x00007f59205db6c0 in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000054 0x00007f59255e51a6 in
QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
from /usr/lib/libQtCore.so.4
0000055 0x00007f59248a14be in ?? () from /usr/lib/libQtGui.so.4
0000056 0x00007f59255bb532 in
QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from
/usr/lib/libQtCore.so.4
0000057 0x00007f59255bb904 in
QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from
/usr/lib/libQtCore.so.4
#58 0x00007f59255bdab9 in QCoreApplication::exec() () from
/usr/lib/libQtCore.so.4
0000059 0x0000000000441b05 in _start ()

Report to http://kdenlive.org/mantis [^]
======================================================================

Issue History
Date Modified Username Field Change
======================================================================
2010-02-26 23:09 blaubeerina New Issue
2010-02-26 23:09 blaubeerina File Added: Avatar340.JPG
2010-02-26 23:10 j-b-m Issue Deleted: 0001466
======================================================================
(0005097)
ddennedy (developer)
2010-05-01 09:04

I reproduce this. I believe there is a bug in the frei0r plugin although I have not reproduced it yet in the debugger to determine for certain. We should blacklist this since it is redundant with Composite's opacity and you need Composite anyways to make use of it.
(0006097)
ddennedy (developer)
2010-11-20 08:36

Removed Transparency effect.

- Issue History
Date Modified Username Field Change
2010-02-26 23:07 blaubeerina New Issue
2010-02-26 23:09 blaubeerina Note Added: 0004765
2010-02-26 23:13 j-b-m Note Added: 0004766
2010-02-27 16:07 blaubeerina Note Added: 0004771
2010-05-01 09:04 ddennedy Note Added: 0005097
2010-05-01 09:05 ddennedy Assigned To => ddennedy
2010-05-01 09:05 ddennedy Status new => assigned
2010-11-20 08:36 ddennedy Note Added: 0006097
2010-11-20 08:36 ddennedy Status assigned => resolved
2010-11-20 08:36 ddennedy Fixed in Version => 0.7.9
2010-11-20 08:36 ddennedy Resolution open => fixed
2011-04-26 21:57 j-b-m Fixed in Version 0.7.9 => 0.8
2011-06-10 10:50 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker