Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001474KdenliveRenderingpublic2010-03-04 20:272010-09-22 17:54
Reporterybecognee 
Assigned Toj-b-m 
PriorityhighSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformLinuxOSUbuntu LinuxOS Version9.04
Product Version0.7.6 
Target Version0.7.8Fixed in Version0.7.8 
Summary0001474: Can't Make DVD with menu
DescriptionHi

With KDEnLive 0.7.6 and DVD Wizard I tried to Make a DVD with menu.
It's stoping with this message :

DVDAuthor::spumux, version 0.6.14.
Build options: gnugetopt magick iconv freetype
Send bugs to <dvdauthor-users@lists.sourceforge.net>

INFO: Locale=fr_FR.UTF-8
INFO: Converting filenames to UTF-8
STAT: 0:00:00.000
INFO: Picture /tmp/kde-ubuntuYenu0q/kdenliveg14271.png had 2 colors
INFO: Picture /tmp/kde-ubuntuYenu0q/kdenlivep14271.png had 2 colors
INFO: Picture /tmp/kde-ubuntuYenu0q/kdenliveX14271.png had 2 colors
INFO: Pickbuttongroups, success with 1 groups, useimg=1
INFO: Found EOF in .sub file.
INFO: Max_sub_size=6958
WARN: Button y coordinates are odd for button b0: 389x456-514x487; they may not display properly.
WARN: Button y coordinates are odd for button b3: 472x306-664x337; they may not display properly.
WARN: Button y coordinates are odd for button b6: 394x154-558x185; they may not display properly.
WARN: Button y coordinates are odd for button b8: 81x206-277x237; they may not display properly.
WARN: Button y coordinates are odd for button b11: 52x356-235x387; they may not display properly.
WARN: Button y coordinates are odd for button b12: 78x406-219x437; they may not display properly.
WARN: Button y coordinates are odd for button b14: 258x504-455x535; they may not display properly.
INFO: 1 subtitles added, 0 subtitles skipped, stream: 32, offset: 0.50

Statistics:
- Processed 0 subtitles.
- The longest display line had -1 characters.
- The maximum number of displayed lines was 0.
- The normal display height of the font arial.ttf was 0.
- The bottom display height of the font arial.ttf was 0.
- The biggest subtitle box had 6958 bytes.

DVDAuthor::dvdauthor, version 0.6.14.
Build options: gnugetopt magick iconv freetype
Send bugs to <dvdauthor-users@lists.sourceforge.net>

INFO: Locale=fr_FR.UTF-8
INFO: Converting filenames to UTF-8

ERR: Parse error 'syntax error, unexpected TITLE_TOK' on token 'title'
ERR: Parser failed on code '{title 1;}'.


Le processus DVDAuthor s'est terminé par une erreur fatale.`

Thank you for your help :-)
Steps To ReproduceMaking a 52 min movie DVD with a menu using a simple Picture in background and 16 titles.
Additional InformationI have exactly the same Problem whith Kdenlive - Version 0.7.7

DVDAuthor::spumux, version 0.6.14.
Build options: gnugetopt magick iconv freetype
Send bugs to <dvdauthor-users@lists.sourceforge.net>

INFO: Locale=fr_FR.UTF-8
INFO: Converting filenames to UTF-8
STAT: 0:00:00.000
INFO: Picture /tmp/kde-yonnelPT2DbA/kdenlives30397.png had 2 colors
INFO: Picture /tmp/kde-yonnelPT2DbA/kdenliveK30397.png had 2 colors
INFO: Picture /tmp/kde-yonnelPT2DbA/kdenliveS30397.png had 2 colors
INFO: Pickbuttongroups, success with 1 groups, useimg=1
INFO: Found EOF in .sub file.
INFO: Max_sub_size=6958
WARN: Button y coordinates are odd for button b0: 389x456-514x487; they may not display properly.
WARN: Button y coordinates are odd for button b3: 472x306-664x337; they may not display properly.
WARN: Button y coordinates are odd for button b6: 394x154-558x185; they may not display properly.
WARN: Button y coordinates are odd for button b8: 81x206-277x237; they may not display properly.
WARN: Button y coordinates are odd for button b11: 52x356-235x387; they may not display properly.
WARN: Button y coordinates are odd for button b12: 78x406-219x437; they may not display properly.
WARN: Button y coordinates are odd for button b14: 258x504-455x535; they may not display properly.
INFO: 1 subtitles added, 0 subtitles skipped, stream: 32, offset: 0.50

Statistics:
- Processed 0 subtitles.
- The longest display line had -1 characters.
- The maximum number of displayed lines was 0.
- The normal display height of the font arial.ttf was 0.
- The bottom display height of the font arial.ttf was 0.
- The biggest subtitle box had 6958 bytes.

DVDAuthor::dvdauthor, version 0.6.14.
Build options: gnugetopt magick iconv freetype
Send bugs to <dvdauthor-users@lists.sourceforge.net>


INFO: Locale=fr_FR.UTF-8
INFO: Converting filenames to UTF-8
ERR: Parse error 'syntax error, unexpected TITLE_TOK' on token 'title'
ERR: Parser failed on code '{title 1;}'.


Le processus DVDAuthor s'est terminé par une erreur fatale.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filespng file icon Capture-1.png [^] (179,018 bytes) 2010-03-04 20:27


xml file icon Menu DVD Ceillac v2.xml [^] (17,711 bytes) 2010-03-27 08:47
? file icon Ceillac.kdvd [^] (3,101 bytes) 2010-03-27 15:43

- Relationships

-  Notes
(0004851)
thatonefilmguy (reporter)
2010-03-22 23:00

Can you try setting you language to US English and see if you can make a dvd?
(0004880)
j-b-m (administrator)
2010-03-26 19:27

Another thing you could do is save your dvd project and attach it here, that would help for debugging.
(0004881)
thatonefilmguy (reporter)
2010-03-27 01:14

I tried reproducing this with French language enabled and couldn't reproduce the bug, so it doesn't seem to be an i18n issue afaik. As j-b-m suggested, if you can upload your dvd project that will help.

Thanks!
(0004882)
ybecognee (reporter)
2010-03-27 08:51

Thank you for your help !
Here is one of my trials.

Thanks for this great software
(0004883)
j-b-m (administrator)
2010-03-27 10:54

The attached xml file was created with dvdstyler, nothing to do with Kdenlive... I need the Kdenlive DVD project file (from the DVD wizard, create your DVD menu, then click "Save", it should create a .kdvd file
(0004885)
ybecognee (reporter)
2010-03-27 15:45

I'm really sorry... I tried other solutions to complete the DVD and I confused the files...
I apologize
(0004886)
j-b-m (administrator)
2010-03-28 15:22

Ok, I found the problem, this is now fixed in svn rev. 4360.
The crash happened when a button in the DVD menu was set to "Play All" after having another value.

As a workaround for Kdenlive 0.7.7.x if you encounter this crash, you can do the following:

* Save your Kdenlive DVD project file (it should save with a .kdvd extension)
* Open the project file with a text editor
* Look for the following string: command="title 1"
* Replace it with: command="jump title 1"
* Save the file and open it in the DVD Wizard, the project should now work.
(0004918)
ybecognee (reporter)
2010-04-04 19:59

Thank you !

Very nice ! It's working now :-)

Thank you very much every body !

- Issue History
Date Modified Username Field Change
2010-03-04 20:27 ybecognee New Issue
2010-03-04 20:27 ybecognee File Added: Capture-1.png
2010-03-22 23:00 thatonefilmguy Note Added: 0004851
2010-03-26 19:27 j-b-m Note Added: 0004880
2010-03-27 01:14 thatonefilmguy Note Added: 0004881
2010-03-27 08:47 ybecognee File Added: Menu DVD Ceillac v2.xml
2010-03-27 08:51 ybecognee Note Added: 0004882
2010-03-27 10:54 j-b-m Note Added: 0004883
2010-03-27 10:54 j-b-m Assigned To => j-b-m
2010-03-27 10:54 j-b-m Status new => feedback
2010-03-27 15:43 ybecognee File Added: Ceillac.kdvd
2010-03-27 15:45 ybecognee Note Added: 0004885
2010-03-27 15:45 ybecognee Status feedback => assigned
2010-03-28 15:22 j-b-m Note Added: 0004886
2010-03-28 15:22 j-b-m Status assigned => resolved
2010-03-28 15:22 j-b-m Resolution open => fixed
2010-03-28 15:22 j-b-m Fixed in Version => Recent git
2010-04-01 00:19 xzhayon Target Version => future version
2010-04-04 19:59 ybecognee Note Added: 0004918
2010-04-04 19:59 ybecognee Status resolved => feedback
2010-04-04 19:59 ybecognee Resolution fixed => reopened
2010-04-05 14:06 j-b-m Status feedback => resolved
2010-04-05 14:06 j-b-m Resolution reopened => fixed
2010-09-14 11:01 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:00 j-b-m Status resolved => closed
2010-09-22 17:54 Granjow Target Version future version => 0.7.8


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker