Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001511KdenliveUser Interfacepublic2010-03-16 04:552010-09-22 17:54
Reporterthatonefilmguy 
Assigned Toxzhayon 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSUbuntu LinuxOS Version9.10
Product VersionRecent git 
Target Version0.7.8Fixed in Version0.7.8 
Summary0001511: Drop Frame timecode not displayed in preview windows or titler
DescriptionCurrently the timecode displayed in Source/Master preview windows and the titler is always in non-drop frame format "00:00:00:00".

When previewing a drop frame sequence in the Master preview window, the timecode should be displayed in drop frame format "00:00:00;00". When the sequence is played in the Master viewer, the timecode will drop frames as it is displayed; however, it will still be displayed in NDF format, even after applying the patch for issue 0001033.

When using the titler, if the project is drop frame then the timecode length for titles should also be in DF format "00:00:00;00".

When viewing a clip in the source preview window, if the clip has drop frame timecode (although I don't think kdenlive even currently reads timecode of source clips) then it should also be displayed in drop frame format. Of course, this is dependent on kdl actually displaying the timecode in the first place.
Steps To Reproduce1. Create an HDV 1440x1080 29.97i project.
2. Note that the timecode displayed in the Master viewer window is in non-drop frame format "00:00:00:00". It should be "00:00:00;00"
3. Note that the timecode displayed in the Preview window is also NDF for all clips (as mentioned above, this depends on timecode format of clips actually being detected)
4. Create a title. Note that timecode is displayed in NDF format.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Files

- Relationships

-  Notes
(0004836)
thatonefilmguy (reporter)
2010-03-18 14:15

Fixed by the latest patch for issue 0001033.

However. The DF display format used is "99:99.99:99" instead of "99:99:99;99" because Qt does not allow use of semicolon ';' separators in a field's inputMask.
(0004905)
xzhayon (developer)
2010-04-01 00:48

let's keep this open until we decide if it's worth trying to support the correct timecode with the ';'

apparently, the solution could be trivial. it's late in the night and i can't check deeper, so i leave this as a record: http://doc.trolltech.com/4.6/qlineedit.html#setValidator [^]

another suggestion: try escaping the semicolon with a backslash
(0004907)
thatonefilmguy (reporter)
2010-04-01 01:24

I tried escaping with a backslash, it doesn't work.

I saw an open Qt bug regarding this issue somewhere on the net but can't find it now. It would be an easy fix if Qt allows semicolons as separators at some point in the future.
(0005125)
xzhayon (developer)
2010-05-11 15:27

fixed in rev. 4428

- Issue History
Date Modified Username Field Change
2010-03-16 04:55 thatonefilmguy New Issue
2010-03-18 14:15 thatonefilmguy Note Added: 0004836
2010-04-01 00:48 xzhayon Note Added: 0004905
2010-04-01 00:48 xzhayon Status new => acknowledged
2010-04-01 00:50 xzhayon Target Version => future version
2010-04-01 01:24 thatonefilmguy Note Added: 0004907
2010-05-11 15:27 xzhayon Note Added: 0005125
2010-05-11 15:27 xzhayon Status acknowledged => resolved
2010-05-11 15:27 xzhayon Fixed in Version => Recent git
2010-05-11 15:27 xzhayon Resolution open => fixed
2010-05-11 15:27 xzhayon Assigned To => xzhayon
2010-09-14 11:01 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:00 j-b-m Status resolved => closed
2010-09-22 17:54 Granjow Target Version future version => 0.7.8


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker