Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001528KdenliveUser Interfacepublic2010-03-22 00:452010-09-22 17:54
Reporterthe-me 
Assigned Toj-b-m 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
Platformi386OSDebianOS VersionSqueeze
Product Version0.7.7.1 
Target Version0.7.8Fixed in Version0.7.8 
Summary0001528: Unusual pointer arithmetic
DescriptionI have run an automated test with cppcheck against kdenlive 0.7.7.1 and there is one error:

[./src/dvdwizard.cpp:651]: (error) Unusual pointer arithmetic

This should be fixed.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0004852)
thatonefilmguy (reporter)
2010-03-23 05:00

The " Overwrite?" + '\n'," is probably the cause of this issue in this line:

warnMessage.append(i18n("Folder %1 already exists. Overwrite?" + '\n', m_status.tmp_folder->url().path(KUrl::AddTrailingSlash) + "DVD"));

I don't know how to actually get this message to display though, so I don't want to write a patch if I can't actually test it. But I suspect this would make the problem go away:

warnMessage.append(i18n("Folder %1 already exists. Overwrite?\n", m_status.tmp_folder->url().path(KUrl::AddTrailingSlash) + "DVD"));

Not sure if it needs to be \\n or just \n in that case though. I do more PHP than C++.
(0004858)
the-me (reporter)
2010-03-23 11:56

I can verify, that this fixes the problem, but I didn't tested the resulted binary.
(0004866)
j-b-m (administrator)
2010-03-24 10:50

Fixed in svn rev. 4355

- Issue History
Date Modified Username Field Change
2010-03-22 00:45 the-me New Issue
2010-03-23 05:00 thatonefilmguy Note Added: 0004852
2010-03-23 11:56 the-me Note Added: 0004858
2010-03-24 10:50 j-b-m Note Added: 0004866
2010-03-24 10:50 j-b-m Assigned To => j-b-m
2010-03-24 10:50 j-b-m Status new => feedback
2010-03-25 11:50 j-b-m Status feedback => resolved
2010-03-25 11:50 j-b-m Fixed in Version => Recent git
2010-03-25 11:50 j-b-m Resolution open => fixed
2010-04-01 00:19 xzhayon Target Version => future version
2010-09-14 11:01 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:00 j-b-m Status resolved => closed
2010-09-22 17:54 Granjow Target Version future version => 0.7.8


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker