Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001546KdenliveFile Loadingpublic2010-04-05 22:182010-11-19 21:55
Reportermaxkessler 
Assigned Toj-b-m 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSFedora LinuxOS Version12
Product Version0.7.7.1 
Target VersionFixed in Version0.7.8 
Summary0001546: Slideshow Clip menu item causes crash (OOM)
DescriptionSelecting the "Slideshow Clip" item in the menu causes Kdenlive to grow a huge memory footprint until it gets killed by the Linux OOM killer.
Steps To ReproducePut a bunch of gigantic (3000x3000 and up) JPEG files in your home directory and select the "Slideshow Clip" menu item (on a computer with 512 MB of RAM and 1 GB of swap).
Additional InformationIn the previous version I used (I forget what number that was) it tried to load and generate thumbnails of *every* image in my home directory. Since I have lots of gigantic images in my home directory, I suspect the new version is still generating thumbnails, but not freeing memory in the process.

I suggest allowing a user to select another directory, *then* having it optionally generate thumbnails of images in that directory. I deselected the options to generate preview images and sound, so those don't show up in the time line. Maybe thumbnail generation in the Slideshow Clip dialog should honor this setting.

Is there another way to generate animations with transparency besides a sequence of PNG files?
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Filespng file icon Slideshow_Clip_window.png [^] (37,061 bytes) 2010-04-07 09:45

- Relationships

-  Notes
(0004926)
j-b-m (administrator)
2010-04-06 03:04

Hi.
I just added a checkbox in the slideshow dialog to enable/disable thumbnails. I also changed the way thumbs are created so that now they are created in the background, that should prevent the issue you encountered. Feedback welcome, all that is in svn rev. 4371
(0004934)
maxkessler (reporter)
2010-04-07 21:41

The screenshot is from the "branch" in the "release-0_7_7" directory. It hung for over 10 minutes before bringing up the dialog and I don't see any checkbox. What directory has the updated version?

Also, I was able to modify the code to put the last image type (Open EXR) at the top of the list and rebuilt it. Since I have no files of that type, the dialog pops right up now.
(0004935)
ttill (developer)
2010-04-08 11:09

The current svn revision normally refers to the trunk directory.
The following command will do the checkout:
svn co https://kdenlive.svn.sourceforge.net/svnroot/kdenlive/trunk/kdenlive [^]

(http://kdenlive.org/user-manual/downloading-and-installing-kdenlive/installing-source/installing-kdenlive [^])

- Issue History
Date Modified Username Field Change
2010-04-05 22:18 maxkessler New Issue
2010-04-06 03:04 j-b-m Note Added: 0004926
2010-04-06 03:04 j-b-m Assigned To => j-b-m
2010-04-06 03:04 j-b-m Status new => feedback
2010-04-07 05:25 maxkessler Note Added: 0004929
2010-04-07 05:25 maxkessler Status feedback => assigned
2010-04-07 07:06 maxkessler Note Deleted: 0004929
2010-04-07 09:45 maxkessler File Added: Slideshow_Clip_window.png
2010-04-07 21:41 maxkessler Note Added: 0004934
2010-04-08 11:09 ttill Note Added: 0004935
2010-11-19 21:55 ttill Status assigned => resolved
2010-11-19 21:55 ttill Resolution open => fixed
2010-11-19 21:55 ttill Fixed in Version => 0.7.8
2010-11-19 21:55 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker