Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001548KdenliveCapturepublic2010-04-08 19:292010-09-14 23:00
Reporterfoobar123 
Assigned Tottill 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSKubuntu LinuxOS Version9.10
Product Version0.7.5 
Target VersionFixed in Version0.7.8 
Summary0001548: Screen Capture does not work with more than one Jack port
DescriptionWhen capturing the screen in kdenlive with recordmydesktop, entering more than one Jack port into the Screen Grab config dialog makes the Record button do nothing. There is no error message in the GUI or stdout.

Capturing with only one Jack port works fine.
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0004947)
ttill (developer)
2010-04-08 22:02

The first thing you should do is upgrading to a newer version of kdenlive. Current version is 0.7.7.1. See:
http://www.kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-compiled-packages/ubuntu-packages [^]
If the bug still exists please confirm.
(0004948)
foobar123 (reporter)
2010-04-08 23:05

I upgraded. The bug still exists.

The problem seems to be related to command line parsing. The list of Jack ports seems not to be split into separate tokens. Recordmydesktop then gets "alsa_pcm:monitor_1 alsa_pcm:monitor_2" as one port name argument.

I've replaced /usr/local/bin/recordmydesktop with a script which simply calls the real recordmydesktop binary. The shell causes parameters to be split. Now recording works here.

So a fix would be to split the Port list at whitespace boundaries in Kdenlive, and there should probably be a hint like "Enter port names separated by spaces".
(0004949)
ttill (developer)
2010-04-09 00:20

I will try to provide a patch later.
(0004950)
ttill (developer)
2010-04-09 13:04
edited on: 2010-04-09 13:05

See this link for the message I sent to the developer mailing list including the patch:
http://sourceforge.net/mailarchive/forum.php?thread_name=4BBEFBB2.6000000%40ttill.de&forum_name=kdenlive-devel [^]

Hope it works now.
If you don't want to wait until the next release the easiest way is probably to use sunab's unstable ppa, which will probably include the patch in the next few days (see: http://kdenlive.org/user-manual/downloading-and-installing-kdenlive/pre-compiled-packages/ubuntu-packages [^])

(0004951)
foobar123 (reporter)
2010-04-09 13:11

Cool, thanks.
(0004956)
ttill (developer)
2010-04-10 13:15

should be fixed in svn rev. 4379
(0004965)
foobar123 (reporter)
2010-04-10 13:43

I use the sunab2 ppa so I should get it with the next weekly build. I'll report back if something still doesn't work. Thanks again

- Issue History
Date Modified Username Field Change
2010-04-08 19:29 foobar123 New Issue
2010-04-08 22:02 ttill Note Added: 0004947
2010-04-08 23:05 foobar123 Note Added: 0004948
2010-04-09 00:20 ttill Note Added: 0004949
2010-04-09 13:04 ttill Note Added: 0004950
2010-04-09 13:05 ttill Note Edited: 0004950 View Revisions
2010-04-09 13:11 foobar123 Note Added: 0004951
2010-04-10 13:15 ttill Note Added: 0004956
2010-04-10 13:43 foobar123 Note Added: 0004965
2010-05-18 15:49 ttill Assigned To => ttill
2010-05-18 15:49 ttill Status new => resolved
2010-05-18 15:49 ttill Resolution open => fixed
2010-05-18 15:49 ttill Fixed in Version => Recent git
2010-09-14 11:01 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:00 j-b-m Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker