Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001556KdenliveUser Interfacepublic2010-04-18 23:342011-06-10 10:50
Reportercentic 
Assigned Toj-b-m 
PriorityhighSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformKubuntuOSLinuxOS Version9.10
Product Version0.7.7.1 
Target VersionFixed in Version0.8 
Summary0001556: Kdenlive crashed after using the "distance" tool
DescriptionApplication: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0x7ff4c14d1750 (LWP 15559))]

Thread 3 (Thread 0x7ff4a46a3910 (LWP 25775)):
#0 0x00007ff4be75982d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007ff4c10e96fa in mlt_consumer_get_frame () from /usr/lib/libmlt.so.2
0000002 0x00007ff4c10e985d in mlt_consumer_rt_frame () from /usr/lib/libmlt.so.2
0000003 0x00007ff4b027782c in ?? () from /usr/lib/mlt/libmltsdl.so
0000004 0x00007ff4be754a04 in start_thread () from /lib/libpthread.so.0
0000005 0x00007ff4bce2280d in clone () from /lib/libc.so.6
0000006 0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ff4a16ed910 (LWP 25776)):
#0 0x00007ff4be7595a9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1 0x00007ff4b027716d in ?? () from /usr/lib/mlt/libmltsdl.so
0000002 0x00007ff4be754a04 in start_thread () from /lib/libpthread.so.0
0000003 0x00007ff4bce2280d in clone () from /lib/libc.so.6
0000004 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ff4c14d1750 (LWP 15559)):
[KCrash Handler]
0000005 0x00007ff4c0ec967b in Mlt::Playlist::insert_at(int, Mlt::Producer*, int) () from /usr/lib/libmlt++.so.3
0000006 0x00000000004a4f84 in _start ()
Steps To ReproduceNot 100% sure, but I was using the distance tool and afterwards kdenlive became unstable and finally crashed with the stackinformation listed above.

I rate this high because afterwards some parts of my audio mixing were gone and could not be restored any more from the crashed session, especially the audio transitions were gone!
TagsNo tags attached.
Build/Install Method3rd party package
Attached Files

- Relationships
related to 0001605closedj-b-m crashed when i edit 

-  Notes
(0005089)
ddennedy (developer)
2010-05-01 07:44

By "distance tool" do you actually mean the "Color Distance Effect" in Kdenlive terminology?
(0005100)
centic (reporter)
2010-05-02 18:28

I meant the tool that is called "Abstandswerkzeug" in German, its the arrow-button right of the scissors in the status bar at the bottom.
(0005177)
xzhayon (developer)
2010-05-19 16:58

the spacer tool
(0006489)
IceHand (reporter)
2011-02-24 18:41

I can confirm this using Kdenlive 0.7.8 and Arch Linux 2011-02-24. If it's the same bug (and I suspect it is) it's very easy to reproduce:

1. Insert two clips into an empty timeline
2. Using the selection tool: select both and move them around a bit
3. Deselect them and use the spacer tool to move them

You should start noticing Kdenlive's strange behaviour. You might end up with clips that cannot be moved, "invisible" clips and clips that are outside of the active timeline (that greyed out part at the rear). After this happens Kdenlive might crash too.

If need be, I can give additional information and/or logs.
(0006490)
j-b-m (administrator)
2011-02-24 19:07

I could reproduce in current svn using IceHand's steps
(0006491)
j-b-m (administrator)
2011-02-24 19:47

Should be fixed in svn rev. 5457
(0006493)
IceHand (reporter)
2011-02-25 00:58
edited on: 2011-02-25 01:02

Yes, should be fixed. I can no longer reproduce with rev. 5458.


- Issue History
Date Modified Username Field Change
2010-04-18 23:34 centic New Issue
2010-05-01 07:44 ddennedy Note Added: 0005089
2010-05-01 07:44 ddennedy Status new => feedback
2010-05-02 18:28 centic Note Added: 0005100
2010-05-02 18:28 centic Status feedback => new
2010-05-19 16:58 xzhayon Note Added: 0005177
2010-05-20 08:16 j-b-m Relationship added related to 0001605
2011-02-24 18:41 IceHand Note Added: 0006489
2011-02-24 19:07 j-b-m Note Added: 0006490
2011-02-24 19:07 j-b-m Assigned To => j-b-m
2011-02-24 19:07 j-b-m Status new => acknowledged
2011-02-24 19:47 j-b-m Note Added: 0006491
2011-02-24 19:47 j-b-m Status acknowledged => feedback
2011-02-25 00:58 IceHand Note Added: 0006493
2011-02-25 01:02 IceHand Note Edited: 0006493 View Revisions
2011-02-25 15:24 j-b-m Status feedback => resolved
2011-02-25 15:24 j-b-m Fixed in Version => Recent git
2011-02-25 15:24 j-b-m Resolution open => fixed
2011-04-26 21:58 j-b-m Fixed in Version Recent git => 0.8
2011-06-10 10:50 Granjow Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker