Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001563KdenliveMLTpublic2010-04-25 10:182010-11-19 21:27
Reporterttill 
Assigned Toddennedy 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform64 bitOSArch LinuxOS Versioncurrent
Product VersionRecent git 
Target VersionFixed in Version0.7.8 
Summary0001563: Crash when switching between monitors
DescriptionI tried different formats but was only able to reproduce using DNxHD clips, which I generated using the transcode menu. The original AVCHD files however work without problems.

The crash also appears with some other combinations of switching between clip/project monitor and selecting / deselecting clips in the project tree.

The problem exists for some time now but I could not find any regularity until now.
Steps To Reproduceadd clip
drag clip to timeline
select project monitor
select clip monitor again
-> crash
Additional InformationKdenlive, ffmpeg latest svn
mlt, x264 latest git

The crash seems to appear in ffmpeg / libswscale, so I recompiled
ffmpeg without stripping to provide a better backtrace.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filestxt file icon kdenlive-20100425.kcrash.txt [^] (9,617 bytes) 2010-04-25 10:18 [Show Content]

- Relationships

-  Notes
(0005074)
ttill (developer)
2010-04-25 10:23

I uploaded a sample file here:
http://ttill.de/00012.MTS.mov [^]
(0005186)
ttill (developer)
2010-05-22 10:19

This seems to be related to the last frames.
The thumbnail at the end is white.
I have to crop about 3 frames from the end, than it will be displayed properly and the crash doesn't appear.
(0006078)
ttill (developer)
2010-11-19 21:26

Fixed in MLT somewhere between 0.5.6 and 0.5.8

- Issue History
Date Modified Username Field Change
2010-04-25 10:18 ttill New Issue
2010-04-25 10:18 ttill File Added: kdenlive-20100425.kcrash.txt
2010-04-25 10:23 ttill Note Added: 0005074
2010-05-22 10:19 ttill Note Added: 0005186
2010-11-19 21:25 ttill Relationship added related to 0001413
2010-11-19 21:26 ttill Note Added: 0006078
2010-11-19 21:26 ttill Assigned To => ddennedy
2010-11-19 21:26 ttill Status new => resolved
2010-11-19 21:26 ttill Resolution open => fixed
2010-11-19 21:26 ttill Fixed in Version => 0.7.8
2010-11-19 21:26 ttill Status resolved => closed
2010-11-19 21:27 ttill Relationship deleted related to 0001413


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker