Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001583KdenliveMLTpublic2010-05-05 10:402011-10-02 22:24
Reporterdavid 
Assigned Toj-b-m 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformallOSallOS Versionall
Product Version0.7.7.1 
Target VersionFixed in Version0.8 
Summary0001583: Proxy clips for editing
DescriptionMany HD-formats and image sequences are very slow to work with in Kdenlive.
You can trancode your clips to make them play smoother in Kdenlive but that involves a degradation in quality and image sequences can't be transcoded at all.

We would need possibility to use proxy clips for editing and using full-resolution originals for rendering. Proxies can be optimized small, high-compressed clips that are very fast to work with within Kdenlive.

UI could be easy as adding option in trancode dialog to link transcoded clips to original and use transcoded as proxy. (Image sequences needs to be transcodable as well!)
Then in render dialog an option to use originals or proxies when rendering.
Backend is someone else's headache ;).
Additional InformationThis issue has been discussed a few times at the forum;
http://kdenlive.org/forum/proxy-clips-hd-editing [^]
http://kdenlive.org/forum/low-quality-version-clips-editing-low-end-computers [^]
http://kdenlive.org/forum/some-questions-new-user [^]
TagsNo tags attached.
Build/Install Method(select)
Attached Files

- Relationships
related to 0001832acknowledgedj-b-m Render the preview of timeline (with effects & transitions) 

-  Notes
(0005923)
jv13613 (reporter)
2010-09-28 21:45

A highly compressed proxy is the complete opposite of what is wanted. (the high compression is what makes HD content so hard to play). And I would recommend a full resolution proxy, but would allow the option of a reduced resolution. Just decrease the quality (bitrate) significantly, but remember to use a codec that is not highly compressed. (DNxHD would be preferable for HD content)
(0005924)
j-b-m (administrator)
2010-09-28 22:28

I am going to start working on this after the Kdenlive 0.7.9 release - probably end of october. As mentionned in the previous comment, we need to carefuly choose which format is the best for this feature. It must be fast to decode and offer a good frame accuracy when seeking. A full resolution proxy would for sure be easier to implement and would also mean that we won't have bad surprises with transition that sometimes use pixel precision. However I am not sure we can get enough fps with a full HD codec...

For me the goal is to be able to play smoothly a transition between 2 clips with one or two effects on each clip when working on an HD project with a usual computer ( something like 2Gh dual core ).

So if some of you have done tests with various formats and want to share the results, just add a note here...
(0005985)
LeHomard (developer)
2010-10-19 16:01

I would say the most basic use case is for AVCHD. There are loads of people having issues with AVCHD, and the answer is always to transcode to DNxHD. Automating that step seems to be the most usefull.

Now I have a quad core computer, so I don't know how well DnxHD behaves on lower end configs, but I find it very usable.

DNxHD is good because it keeps most of the original AVCHD files quality, but it makes pretty large files. And the purpose of proxy files is to not use those files for rendering... But it would be a nice first step !

Blender implements proxy clips in it's sequencer, maybe it would be worth asking how it's done...
(0006175)
machony (reporter)
2010-12-15 13:48

I just downscale my clips, render them to XVID and add an additional file extension to copies so at least that way I can re-edit the project file to batch remove the additional file extensions and render the project with the original clips. I'm happy enough with this workflow.
(0006328)
j-b-m (administrator)
2011-01-18 23:16

I finally took time to work on this feature. Based on OpenHawk's experiments (1), I added a proxy feature in Kdenlive.

Testers are welcome. You can enable proxies for all clips in Kdenlive's settings dialog (under Project Defaults), or individually for each clip in the project tree's context menu.

(1) http://kdenlive.org/forum/proxy-clips-hd-editing [^]

- Issue History
Date Modified Username Field Change
2010-05-05 10:40 david New Issue
2010-06-04 21:07 ttill Status new => acknowledged
2010-06-04 21:07 ttill Target Version => future version
2010-09-28 21:45 jv13613 Note Added: 0005923
2010-09-28 22:28 j-b-m Note Added: 0005924
2010-09-28 22:30 j-b-m Relationship added related to 0001832
2010-10-19 16:01 LeHomard Note Added: 0005985
2010-12-15 13:48 machony Note Added: 0006175
2011-01-18 23:16 j-b-m Note Added: 0006328
2011-01-18 23:16 j-b-m Assigned To => j-b-m
2011-01-18 23:16 j-b-m Status acknowledged => feedback
2011-10-02 22:20 ttill Status feedback => resolved
2011-10-02 22:20 ttill Fixed in Version => 0.8
2011-10-02 22:20 ttill Resolution open => fixed
2011-10-02 22:24 ttill Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker