Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001587KdenliveEffectspublic2010-05-05 16:052011-01-11 17:59
Reporterdavid 
Assigned Toj-b-m 
PrioritynormalSeverityminorReproducibilitysometimes
StatusclosedResolutionfixed 
Platform64 bitOSUbuntu LinuxOS Version8.10
Product Version0.7.7.1 
Target Version0.7.8Fixed in Version0.7.8 
Summary0001587: Fade to Black, wrong end frame
DescriptionSometimes it seems like Kdenlive uses the wrong end frame for ftb. A long ftb of a few seconds get's about halfways at end of clip. If ftb is shortened to about 12fr. it isn't visible at all.

Drag end position of clip out and then back again seems to get ftb to use right frame and everything works again.
TagsNo tags attached.
Build/Install Method(select)
Attached Files? file icon fade_demo.kdenlive [^] (5,480 bytes) 2010-09-01 07:36

- Relationships
related to 0001975feedback Fade to Black, wrong end frame - like 

-  Notes
(0005146)
j-b-m (administrator)
2010-05-18 21:02

cannot reproduce on current svn. Can you try to find a reliable way to reproduce the issue, that would help...
(0005717)
fullermd (reporter)
2010-08-31 03:21

I can reproduce this on current svn/git. Add clip. Cut off a hunk at the front and a hunk at the end. Add fade from/to black. The fade _from_ will work fine; the fade _to_ will always save as happening over frames relative to the end of the entire clip, not the segment actually existing (verified by reading through save file).

This works with 0.7.7.1, but fails with current HEAD.
(0005718)
fullermd (reporter)
2010-08-31 03:25

Additional: Note that this happens to audio fade out as well. So it may be more general "attach to end of clip"-type.
(0005719)
j-b-m (administrator)
2010-08-31 07:56

Still cannot reproduce here. Can you also reproduce the problem with color clips?

Could you attach here a simple project file the shows this issue?
(0005732)
fullermd (reporter)
2010-09-01 07:36

Yes. Will upload.
4 second color clip. On first track (playlist5), added, with a 1 second fade to black at the end; just fine. On second track (playlist4), chopped a second off the end, then added a 1 second fade to black at the end; also fine. On third (playlist3), chopped a second off the front and a second off the end, and now the 1 second fade begins on the frame right after that (e.g., 1 second back from the end of the full uncut clip).
(0005734)
j-b-m (administrator)
2010-09-01 07:47

thanks a lot. can you also tell me how you cut the clip (resize with mouse, razor tool or keyboard shortcut) and how you add the effect (double click in effeft list,drag from effect list or clip's context menu)... that might be useful
(0005735)
fullermd (reporter)
2010-09-01 07:55

Cut with the razor tool. Added via context menu.

Adding via selecting the clip and then adding from the list in the Effect Stack tab acts the same. Chopping down the clip by crop/resize with mouse also does the same.
(0005758)
j-b-m (administrator)
2010-09-03 10:34

Ok, I found a few issues that caused the described problem when trying to change the effect length from the effect stack. This should now be fixed in svn rev. 4820.

However, I could not reproduce the issue when simply adding the effect without changing it's length...

Could you please try to update to latest svn and see if your problem is fixed?
(0005764)
fullermd (reporter)
2010-09-04 00:02

Seems to work here in a quick test, thanks :)

If by "without changing its length" you mean just taking the default length of the fade, I've never tried that; I always adjusted the fade length. So maybe we were talking past each other.
(0005765)
j-b-m (administrator)
2010-09-04 00:43

Ok, great. So if you were adjusting effect length, I think the problem is solved now.

- Issue History
Date Modified Username Field Change
2010-05-05 16:05 david New Issue
2010-05-18 21:02 j-b-m Note Added: 0005146
2010-05-18 21:02 j-b-m Assigned To => j-b-m
2010-05-18 21:02 j-b-m Status new => feedback
2010-08-31 03:21 fullermd Note Added: 0005717
2010-08-31 03:25 fullermd Note Added: 0005718
2010-08-31 07:56 j-b-m Note Added: 0005719
2010-09-01 07:36 fullermd Note Added: 0005732
2010-09-01 07:36 fullermd File Added: fade_demo.kdenlive
2010-09-01 07:47 j-b-m Note Added: 0005734
2010-09-01 07:55 fullermd Note Added: 0005735
2010-09-01 13:54 j-b-m Target Version => 0.7.8
2010-09-03 10:34 j-b-m Note Added: 0005758
2010-09-04 00:02 fullermd Note Added: 0005764
2010-09-04 00:43 j-b-m Note Added: 0005765
2010-09-04 00:43 j-b-m Status feedback => resolved
2010-09-04 00:43 j-b-m Resolution open => fixed
2010-09-14 23:15 ttill Status resolved => closed
2010-09-14 23:15 ttill Fixed in Version => 0.7.8
2011-02-08 08:48 ddennedy Relationship added related to 0001975


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker