Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001633KdenliveUser Interfacepublic2010-05-30 05:082010-09-22 17:54
ReporterJivanAmara 
Assigned Tottill 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionfixed 
Platform32 bit intel and alikeOSDebian LinuxOS Version4.0
Product Version0.7.7.1 
Target Version0.7.8Fixed in Version0.7.8 
Summary0001633: Crash when deleting clip.
DescriptionCrashes with a segfault after deleting a clip from the project tree which is paused in the clip monitor.
Steps To ReproduceOpen a new project.
Add a clip.
Start playing the clip then pause it.
Delete the clip from the project tree.
Press play in the clip monitor.
Additional InformationThe clip I was using was an flv.

App crash report follows:
Application: kdenlive (0.7.7.1)
KDE Platform Version: 4.4.3 (KDE 4.4.3)
Qt Version: 4.6.2
Operating System: Linux 2.6.32-3-686-bigmem i686
Distribution: Debian GNU/Linux testing (squeeze)

-- Information about the crash:
<In detail, tell us what you were doing when the application crashed.>

The crash can be reproduced every time.

 -- Backtrace:
Application: Kdenlive (kdenlive), signal: Segmentation fault
[Current thread is 1 (Thread 0xb4ce9700 (LWP 13754))]

Thread 5 (Thread 0xb1638b70 (LWP 13789)):
#0 0xb779e424 in __kernel_vsyscall ()
#1 0xb5bac3d2 in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib/i686/cmov/libpthread.so.0
0000002 0xb5c9c864 in pthread_cond_timedwait () from /lib/i686/cmov/libc.so.6
0000003 0xb777c181 in mlt_consumer_put_frame () from /usr/lib/libmlt.so.2
0000004 0x08bfd5b0 in ?? ()
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 4 (Thread 0xaed5fb70 (LWP 13881)):
#0 0xb779e424 in __kernel_vsyscall ()
#1 0xb5bac0a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/cmov/libpthread.so.0
0000002 0xb5c9c80d in pthread_cond_wait () from /lib/i686/cmov/libc.so.6
0000003 0xb2917c05 in ?? () from /usr/lib/mlt/libmltsdl.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 3 (Thread 0xafd61b70 (LWP 13882)):
#0 0xb779e424 in __kernel_vsyscall ()
#1 0xb5bac0a5 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i686/cmov/libpthread.so.0
0000002 0xb5c9c80d in pthread_cond_wait () from /lib/i686/cmov/libc.so.6
0000003 0xb777c9d8 in ?? () from /usr/lib/libmlt.so.2
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 2 (Thread 0xaf560b70 (LWP 13884)):
#0 0xb779e424 in __kernel_vsyscall ()
#1 0xb5c81b27 in poll () from /lib/i686/cmov/libc.so.6
0000002 0xb54ec0f0 in ?? () from /usr/lib/libxcb.so.1
0000003 0xb54ee761 in xcb_wait_for_reply () from /usr/lib/libxcb.so.1
0000004 0xb596a7a6 in _XReply () from /usr/lib/libX11.so.6
0000005 0xb5948a63 in _XGetWindowAttributes () from /usr/lib/libX11.so.6
0000006 0xb5948be2 in XGetWindowAttributes () from /usr/lib/libX11.so.6
0000007 0xb29180bc in ?? () from /usr/lib/mlt/libmltsdl.so
Backtrace stopped: previous frame inner to this frame (corrupt stack?)

Thread 1 (Thread 0xb4ce9700 (LWP 13754)):
[KCrash Handler]
0000006 QBasicAtomicInt::operator!= (this=0x8fe9468, t=...) at /usr/include/qt4/QtCore/qbasicatomic.h:75
0000007 QList<CommentedTime>::detach (this=0x8fe9468, t=...) at /usr/include/qt4/QtCore/qlist.h:122
0000008 QList<CommentedTime>::begin (this=0x8fe9468, t=...) at /usr/include/qt4/QtCore/qlist.h:248
0000009 DocClipBase::markerComment (this=0x8fe9468, t=...) at /build/buildd-kdenlive_0.7.7.1-2-i386-gwTj3t/kdenlive-0.7.7.1/src/docclipbase.cpp:417
0000010 0x080c4a77 in Monitor::checkOverlay (this=0x8beea40) at /build/buildd-kdenlive_0.7.7.1-2-i386-gwTj3t/kdenlive-0.7.7.1/src/monitor.cpp:551
0000011 0x080c5a88 in Monitor::seekCursor (this=0x8beea40, pos=686) at /build/buildd-kdenlive_0.7.7.1-2-i386-gwTj3t/kdenlive-0.7.7.1/src/monitor.cpp:634
0000012 0x080c7a2b in Monitor::qt_metacall (this=0x8beea40, _c=QMetaObject::InvokeMetaMethod, _id=33, _a=0x9057370)
    at /build/buildd-kdenlive_0.7.7.1-2-i386-gwTj3t/kdenlive-0.7.7.1/build/src/cmake_bindir/monitor.moc:262
0000013 0xb6aadaea in QMetaObject::metacall(QObject*, QMetaObject::Call, int, void**) () from /usr/lib/libQtCore.so.4
0000014 0xb6ab8016 in QMetaCallEvent::placeMetaCall(QObject*) () from /usr/lib/libQtCore.so.4
0000015 0xb6ab90de in QObject::event(QEvent*) () from /usr/lib/libQtCore.so.4
0000016 0xb5ff59a6 in QWidget::event(QEvent*) () from /usr/lib/libQtGui.so.4
0000017 0xb5f97bec in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000018 0xb5f9e7f9 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/libQtGui.so.4
0000019 0xb74ef7da in KApplication::notify(QObject*, QEvent*) () from /usr/lib/libkdeui.so.5
0000020 0xb6aa88eb in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/libQtCore.so.4
0000021 0xb6aab2c3 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/libQtCore.so.4
0000022 0xb6aab42d in QCoreApplication::sendPostedEvents(QObject*, int) () from /usr/lib/libQtCore.so.4
0000023 0xb6ad47ff in ?? () from /usr/lib/libQtCore.so.4
0000024 0xb566b2e5 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
0000025 0xb566f000 in ?? () from /lib/libglib-2.0.so.0
0000026 0xb566f198 in g_main_context_iteration () from /lib/libglib-2.0.so.0
0000027 0xb6ad42f5 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000028 0xb6056255 in ?? () from /usr/lib/libQtGui.so.4
0000029 0xb6aa6f09 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000030 0xb6aa735a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQtCore.so.4
0000031 0xb6aab4ef in QCoreApplication::exec() () from /usr/lib/libQtCore.so.4
0000032 0xb5f97c87 in QApplication::exec() () from /usr/lib/libQtGui.so.4
0000033 0x08082bad in main (argc=3, argv=0xbf8d86f4) at /build/buildd-kdenlive_0.7.7.1-2-i386-gwTj3t/kdenlive-0.7.7.1/src/main.cpp:86
TagsNo tags attached.
Build/Install MethodDistribution package
Attached Files

- Relationships

-  Notes
(0005237)
JivanAmara (reporter)
2010-05-30 05:13

Sorry about the duplicates. When the site complained that the file 'kdenlive-20100530.kcrash' I tried to upload wasn't acceptable, I thought the issue hadn't been submitted at all.
(0005238)
Granjow (developer)
2010-05-30 08:36

Duplicates deleted. Always these buggy bug reporters :)

Cannot reproduce in curent SVN. Does it happen with only this clip?
(0005239)
JivanAmara (reporter)
2010-05-30 14:33

No, it happens with every (so far five) flv file I've attempted it with.
(0005240)
Granjow (developer)
2010-05-30 14:42

Could you perhaps upload one of them?
(0005248)
JivanAmara (reporter)
2010-06-02 12:46

Sure, enjoy :)
(0005252)
Granjow (developer)
2010-06-02 19:30

Thanks. Tried -- still cannot reproduce it here. After deleting the clip from the project tree the clip monitor gets black and just plays «black» as in a new project.

And -- Sorry, forgot to mention that. Is the clip free? Otherwise we'd better delete it again, we're no file sharing page here ;)

Did you also try non-flv files?
(0005257)
JivanAmara (reporter)
2010-06-03 12:20
edited on: 2010-06-03 12:25

I'm pretty sure that Chinese intellectual property laws allow the sharing of this file...it's not helping you recreate the problem though, so there's no reason not to remove it to set your mind at ease.

I just tried with an avi and got the same behavior.

Does your package manager allow you to easily install Version 0.7.7.1 to check if it's something that was fixed between the version Debian-Testing has and the current svn? I think that's easier than me building the current svn.

(0005258)
Granjow (developer)
2010-06-03 13:19

Ah.
Checked out the 0.7.7 release branch -> reproducible.
Has been fixed in r4402 by ttill, about 2 months ago :)

- Issue History
Date Modified Username Field Change
2010-05-30 05:08 JivanAmara New Issue
2010-05-30 05:13 JivanAmara Note Added: 0005237
2010-05-30 08:36 Granjow Note Added: 0005238
2010-05-30 14:33 JivanAmara Note Added: 0005239
2010-05-30 14:42 Granjow Note Added: 0005240
2010-06-02 12:42 JivanAmara File Added: Chinese_Cartoon_001.flv
2010-06-02 12:46 JivanAmara Note Added: 0005248
2010-06-02 19:30 Granjow Note Added: 0005252
2010-06-03 12:20 JivanAmara Note Added: 0005257
2010-06-03 12:25 JivanAmara Note Edited: 0005257 View Revisions
2010-06-03 13:14 Granjow File Deleted: Chinese_Cartoon_001.flv
2010-06-03 13:19 Granjow Note Added: 0005258
2010-06-03 13:19 Granjow Status new => resolved
2010-06-03 13:19 Granjow Fixed in Version => Recent git
2010-06-03 13:19 Granjow Resolution open => fixed
2010-06-03 13:19 Granjow Assigned To => ttill
2010-06-03 13:19 Granjow Target Version => future version
2010-09-14 11:01 j-b-m Fixed in Version Recent git => 0.7.8
2010-09-14 23:01 j-b-m Status resolved => closed
2010-09-22 17:54 Granjow Target Version future version => 0.7.8


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker