Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001713KdenliveMLTpublic2010-07-26 18:332010-08-18 12:36
ReporterGranjow 
Assigned Toddennedy 
PrioritynormalSeverityminorReproducibilityalways
StatusassignedResolutionopen 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version 
Summary0001713: Font antialiasing only with background color?
DescriptionI'm not sure whether this is really MLT or something else.

In the attached project the upper word is directly on the semitransparent rect, the lower word is in a transparent title above the other one. They should look equal, but don't.
TagsNo tags attached.
Build/Install MethodManual build from SVN
Attached Filespng file icon kdenlive-transparency.png [^] (44,874 bytes) 2010-07-26 18:33


? file icon FontTransparency.kdenlive [^] (11,331 bytes) 2010-07-26 18:34
png file icon kdenlive-title-alpha-diff.png [^] (27,874 bytes) 2010-08-17 10:10


? file icon composite-alpha.kdenlive [^] (8,479 bytes) 2010-08-18 12:24
png file icon composite-auto-vs-track3.png [^] (40,194 bytes) 2010-08-18 12:33

- Relationships
related to 0001485new Image Alpha Transparency does not work as expected 

-  Notes
(0005419)
ddennedy (developer)
2010-07-29 20:57

I do not understand. Needs better description.
(0005639)
Granjow (developer)
2010-08-17 10:12

The characters don't look equal. See attached image. The ones with the #000/50% background look much smoother.
(0005641)
ddennedy (developer)
2010-08-17 10:26

I see. I think this is due to the compositor operating in yuv422 with no interpolation. Its shortcuts impose a number of limitations. The titles with a background have a very course alpha channel whereas the titles without have an alpha channel that follows the lines of the text.
(0005644)
Granjow (developer)
2010-08-18 12:31

I just noticed something else which might be related (but also maybe not).

In the project I attached (composite-alpha) I've got two titles on top of each other, both containing a semi-transparent rectangle. When I stack them on top of each other I expected the first one to darken the second one, but it does not do so (first part in the project). Only if the Composite effect is applied to the third track (white) for both rectangles.
(0005645)
Granjow (developer)
2010-08-18 12:36

Added another example image. Setup is the same as in the kdenlive project.

The left image was the reason why I opened this bug. With video background it's far better visible.

On the left I've got
0: «Wenn …», white text only, no background. Composite transition with auto = 1.
1: «zuerst …», white text on semi-transparent background rectangle. Composite with auto = 2.
2: Video.

On the right the same, except for
0: Composite with track 2 (Video)

- Issue History
Date Modified Username Field Change
2010-07-26 18:33 Granjow New Issue
2010-07-26 18:33 Granjow File Added: kdenlive-transparency.png
2010-07-26 18:33 Granjow File Added: FontTransparency.kdenlive
2010-07-26 18:34 Granjow File Deleted: FontTransparency.kdenlive
2010-07-26 18:34 Granjow File Added: FontTransparency.kdenlive
2010-07-29 20:17 Granjow Relationship added related to 0001485
2010-07-29 20:57 ddennedy Note Added: 0005419
2010-07-29 20:57 ddennedy Assigned To => ddennedy
2010-07-29 20:57 ddennedy Status new => feedback
2010-08-17 10:10 Granjow File Added: kdenlive-title-alpha-diff.png
2010-08-17 10:12 Granjow Note Added: 0005639
2010-08-17 10:12 Granjow Status feedback => assigned
2010-08-17 10:26 ddennedy Note Added: 0005641
2010-08-18 12:24 Granjow File Added: composite-alpha.kdenlive
2010-08-18 12:31 Granjow Note Added: 0005644
2010-08-18 12:33 Granjow File Added: composite-auto-vs-track3.png
2010-08-18 12:36 Granjow Note Added: 0005645


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker