Kdenlive   bug tracker Home page

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000172KdenliveBuild Systempublic2008-09-17 08:542008-11-12 23:00
Reportermtxd 
Assigned To 
PrioritynormalSeverityblockReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product VersionRecent git 
Target VersionFixed in Version0.7.0 beta 
Summary0000172: Does not compile
Descriptionffmpeg: Revision 15339
mlt: Revision 1181
kdenlive: Revision 2396

[ 93%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/kdenlivesettings.o
Linking CXX executable kdenlive
/usr/local/lib/libavformat.so: undefined reference to `av_fifo_realloc2'
/usr/local/lib/libavcodec.so.52: undefined reference to `av_memcpy_backptr'
/usr/local/lib/libavcodec.so.52: undefined reference to `av_lfg_init'
collect2: ld returned 1 exit status
make[2]: *** [src/cmake_bindir/kdenlive] Error 1
make[1]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/all] Error 2
make: *** [all] Error 2
TagsNo tags attached.
Build/Install Method
Attached Files? file icon kdenliveBuilderWizard.rc [^] (516 bytes) 2008-09-29 10:06
? file icon kbw-action.sh [^] (39,649 bytes) 2008-09-29 10:06
? file icon kbw-log [^] (729,244 bytes) 2008-09-29 10:35

- Relationships

-  Notes
(0000264)
madsdyd (administrator)
2008-09-26 17:11

Using the following revisions compiles here:

ffmpeg revision 15426
mlt revision 1182
mlt++ revision 1182
kdenlive revision 2413

If you have trouble building/obtaining the KDE4/qt4 version of Kdenlive, please consult http://en.wikibooks.org/wiki/Kdenlive/Getting_and_installing [^]

You may especially be interessted in the Kdenlive Builder Wizard, available at http://www.kde-apps.org/content/show.php?content=85826 [^] .
(0000294)
mtxd (reporter)
2008-09-29 08:21

Updated to the latest svn's, but still get the same error message:

[ 93%] Building CXX object src/cmake_bindir/CMakeFiles/kdenlive.dir/kdenlivesettings.o
Linking CXX executable kdenlive
/usr/local/lib/libavformat.so: undefined reference to `av_fifo_realloc2'
/usr/local/lib/libavcodec.so.52: undefined reference to `av_memcpy_backptr'
/usr/local/lib/libavcodec.so.52: undefined reference to `av_lfg_init'
collect2: ld returned 1 exit status
make[2]: *** [src/cmake_bindir/kdenlive] Error 1
make[1]: *** [src/cmake_bindir/CMakeFiles/kdenlive.dir/all] Error 2
make: *** [all] Error 2
(0000295)
mtxd (reporter)
2008-09-29 08:23

FFMPEG:
./configure --enable-gpl --enable-shared --enable-libvorbis --enable-postproc --enable-swscale

MLT:
./configure --prefix=/usr --enable-gpl --qimage-libdir=/usr/lib/ --qimage-includedir=/usr/include/qt4 --disable-mmx --avformat-swscale --avformat-static=/usr/src/ffmpeg
(0000296)
madsdyd (administrator)
2008-09-29 08:29

I am a bit confused.

Are you trying to compile head from Kdenlive, or the Kdenlive KDE4 version? (A branch).

Could I persuade you to try the Wizard? If that fails, I would really like the log. If it does not fail, we can look at the options you are passing to the various modules (ffmpeg, mlt, mlt++ and kdenlive).

Also, could you try to remove any old installs before you try manually (as opposed to using the wizard) to compile again?
(0000297)
mtxd (reporter)
2008-09-29 09:04
edited on: 2008-09-29 09:44

Kdenlive KDE4:

URL: https://kdenlive.svn.sourceforge.net/svnroot/kdenlive/branches/KDE4 [^]
Repository Root: https://kdenlive.svn.sourceforge.net/svnroot/kdenlive [^]
Repository UUID: a2abcaa8-d70d-0410-9ff2-926f44380769
Revision: 2417

Wizard doesn't work for me, it doesn't even start. kmdr-executor is not included in debian kommander 4.1.1 package.
kommander ./85826-kdenlive_builder_wizard.kmdr doesn't work either. The window opens, but it is blank with only 3 buttons: back, finish and cancel.
Errors in console:

-----------------------------
kommander(28902) KommanderFactory::loadConnections: CONNECTION FAILED: Signal: TextBrowser . "textChanged()" Slot: TextBrowser . "scrollToBottom()"
kommander(28902) KommanderFactory::loadConnections: No slot: "scrollToBottom()" in object TextBrowser(0x9da660, name = "TextBrowserDisplayStatus")
kommander(28902) KommanderWidget::evalFunction: "This is the initial run"

...a long list of similar error...

kommander(28902) KommanderWidget::DBUSQuery: DBUS call result for "checked(QString)" : 2 : (QVariant(bool, true) ) error: ""
kommander(28902) KommanderWidget::DBUSQuery: DBUS call result for "setEnabled(QString, bool)" : 2 : () error: ""
/bin/sh: line 4: syntax error near unexpected token `then'
/bin/sh: line 4: ` then'
-----------------------------

I did "make distclean" before compiling ffmpeg, mlt and kdenlive.

By the way, the system I try to compile on is x86_64

(0000298)
madsdyd (administrator)
2008-09-29 10:11

Hmm. Sad about the wizard, but lets try another approach (I insist :-)

I have uploaded two files. One is a configuration file, similar to the one the Wizard creates. The other is a script, that reads the configuration file and compiles kdenlive from it.

Save both files. Edit the configuration file, change /home/madsdyd/ to your home dir. Note that a single tab is used as a seperator. Make two dirs in your home directory:

mkdir src
mkdir kdenlive

(Don't worry about the dirs, you can always delete them later on).

run the script :
chmod 755 kbw-action.sh
./kbw-action.sh -c kdenliveBuilderWizard.rc | tee kbw-log

Lets take it from there - the log will contain useful information wheter the compile fails or not.

OK?
(0000299)
mtxd (reporter)
2008-09-29 10:35
edited on: 2008-09-29 10:37

It works :)
I attached the log file anyway, maybe it will help to find out what was wrong.

Will try it with my HV30 in some hours :)

P.S. Tell me please if you find what was wrong.

(0000301)
madsdyd (administrator)
2008-09-29 10:48

Happy to hear it works :-)

My best bet about the problems is that you have some old installation parts of ffmpeg lying about in either /usr or /usr/local. I know you make a "make distclean", but you should probably make a "make uninstall" too. Or something. I always prefer not to install into /usr/local/ for fear of polluting it with stuff that is hard to remove later on. Sometimes /usr/local/ffmpeg-something/, but rarely /usr/local directly.

I have closed this issue - if you have problems with your HV30, then please create a new issue. Thanks.

- Issue History
Date Modified Username Field Change
2008-09-17 08:54 mtxd New Issue
2008-09-26 17:11 madsdyd Status new => closed
2008-09-26 17:11 madsdyd Note Added: 0000264
2008-09-26 17:11 madsdyd Resolution open => unable to reproduce
2008-09-26 17:11 madsdyd Fixed in Version => Recent git
2008-09-29 08:21 mtxd Status closed => feedback
2008-09-29 08:21 mtxd Resolution unable to reproduce => reopened
2008-09-29 08:21 mtxd Note Added: 0000294
2008-09-29 08:23 mtxd Note Added: 0000295
2008-09-29 08:29 madsdyd Note Added: 0000296
2008-09-29 09:04 mtxd Note Added: 0000297
2008-09-29 09:13 mtxd Note Edited: 0000297
2008-09-29 09:18 mtxd Note Edited: 0000297
2008-09-29 09:41 mtxd Note Edited: 0000297
2008-09-29 09:44 mtxd Note Edited: 0000297
2008-09-29 10:06 madsdyd File Added: kdenliveBuilderWizard.rc
2008-09-29 10:06 madsdyd File Added: kbw-action.sh
2008-09-29 10:11 madsdyd Note Added: 0000298
2008-09-29 10:35 mtxd Note Added: 0000299
2008-09-29 10:35 mtxd File Added: kbw-log
2008-09-29 10:36 mtxd Note Edited: 0000299
2008-09-29 10:37 mtxd Note Edited: 0000299
2008-09-29 10:48 madsdyd Status feedback => closed
2008-09-29 10:48 madsdyd Note Added: 0000301
2008-09-29 10:48 madsdyd Resolution reopened => fixed
2008-11-12 23:00 madsdyd Fixed in Version Recent git => 0.7.0 beta


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker